AGB  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Dienst schließt sich automatisch

Ein Thema von KoRn117 · begonnen am 21. Nov 2003 · letzter Beitrag vom 24. Nov 2003
Antwort Antwort
Seite 1 von 2  1 2   
KoRn117

Registriert seit: 24. Sep 2003
Ort: Hessen
50 Beiträge
 
Delphi 7 Enterprise
 
#1

Dienst schließt sich automatisch

  Alt 21. Nov 2003, 18:39
Hallo,

also ich hab n Problem und zwar will ich mit Delphi 7 einen Dienst schreiben. Ich öffne das Standart Formular für "Service- Anwendung".
Sobald der Dienst startet schließt er sich gleich wieder obwohl noch ein zweiter Thread vorhanden ist indem ne schleife läuft, doch anscheinend überspringt der selbst das Ereignis OnStart - wenn ich dort nämlich ein "beep" reinschreibe passiert auch nix. Der Dienst wird nach ca.10 sek automatisch geschlossen egal was im quelltext steht. Bitte verweist NICHT auf das Tutorial von Assarbad(Ich möchte einen Timer etc verwenden)
Ich dachte es passt in die Sparte weil es sich ja nicht um Windows api Handelt.

Schonmal Danke für Antworten

Mfg

payne
  Mit Zitat antworten Zitat
Benutzerbild von sakura
sakura

Registriert seit: 10. Jun 2002
Ort: München
11.260 Beiträge
 
Delphi 2010 Architect
 
#2

Re: Dienst schließt sich automatisch

  Alt 21. Nov 2003, 19:13
Zitat von KoRn117:
Ich öffne das Standart Formular für "Service- Anwendung".
Was genau meinst Du damit Hast Du ein paar Code-Broken zum anschauen?

......
Daniel W.
Ich bin nicht zurück, ich tue nur so
  Mit Zitat antworten Zitat
KoRn117

Registriert seit: 24. Sep 2003
Ort: Hessen
50 Beiträge
 
Delphi 7 Enterprise
 
#3

Re: Dienst schließt sich automatisch

  Alt 23. Nov 2003, 12:20
ich weiß es nciht was "er" damit meinte ich habe diese frage für einen freund reingestellt
  Mit Zitat antworten Zitat
WtF

Registriert seit: 24. Nov 2003
Ort: Nähe München
72 Beiträge
 
FreePascal / Lazarus
 
#4

Re: Dienst schließt sich automatisch

  Alt 24. Nov 2003, 12:57
Ne sorry hab gerade keinen code Brocken da, aber vieleicht kannst du mir mal nen allgemeinen Tip geben, wie ich es hinbekomme, das nach dem starten des Projekts es NICHT automatisch geschlossen wird. Geh mal auf Neu->weitere...->TabSheet"Neu" ->Service- Anwendungen. Wenn man das dann einfach nur so startet hab ich ja volles verständnis dazu, das es sich nach kurzer zeit wieder schließt, aber wenn man ne schleife, in das ereignis onexecute haut (die sich garnicht beenden kann) beendet sich der dienst trotzdem nach ca.10 sekunden - warum??Was muss man machen damit dies nicht passiert?
Vieleicht n plan haben
Es gibt auch nicht wirklich viel die sich mit diensten beschäftigen so wie ich das sehe
mfg
Steffen
Was meinst du als unbeteiligter eigentlich zum Thema Intelligenz ? Keep it real, Respect!
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie
(Moderator)

Registriert seit: 29. Mai 2002
35.147 Beiträge
 
Delphi 2006 Professional
 
#5

Re: Dienst schließt sich automatisch

  Alt 24. Nov 2003, 14:12
Du musst den Service auch installieren / bekannt machen und dann musst du ihn starten über das Controlpanel für Dienste.
Michael
"Every language has an optimization operator. In Delphi that operator is: //"
  Mit Zitat antworten Zitat
Benutzerbild von sakura
sakura

Registriert seit: 10. Jun 2002
Ort: München
11.260 Beiträge
 
Delphi 2010 Architect
 
#6

Re: Dienst schließt sich automatisch

  Alt 24. Nov 2003, 14:14
Zitat von WtF:
Es gibt auch nicht wirklich viel die sich mit diensten beschäftigen so wie ich das sehe
Keine Sorge, ich habe mehrere davon im täglichen Einsatz. Aber wie Luckie schon sagte. Nachdem man einen Dienst installiert hat (pfad\dienst.exe /install) startet man diesen über die Diensteverwaltung (Systemsteuerung -> Verwaltung -> Dienste)

......
Daniel W.
Ich bin nicht zurück, ich tue nur so
  Mit Zitat antworten Zitat
WtF

Registriert seit: 24. Nov 2003
Ort: Nähe München
72 Beiträge
 
FreePascal / Lazarus
 
#7

Re: Dienst schließt sich automatisch

  Alt 24. Nov 2003, 14:43
Danke für die schnelle Antwort.
Das ich den Dienst mit /install installieren muss ist mir bekannt. Versteh ich das Richtig, das unter der Entwicklungsphase das Programm nicht ausgeführt werden kann?? Ich meine ja wenn ich das Projekt starte fliege ich nach n par sekunden und es reagiert auch auf garnix was im quelltext steht. Muss ich wirklich erst die Exe mit /install oder silent ausführen damit das Prog normal läuft? Das kann doch nicht sein
Steffen
Was meinst du als unbeteiligter eigentlich zum Thema Intelligenz ? Keep it real, Respect!
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie
(Moderator)

Registriert seit: 29. Mai 2002
35.147 Beiträge
 
Delphi 2006 Professional
 
#8

Re: Dienst schließt sich automatisch

  Alt 24. Nov 2003, 15:00
Das ist nun mal das Prinzip von Diensten. Sie werden ja vom Srvicemanager gesteuert und der kann seine Arbeit nur tun, wenn der Service installiert wurde.
Michael
"Every language has an optimization operator. In Delphi that operator is: //"
  Mit Zitat antworten Zitat
WtF

Registriert seit: 24. Nov 2003
Ort: Nähe München
72 Beiträge
 
FreePascal / Lazarus
 
#9

Re: Dienst schließt sich automatisch

  Alt 24. Nov 2003, 19:36
sorry ich glaube ich drücke mich ein wenig undeutlich aus.
Also wenn ich in Delphi gerade einen Dienst programmiere kann ich den nicht mit delphi ausführen (F9) sondern muss ihn kompilieren und mit /install erstmal installieren um zu sehen ob das so funktioniert wie ich will? Hab ich das jetzt richtig verstanden
Steffen
Was meinst du als unbeteiligter eigentlich zum Thema Intelligenz ? Keep it real, Respect!
  Mit Zitat antworten Zitat
Chewie

Registriert seit: 10. Jun 2002
Ort: Deidesheim
2.886 Beiträge
 
Turbo Delphi für Win32
 
#10

Re: Dienst schließt sich automatisch

  Alt 24. Nov 2003, 19:38
Zitat von WtF:
Hab ich das jetzt richtig verstanden
Ja. Aber du musst ihn nur einmal installieren.
Martin Leim
Egal wie dumm man selbst ist, es gibt immer andere, die noch dümmer sind
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 13:00 Uhr.
Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2014 by Daniel R. Wolf