AGB  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

F9 bzw Start Probleme

Ein Thema von hugo139 · begonnen am 15. Apr 2012 · letzter Beitrag vom 16. Apr 2012
Antwort Antwort
hugo139

Registriert seit: 12. Feb 2012
4 Beiträge
 
#1

F9 bzw Start Probleme

  Alt 15. Apr 2012, 10:41
Hallo Leute,
seit einiger Zeit muss ich immer, wenn ich kompilieren will, zweimal die F9 bzw. Start klicken, damit das Programm sofort startet und nicht erst bei der ersten Zeile im Quellcode stehen bleibt.

Hat einer eine Idee woran das liegen kann???
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu
Online

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
27.533 Beiträge
 
Delphi XE3 Professional
 
#2

AW: F9 bzw Start Probleme

  Alt 15. Apr 2012, 11:16
Interessant währe es zu wissen, um welche Delphi-Version und um welches Betriebssystem es sich handelt.

Ideen hab ich derzeit noch nicht.
Allerdings hatte ich vor 'ner Weile das umgekehrte Problem, da wurden beim ersten Mal, also kurz nach dem Kompilieren, die Debuginfos nicht richtig geladen und es gingen keine Haltepunkte.

Nach 'ner Woche war's von Alleine weg.
Und vorher hatte alles Mögliche, wie alle eigenen Packages (da wo unter Anderem auch die zu debuggende Unit drin steckte) neu zu kompilieren und neu zu installieren, leider nichts geholfen.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
hugo139

Registriert seit: 12. Feb 2012
4 Beiträge
 
#3

AW: F9 bzw Start Probleme

  Alt 15. Apr 2012, 12:13
Es ist Windows 7 und die Lazarus (IDE) 0.9.30.2.
Ich habe nun herausgefunden, dass es Projekt spezifisch ist. Bei einen neuen Projekt startet das Programm sofort, ohne in der .lpr –Datei anzuhalten. Aber die Projekteinstellungen sind gleich eingestellt.
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu
Online

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
27.533 Beiträge
 
Delphi XE3 Professional
 
#4

AW: F9 bzw Start Probleme

  Alt 15. Apr 2012, 12:32
Dann würde ich mal versuchen den Code in ein neues Projekt zu übernehmen.

Nja, ich weiß nicht in wie weit du alles verglichen hast, aber vielleicht stimmen die Einstellungen dennoch nicht überein.
Oder irgendwas im Programm verursacht dieses "Problem", bzw. es löst in dieser Kombination einen Fehler im Compiler oder Debugger aus.

Im Notfall, falls sich hier keine Lösung findet, hilft eventuelle eine Suche und Anfrage im Bugtracker auf http://forum.lazarus.freepascal.org oder in www.lazarusforum.de .


Vorallem das Lazarus sollte man in einem "Delphi"-Forum schon angeben.
Für spätere Fragen kann man seine Version im Profil angeben, damit sich die Beantworter darauf einstellen und ihre Antworten anpassen können.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014

Geändert von himitsu (15. Apr 2012 um 12:38 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von JamesTKirk
JamesTKirk

Registriert seit: 9. Sep 2004
Ort: Eberfing
581 Beiträge
 
FreePascal / Lazarus
 
#5

AW: F9 bzw Start Probleme

  Alt 15. Apr 2012, 13:06
Hallo Leute,
seit einiger Zeit muss ich immer, wenn ich kompilieren will, zweimal die F9 bzw. Start klicken, damit das Programm sofort startet und nicht erst bei der ersten Zeile im Quellcode stehen bleibt.

Hat einer eine Idee woran das liegen kann???
Vielleicht hast du noch irgendwo einen Breakpoint stehen, der nicht angezeigt wird. Dazu kannst du unter Ansicht => Debuggerfenster => Haltepunkte alle vorhandenen Haltepunkte betrachten und auch entfernen.

Sollte das nicht funktionieren, so probier doch mal folgendes:
Stell unter Projekt => Projekteinstellungen => Sitzung sicher, dass "lps-Datei im Projektverzeichnis anlegen" selektiert ist, schließe den Dialog und speichere das Projekt (eventuell in der Unit noch was Ändern, damit du auch wirklich speichern kannst).
Dann öffnest du entweder ein anderes Projekt oder schließt Lazarus und löscht die lps-Datei deines Projekts welche gerade angelegt wurde. Dadurch sollten alle Breakpoints, die in dem Projekt gesetzt waren, gelöscht sein (welche Dateien du offen hattest ist dann allerdings auch weg, sollte sich aber ja leicht wieder zusammenöffnen lassen ).

Gruß,
Sven
Sven
this post is printed on 100% recycled electrons
  Mit Zitat antworten Zitat
hugo139

Registriert seit: 12. Feb 2012
4 Beiträge
 
#6

AW: F9 bzw Start Probleme

  Alt 16. Apr 2012, 12:30
Habe den Fehler gefunden. Obwohl die IDE keine BreakPoints angezeigt hatte, sind in der .lpi Datei welche gewesen ist wahrscheinlich ein Bug der IDE.
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu
Online

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
27.533 Beiträge
 
Delphi XE3 Professional
 
#7

AW: F9 bzw Start Probleme

  Alt 16. Apr 2012, 13:51
In der IDE werden nur Haltepunkte angezeigt, welche auch zu einer Codezeile passen, bzw. zum Anfang eines Befehls.

Liegen diese nicht auf einem Befehl, dann kann dieser Befehl, bzw. dessen Codezeile, natürlich auch nicht markiert werden.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 17:55 Uhr.
Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2014 by Daniel R. Wolf