AGB  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Multimedia Delphi Linien auf TPicture.Bitmap.Canvas funktionieren nicht

Linien auf TPicture.Bitmap.Canvas funktionieren nicht

Ein Thema von hitzi · begonnen am 26. Jul 2005 · letzter Beitrag vom 26. Jul 2005
Antwort Antwort
Benutzerbild von hitzi
hitzi

Registriert seit: 2. Jan 2003
Ort: Eibau
768 Beiträge
 
Delphi 2010 Professional
 
#1

Linien auf TPicture.Bitmap.Canvas funktionieren nicht

  Alt 26. Jul 2005, 07:39
Hallo,

folgender Code zeichnet bei mir keine Linie:
Delphi-Quellcode:
[..]
var bmp : TPicture;
    jpg : TJPEGImage;
begin
[..]
  jpg := TJPEGImage.Create;
  bmp := TPicture.Create;
  try
    bmp.LoadFromFile(ExtractFilePath(ParamStr(0)) + 'dat\' + name + '.bmp');
    bmp.Bitmap.Canvas.Pen.Color := clBlack;
    bmp.Bitmap.Canvas.Pen.Style := psSolid;
    bmp.Bitmap.Canvas.Pen.Mode := pmNotXor;
    bmp.Bitmap.Canvas.MoveTo(0, 0);
    bmp.Bitmap.Canvas.LineTo(100, 100);

    jpg.Assign(bmp.Bitmap);
    jpg.SaveToFile(ExtractFilePath(ParamStr(0)) + 'temp\' + ExtractFileName(Filename) + '.jpg');
  finally
    FreeAndNil(bmp);
    FreeAndNil(jpg);
  end;
Ein bmp.Bitmap.Canvas.TextOut funktioniert jedoch und es wird ein Text in der gespeicherten JPG Datei angezeigt. Wo liegt mein Fehler?

Gruss
Thomas
Besucht doch mal http://www.hitziger.net
  Mit Zitat antworten Zitat
barf00s
(Gast)

n/a Beiträge
 
#2

Re: Linien auf TPicture.Bitmap.Canvas funktionieren nicht

  Alt 26. Jul 2005, 07:49
dann liegts vllt an dem falschen Pen.Mode -.-°
  Mit Zitat antworten Zitat
Benutzerbild von turboPASCAL
turboPASCAL

Registriert seit: 8. Mai 2005
Ort: Sondershausen
4.267 Beiträge
 
Delphi 6 Personal
 
#3

Re: Linien auf TPicture.Bitmap.Canvas funktionieren nicht

  Alt 26. Jul 2005, 08:05
Kann ich mir nicht vorstellen, der Code ist i.O. und die Linie wird auch gezeichnet.

pmNotXor zeichnet bei einmaligen Aufruf (der Linie) eine "Inversion" (Invertieren = Inversion ?) der Farben des Bildes.
Matti
Meine Software-Projekte - Homepage - Grüße vom Rüsselmops -Mops Mopser
  Mit Zitat antworten Zitat
Benutzerbild von hitzi
hitzi

Registriert seit: 2. Jan 2003
Ort: Eibau
768 Beiträge
 
Delphi 2010 Professional
 
#4

Re: Linien auf TPicture.Bitmap.Canvas funktionieren nicht

  Alt 26. Jul 2005, 08:10
Vergesst die Frage

Ich hatte die falschen Koordinaten und hab so immer an der falschen Stelle im Bild nach der Linie gesucht, welche wegem dem Hintergrund relativ schwer zu sehen ist. Außerdem hab ich auch noch den Mode in pmCopy geändert.

Nochmal ein dickes Sorry.
Thomas
Besucht doch mal http://www.hitziger.net
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 20:36 Uhr.
Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2014 by Daniel R. Wolf