AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Programmieren allgemein Problem beim Kopieren einer Bitmap in eine Image

Problem beim Kopieren einer Bitmap in eine Image

Ein Thema von thomas2009 · begonnen am 5. Mär 2011 · letzter Beitrag vom 6. Mär 2011
Antwort Antwort
thomas2009
(Gast)

n/a Beiträge
 
#1

Problem beim Kopieren einer Bitmap in eine Image

  Alt 5. Mär 2011, 23:07
Hi
ich möchte mein Image1.Bitmap in image2 kopieren
image1 ist 8Bit
Wenn ich image1.Bitmap in Image2 kopiere, dann bekomme ich 24Bit !

Ich kopiere (male) image1 in image 2 mit diesem Code :
Delphi-Quellcode:
Image2.Canvas.CopyRect(Rect0,0,
image2.picture.bitmap.Width,image2.picture.bitmap.Height),
image2.Canvas,Rect(0,0,image2.picture.bitmap.width, image2.picture.Bitmap.Height));
Was soll ich machen, damit die Tiffarbe beim Kopieren nicht sich ändert?
  Mit Zitat antworten Zitat
Capa

Registriert seit: 26. Okt 2003
102 Beiträge
 
RAD-Studio 2010 Arc
 
#2

AW: Problem beim Kopieren einer Bitmap in eine Image

  Alt 5. Mär 2011, 23:08
wieviele threads willst du den noch zu ein und dem selben thema erstellen ?
  Mit Zitat antworten Zitat
thomas2009
(Gast)

n/a Beiträge
 
#3

AW: Problem beim Kopieren einer Bitmap in eine Image

  Alt 5. Mär 2011, 23:17
Nachdem Du "8Bit" gesehen hast, hast Du gedacht, dass es um das gleiche Thema sich handelt ? Nein
Dies mal ist ganz anderes Problem
  Mit Zitat antworten Zitat
Capa

Registriert seit: 26. Okt 2003
102 Beiträge
 
RAD-Studio 2010 Arc
 
#4

AW: Problem beim Kopieren einer Bitmap in eine Image

  Alt 5. Mär 2011, 23:19
Im endeffekt ist es ein und das selbe thema Image und 8bit nur eine etwas
anders formulierte fragestellung.
  Mit Zitat antworten Zitat
Benutzerbild von rollstuhlfahrer
rollstuhlfahrer

Registriert seit: 1. Aug 2007
Ort: Ludwigshafen am Rhein
1.529 Beiträge
 
Delphi 7 Professional
 
#5

AW: Problem beim Kopieren einer Bitmap in eine Image

  Alt 5. Mär 2011, 23:29
Und was soll an dem Code-Schnipsel da oben jetzt nicht funktionieren, außer, dass eine Klammer fehlt?

Bernhard
Bernhard
Iliacos intra muros peccatur et extra!
  Mit Zitat antworten Zitat
Benutzerbild von Sir Rufo
Sir Rufo

Registriert seit: 5. Jan 2005
Ort: Stadthagen
9.454 Beiträge
 
Delphi 10 Seattle Enterprise
 
#6

AW: Problem beim Kopieren einer Bitmap in eine Image

  Alt 5. Mär 2011, 23:37
Image1 wird nicht kopiert, sondern auf den Canvas gemalt und von dort "abfotografiert".
Somit hat das Resultat die gleiche Farbtiefe wie Canvas

Dazu fällt mir nur noch ein: "Denn sie wissen nicht was sie tun"
Kaum macht man's richtig - schon funktioniert's
Zertifikat: Sir Rufo (Fingerprint: ‎ea 0a 4c 14 0d b6 3a a4 c1 c5 b9 dc 90 9d f0 e9 de 13 da 60)
  Mit Zitat antworten Zitat
Benutzerbild von Bummi
Bummi

Registriert seit: 15. Jun 2010
Ort: Augsburg Bayern Süddeutschland
3.470 Beiträge
 
Delphi XE3 Enterprise
 
#7

AW: Problem beim Kopieren einer Bitmap in eine Image

  Alt 6. Mär 2011, 08:24
Du kannst auf Dein Zielbitmap malen und danach das Pixelformat ändern, das Resultat wird aber bescheiden meist aussehen.
Thomas Wassermann H₂♂
Das Problem steckt meistens zwischen den Ohren
DRY DRY KISS
H₂ (wenn bei meinen Snipplets nichts anderes angegeben ist Lizenz: WTFPL)
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 12:03 Uhr.
Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2023 by Daniel R. Wolf, 2024 by Thomas Breitkreuz