AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

not a single group....

Offene Frage von "jobo"
Ein Thema von p80286 · begonnen am 11. Mär 2011 · letzter Beitrag vom 11. Mär 2011
Antwort Antwort
Benutzerbild von p80286
p80286

Registriert seit: 28. Apr 2008
Ort: Stolberg (Rhl)
6.658 Beiträge
 
Delphi 7 Personal
 
#1

not a single group....

  Alt 11. Mär 2011, 16:56
Datenbank: oracle • Version: 9 • Zugriff über: ADO
Hallo zusammen,

Nein ich weiß was die Fehlermeldung bedeutet, aber sie ist vollkommen sinnlos.
Die Fehlermeldung tritt bei folgendem SQL.Text auf:
Delphi-Quellcode:
  sql.Text:='select count(feld) from tabelle were feld1=:wert';
  Parameters.ParamByName('wert').Value:='WERT';
übergebe ich:
sql.Text:='select count(feld) from tabelle were feld1=''WERT'' '; läuft alles so wie es soll.

Bevor jemand fragt
Delphi-Quellcode:
  sql.Text:='select feld from tabelle were feld1=:wert';
  Parameters.ParamByName('wert').Value:='WERT';
liefert genau ein Feld (Fields.count) zurück.

Hat einer von Euch eine Idee was da falsch ist?

Gruß
K-H
Programme gehorchen nicht Deinen Absichten sondern Deinen Anweisungen
R.E.D retired error detector
  Mit Zitat antworten Zitat
jobo

Registriert seit: 29. Nov 2010
2.963 Beiträge
 
Delphi 2010 Enterprise
 
#2

AW: not a single group....

  Alt 11. Mär 2011, 17:04
Dein Select sieht so aus, als ob es nicht das ist, was die Probleme macht.
Ist es Absicht, dass Feldname in der select clause <> Feldname in der where clause ist?
Was ist mit den Feldtypen, ist das wirklich ein Textfeld?
Schonmal versucht den Parametertyp mit anzugeben?
Gruß, Jo
  Mit Zitat antworten Zitat
alzaimar
(Moderator)

Registriert seit: 6. Mai 2005
Ort: Berlin
4.956 Beiträge
 
Delphi 2007 Enterprise
 
#3

AW: not a single group....

  Alt 11. Mär 2011, 17:06
Woher soll Delphi wissen, das es sich beim Parameter um einen String handelt, der in Hochkommata eingeschlossen werden muss?
"Wenn ist das Nunstruck git und Slotermeyer? Ja! Beiherhund das Oder die Flipperwaldt gersput!"
(Monty Python "Joke Warefare")
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
16.900 Beiträge
 
Delphi 10.4 Sydney
 
#4

AW: not a single group....

  Alt 11. Mär 2011, 17:08
Welcher ADO-Provider wird verwendet? Falls der von MS so würde ich sagen das dieser den Fehler verursacht.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
Benutzerbild von p80286
p80286

Registriert seit: 28. Apr 2008
Ort: Stolberg (Rhl)
6.658 Beiträge
 
Delphi 7 Personal
 
#5

AW: not a single group....

  Alt 11. Mär 2011, 17:08
Dein Select sieht so aus, als ob es nicht das ist, was die Probleme macht.
Ist es Absicht, dass Feldname in der select clause <> Feldname in der where clause ist?
Ja ist es!
Was ist mit den Feldtypen, ist das wirklich ein Textfeld?
Schonmal versucht den Parametertyp mit anzugeben?
Das ist Text! aber den Typ mitgeben muß ich mal ausprobieren.

Gruß
K-H

Edith:
Welcher ADO-Provider wird verwendet? Falls der von MS so würde ich sagen das dieser den Fehler verursacht.
Mal den Teufel nicht an die wand (MSDORA)

Edith2:
@Bernhard
Danke das war's. mit
Code:
Provider=OraOLEDB.Oracle.1;
geht es!

Vielen Dank!
Programme gehorchen nicht Deinen Absichten sondern Deinen Anweisungen
R.E.D retired error detector

Geändert von p80286 (11. Mär 2011 um 17:17 Uhr)
  Mit Zitat antworten Zitat
jobo

Registriert seit: 29. Nov 2010
2.963 Beiträge
 
Delphi 2010 Enterprise
 
#6

AW: not a single group....

  Alt 11. Mär 2011, 17:23
Der MS-Provider für Oracle ist zwar out, aber so schlecht ist doch auch wieder nicht!
Gruß, Jo
  Mit Zitat antworten Zitat
Benutzerbild von p80286
p80286

Registriert seit: 28. Apr 2008
Ort: Stolberg (Rhl)
6.658 Beiträge
 
Delphi 7 Personal
 
#7

AW: not a single group....

  Alt 11. Mär 2011, 17:39
Wenn du einen Nachmittag fummelst und Fehler suchst wo keine sind
dann könnte man schon negativ denken!

Gruß
K-H
Programme gehorchen nicht Deinen Absichten sondern Deinen Anweisungen
R.E.D retired error detector
  Mit Zitat antworten Zitat
jobo

Registriert seit: 29. Nov 2010
2.963 Beiträge
 
Delphi 2010 Enterprise
 
#8

AW: not a single group....

  Alt 11. Mär 2011, 17:45
Er ist wirklich so schlecht, ich war nur verwundert, weil wir den selber lange eingesetzt haben und das nie aufgetreten ist.

Nur pro Forma:
Das Ding wird von MS nicht mehr gepflegt. Und der von Oracle ist mittlerweile ganz ok.
Gruß, Jo
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 02:28 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf