AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Fehler beim Öffnen eines Projekts

Ein Thema von Cordt · begonnen am 15. Feb 2014 · letzter Beitrag vom 14. Mai 2014
Antwort Antwort
Seite 1 von 2  1 2   
Cordt

Registriert seit: 10. Jan 2013
32 Beiträge
 
#1

Fehler beim Öffnen eines Projekts

  Alt 15. Feb 2014, 17:33
Hey Leute,

ich habe soeben auf einem 2. Rechner(Win 8.1) mein RADStudio (Delphi 2009 Architect) installiert, was auch problemlos funktioniert hat.
Möchte ich nun ein Projekt öffnen erhalte ich folgende Fehlermeldung, in dem Moment, in dem ich mit der Maus über der Form des Projekts bin, bzw ich die Maus dort hin bewege. Bleibe ich mit der Maus außerhalb der Form passiert nichts:

Fehler
Ungültige Zeigeroperation

Code:
[50006BAC]{rtl120.bpl } System.TObject.FreeInstance (Line 9787, "System.pas" + 2) + $2
[500041D2]{rtl120.bpl } System.ErrorAt (Line 4057, "System.pas" + 3) + $4
[50006BAC]{rtl120.bpl } System.TObject.FreeInstance (Line 9787, "System.pas" + 2) + $2
[500071BA]{rtl120.bpl } System.@ClassDestroy (Line 10609, "System.pas" + 0) + $2
[501269EE]{vcl120.bpl } Graphics.TFont.Destroy (Line 2296, "Graphics.pas" + 5) + $6
[50006BF4]{rtl120.bpl } System.TObject.Free (Line 9806, "System.pas" + 1) + $4
[501279F7]{vcl120.bpl } Graphics.TCanvas.Destroy (Line 3472, "Graphics.pas" + 4) + $3
[501CD99D]{vcl120.bpl } Controls.TControlCanvas.Destroy (Line 4484, "Controls.pas" + 2) + $7
[50006BF4]{rtl120.bpl } System.TObject.Free (Line 9806, "System.pas" + 1) + $4
[501DA4B1]{vcl120.bpl } Controls.TCustomControl.Destroy (Line 12700, "Controls.pas" + 1) + $6
[50006BF4]{rtl120.bpl } System.TObject.Free (Line 9806, "System.pas" + 1) + $4
[514ACE8E]{vcldesigner120.bpl} VCLSurface.TVclDesignSurface.CancelDragHint (Line 4078, "VCLSurface.pas" + 9) + $0
[514A92A0]{vcldesigner120.bpl} VCLSurface.TVclDesignSurface.InstanceRemoved (Line 2464, "VCLSurface.pas" + 1) + $2
[514AB74E]{vcldesigner120.bpl} VCLSurface.TVclDesignSurface.Notification (Line 3453, "VCLSurface.pas" + 17) + $6
[501EFFE7]{vcl120.bpl } Forms.TCustomForm.Notification (Line 3342, "Forms.pas" + 40) + $C
[20B97FD1]{designide120.bpl} Proxies.NotificationHook (Line 310, "Proxies.pas" + 8) + $B
[50056415]{rtl120.bpl } Classes.TComponent.Destroy (Line 11503, "Classes.pas" + 5) + $11
[501CE223]{vcl120.bpl } Controls.TControl.Destroy (Line 4834, "Controls.pas" + 24) + $7
[50006BAC]{rtl120.bpl } System.TObject.FreeInstance (Line 9787, "System.pas" + 2) + $2
[500071BA]{rtl120.bpl } System.@ClassDestroy (Line 10609, "System.pas" + 0) + $2
[50047554]{rtl120.bpl } Classes.TPersistent.Destroy (Line 4137, "Classes.pas" + 3) + $6
[501D2819]{vcl120.bpl } Controls.TWinControl.Destroy (Line 7749, "Controls.pas" + 30) + $7
[501DA4BD]{vcl120.bpl } Controls.TCustomControl.Destroy (Line 12701, "Controls.pas" + 2) + $7
[50006BF4]{rtl120.bpl } System.TObject.Free (Line 9806, "System.pas" + 1) + $4
[514ACE8E]{vcldesigner120.bpl} VCLSurface.TVclDesignSurface.CancelDragHint (Line 4078, "VCLSurface.pas" + 9) + $0
[514AC829]{vcldesigner120.bpl} VCLSurface.TVclDesignSurface.DragHintMouseMessage (Line 3926, "VCLSurface.pas" + 7) + $2
[514AAE4E]{vcldesigner120.bpl} VCLSurface.TVclDesignSurface.IsDesignMsg (Line 3151, "VCLSurface.pas" + 56) + $14
[50006F53]{rtl120.bpl } System.TObject.Dispatch (Line 10314, "System.pas" + 8) + $0
[50006DDA]{rtl120.bpl } System.@IsClass (Line 10084, "System.pas" + 1) + $8
[501D096B]{vcl120.bpl } Controls.TControl.WndProc (Line 6553, "Controls.pas" + 4) + $21
[501D5287]{vcl120.bpl } Controls.TWinControl.WndProc (Line 9334, "Controls.pas" + 136) + $6
[501D4A37]{vcl120.bpl } Controls.GetControlAtPos (Line 9086, "Controls.pas" + 4) + $13
[501D4B62]{vcl120.bpl } Controls.TWinControl.ControlAtPos (Line 9109, "Controls.pas" + 13) + $E
[501D0820]{vcl120.bpl } Controls.TControl.Perform (Line 6418, "Controls.pas" + 10) + $8
[501D4C17]{vcl120.bpl } Controls.TWinControl.IsControlMouseMsg (Line 9133, "Controls.pas" + 15) + $15
[501D5132]{vcl120.bpl } Controls.TWinControl.WndProc (Line 9289, "Controls.pas" + 91) + $6
[5000CB69]{rtl120.bpl } System.TInterfacedObject._AddRef (Line 21559, "System.pas" + 1) + $3
[501F0F88]{vcl120.bpl } Forms.TCustomForm.WndProc (Line 3902, "Forms.pas" + 191) + $5
[514AC648]{vcldesigner120.bpl} VCLSurface.TDesignerHintWindow.IsHintMsg (Line 3861, "VCLSurface.pas" + 1) + $74
[21CE402B]{delphivclide120.bpl} VCLFormContainer.TControlSizer.ControlWndProc (Line 306, "VCLFormContainer.pas" + 33) + $C
[5000CA9C]{rtl120.bpl } System.@IntfClear (Line 21411, "System.pas" + 7) + $0
[21CEBAA0]{delphivclide120.bpl} VCLFormDesigner.TVCLRootDesigner.IsHintMsg (Line 1430, "VCLFormDesigner.pas" + 5) + $10
[501D49A0]{vcl120.bpl } Controls.TWinControl.MainWndProc (Line 9063, "Controls.pas" + 3) + $6
[50057E04]{rtl120.bpl } Classes.StdWndProc (Line 12723, "Classes.pas" + 8) + $0
[501F9EAB]{vcl120.bpl } Forms.TApplication.ProcessMessage (Line 9613, "Forms.pas" + 23) + $1
[501F9EEE]{vcl120.bpl } Forms.TApplication.HandleMessage (Line 9643, "Forms.pas" + 1) + $4
[501FA219]{vcl120.bpl } Forms.TApplication.Run (Line 9780, "Forms.pas" + 26) + $3
[004259D2]{bds.exe    } bds.bds (Line 196, "" + 7) + $7
Und wenn es noch mehr Spass hat, dann kommen danach noch 2 Fehlermeldungen(eine in der gleichen Größe, eine die breiter ist), die keinerlei Text haben, kein Symbol, sondern nur ein x zum Schließen.
Ist das der Fall, dann schmiert die Entwicklungsumgebung ab.

Wenn nicht:
Beim Schließen kommen noch Zugriffsverletzungen in Modul 'vclide120.bpl'. Lesen von Adresse...

Wenn ich die Maus beim Öffnen von der Form weggehalten habe und andere Teile des Projektes öffne oder zuerst in den Quelltext gehe, dann gibts keine Fehler, auch wenn ich wieder auf die Hauptform zurückkehre. Auch nicht beim Schließen.


Hat jemand von Euch ne Ahnung was das sein könnte, woher das kommt und wie es wieder weggeht?

Lg Cordt
  Mit Zitat antworten Zitat
mkinzler
(Moderator)

Registriert seit: 9. Dez 2005
Ort: Heilbronn
39.830 Beiträge
 
Delphi 10.4 Sydney
 
#2

AW: Fehler beim Öffnen eines Projekts

  Alt 15. Feb 2014, 17:37
Hast du mal testweise versucht die IDE als Admin zu starten?
Markus Kinzler
  Mit Zitat antworten Zitat
Cordt

Registriert seit: 10. Jan 2013
32 Beiträge
 
#3

AW: Fehler beim Öffnen eines Projekts

  Alt 16. Feb 2014, 00:22
Ja, das verändert nichts.
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
8.495 Beiträge
 
Delphi 10.4 Sydney
 
#4

AW: Fehler beim Öffnen eines Projekts

  Alt 16. Feb 2014, 01:39
Passiert das bei allen Projekten? (Kann es an bestimmten Komponenten liegen?)
Hast du schon irgendwelche Addons drauf oder irgendwelche Einstellungen von Delphi geändert? (IDE Layout, ...)
Hast du alle Updates für Delphi eingespielt?

Passiert es auch mit dem IDE Fix Pack?
http://andy.jgknet.de/blog/ide-tools...-pack-2009-10/
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
Cordt

Registriert seit: 10. Jan 2013
32 Beiträge
 
#5

AW: Fehler beim Öffnen eines Projekts

  Alt 16. Feb 2014, 12:44
Bedauerlicherweise nur bei einem Projekt, welches diese Schwierigkeiten sonst auf keinem PC hat. Ich hab die Komponenten eig nahezu komplett von der Stadardpalette.
Keinerlei Addons oder Veränderungen.
Noch nicht mal den Delphi_2007_2009_WOW64_Debugger_Fix, welchen ich aber auch schon bei einer der Neuinstallationen mit getestet hatte.
Den Fix teste ich mal, dankesehr.
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
8.495 Beiträge
 
Delphi 10.4 Sydney
 
#6

AW: Fehler beim Öffnen eines Projekts

  Alt 16. Feb 2014, 13:34
Bedauerlicherweise nur bei einem Projekt, welches diese Schwierigkeiten sonst auf keinem PC hat. Ich hab die Komponenten eig nahezu komplett von der Stadardpalette.
Dann würde ich der Reihe nach die Komponenten herunterwerfen und schauen wann das Problem nicht mehr auftritt.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
Cordt

Registriert seit: 10. Jan 2013
32 Beiträge
 
#7

AW: Fehler beim Öffnen eines Projekts

  Alt 20. Feb 2014, 13:18
Aufgrund der Tatsache, dass ich den 2.Rechner wieder zum Verkäufer zurückschicken musste und dieses Modell nicht mehr beziehe, ist das Problem nun leider eins der unlösbaren.
Danke für die Hilfestellungen.
Lg Cordt
  Mit Zitat antworten Zitat
Cordt

Registriert seit: 10. Jan 2013
32 Beiträge
 
#8

AW: Fehler beim Öffnen eines Projekts

  Alt 8. Mai 2014, 11:23
Das Problem ist wieder aufgetreten, diesmal bei einem anderen Projekt. Dadurch konnte ich eingrenzen mit welchem Objekt es zusammenhängt.
Es handelt sich um ein stinknormales Image.
Wenn ich mit der Maus darauf komme, dann hagelt es Fehlermeldungen und die Entwicklungsumgebung schmiert ab.

Mit diesem Wissen komme ich leider auch nicht sehr viel weiter.
Was ist jetzt die Vorgehensweise, um dieses Problem zu lösen?
[Rückfragen kann ich frühestens nächste Woche beantworten, wenn das Gerät wieder hier ist]

Lg und danke
Cordt
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer

Registriert seit: 13. Aug 2002
17.103 Beiträge
 
Delphi 10.4 Sydney
 
#9

AW: Fehler beim Öffnen eines Projekts

  Alt 8. Mai 2014, 15:56
Es handelt sich um ein stinknormales Image.
Wenn ich mit der Maus darauf komme, dann hagelt es Fehlermeldungen und die Entwicklungsumgebung schmiert ab.
Ist das Image gefüllt? Tritt es auch auf wenn ein anderes Bild geladen wird?
Evtl. wurde hier ein "ungünstiges" image geladen das nicht ganz Format-Defintionskonform ist.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
hathor
(Gast)

n/a Beiträge
 
#10

AW: Fehler beim Öffnen eines Projekts

  Alt 8. Mai 2014, 17:35
Test: Ohne Debugger ausführen.

Wenn es dann KEINE Fehlermeldung mehr gibt, musst Du ein File austauschen:
vclide120.bpl

Original entfernen - im ganzen Laufwerk suchen!!!
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 01:25 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf