AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Netzwerke ForceDirectories geht mit Metzwerklaufwerk unter Win 10 nicht.

ForceDirectories geht mit Metzwerklaufwerk unter Win 10 nicht.

Ein Thema von just beginner · begonnen am 17. Jan 2019 · letzter Beitrag vom 22. Jan 2019
Antwort Antwort
just beginner

Registriert seit: 23. Feb 2007
Ort: Norddeutschland
20 Beiträge
 
Delphi 10.3 Rio
 
#1

ForceDirectories geht mit Metzwerklaufwerk unter Win 10 nicht.

  Alt 17. Jan 2019, 14:54
Hallö,

ich habe auf ein Windows10 64 Bit Rechner ein Netzwerklaufwerk eingebunden (Laufwerk Z).
Jetzt versuche mit meiner Anwendung (32 Bit und Adminrechte) mit System.SysUtils.ForceDirectories(Z:\bla\blaa) ein Verzeichnis zu erstellen. Rückgabewert von ForceDirectories ist false und Verzeichnis ist nicht erstellt.
ForceDirectories(C:\bla\bla) geht es aber.

Auf ein Windows 7 32 Bit Rechner geht auch ForceDirectories(Z:\bla\blaa).

Was mache ich falsch?
Frank
  Mit Zitat antworten Zitat
HolgerX

Registriert seit: 10. Apr 2006
Ort: Leverkusen
785 Beiträge
 
Delphi 6 Professional
 
#2

AW: ForceDirectories geht mit Metzwerklaufwerk unter Win 10 nicht.

  Alt 17. Jan 2019, 15:27
Hmm..

Ich gehe davon aus, das Z: ein Netzwerklaufwerk ist..

Wie hast Du dieses den gemapt?

Wenn dieses als normaler User/Admin (ohne elevated) erfolgt ist und Du dann als elevated Admin darauf versuchst zuzugreifen, dann wird dies scheitern, da Windows hier unterscheidet, ob User oder elevated User..
Dies sind für Windows 2 verschiedene Benutzer und nur der eine hat das Laufwerk gemapt..
  Mit Zitat antworten Zitat
just beginner

Registriert seit: 23. Feb 2007
Ort: Norddeutschland
20 Beiträge
 
Delphi 10.3 Rio
 
#3

AW: ForceDirectories geht mit Metzwerklaufwerk unter Win 10 nicht.

  Alt 17. Jan 2019, 15:35
Das Netzwerklaufwerk Z ist ist mit einem anderen Benutzer gemapt als der auf den Rechner angemeldet ist.
Der am Rechner angemeldete User hat Adminrechte.
Unter den Netzwerklaufwerkeigenschaften von Z: sehe ich das es für „Jeden“ aktiv ist.
Über den Explorer kann ich auch Verzeichnisse auf Z: anlegen.
Frank
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
7.210 Beiträge
 
Delphi XE4 Professional
 
#4

AW: ForceDirectories geht mit Metzwerklaufwerk unter Win 10 nicht.

  Alt 17. Jan 2019, 15:39
Hallo,
was sagt denn GetLastError?
Bestimmt "Zugriff verweigert" oder so ähnlich.

Über den Explorer kann ich auch Verzeichnisse auf Z: anlegen.
Wie rufst Du denn ForceDirectories im Explorer auf, wenn es dort ja gehen soll?
Verzeichnis anlegen <> ForceDirectories

Interessant ist folgender Thread, dort ganz unten,
wo steht, dass Delphi gar nicht die Windows-Funktion benutzt.
https://stackoverflow.com/questions/...-returns-false
Heiko

Geändert von hoika (17. Jan 2019 um 15:42 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Dalai
Dalai

Registriert seit: 9. Apr 2006
1.331 Beiträge
 
Delphi 5 Professional
 
#5

AW: ForceDirectories geht mit Metzwerklaufwerk unter Win 10 nicht.

  Alt 17. Jan 2019, 15:44
Netzlaufwerke waren schon immer (seit XP) nutzerspezifisch. Seit Vista trifft das sogar auf Netzlaufwerke zu, die in einem Programm verbunden wurden, das als Administrator (via UAC) läuft. Insofern sind Netzlaufwerke nicht nur nutzerspezifisch sondern an ein Token gebunden.

Wenn deine Anwendung unter einem anderen Nutzer läuft, wirst du das Laufwerk dort nochmal verbinden müssen. Das ließe sich übrigens ermitteln, indem du einfach prüfst, ob das Laufwerk bzw. Dateien darauf existieren, bevor du ForceDirectories machst . Die Anregung als Code:
Delphi-Quellcode:
if FileExists('Z:\bla\*.*') then
    ShowMessage('Da gibts was');
if ForceDirectories('Z:\bla') then
    ShowMessage('wurde angelegt');
Grüße
Dalai
  Mit Zitat antworten Zitat
HolgerX

Registriert seit: 10. Apr 2006
Ort: Leverkusen
785 Beiträge
 
Delphi 6 Professional
 
#6

AW: ForceDirectories geht mit Metzwerklaufwerk unter Win 10 nicht.

  Alt 17. Jan 2019, 15:47
Hmm..

Das Netzwerklaufwerk Z ist ist mit einem anderen Benutzer gemapt als der auf den Rechner angemeldet ist.
Der am Rechner angemeldete User hat Adminrechte.
Unter den Netzwerklaufwerkeigenschaften von Z: sehe ich das es für „Jeden“ aktiv ist.
Über den Explorer kann ich auch Verzeichnisse auf Z: anlegen.

Adminrechte <> Elevated..

Windows-Explorer wird (normalerweise) unelevated gestartet.
Starte den Elevated und das Z: ist nicht mehr vorhanden!

Mapping gilt immer nur für den User (elevated und unelevated sind VERSCHIEDENE User, auch bei gleichem Namen) der auch das Mapping ausgeführt hat!
  Mit Zitat antworten Zitat
just beginner

Registriert seit: 23. Feb 2007
Ort: Norddeutschland
20 Beiträge
 
Delphi 10.3 Rio
 
#7

AW: ForceDirectories geht mit Metzwerklaufwerk unter Win 10 nicht.

  Alt 18. Jan 2019, 10:20
Hallö,

das mit den Adminrechten und Elevated war das Problem. Danke HolgerX

Hier war ich die Lösung:

http://blog.adminweb.at/netzlaufwerk...icht-sichtbar/
https://docs.microsoft.com/en-us/pre...844140(v=ws.10)

Nach einem Neustart des Rechners das Netzwerklaufwerk nicht erreichbar(rotes Kreuz im Explorer)
Problem war das: https://www.borncity.com/blog/2018/0...netzlaufwerke/

Das hat geholfen:

https://windowsunited.de/loesung-win...htig-anzeigen/



Gruß
Frank

Geändert von just beginner (18. Jan 2019 um 11:11 Uhr)
  Mit Zitat antworten Zitat
generic

Registriert seit: 24. Mär 2004
Ort: bei Hannover
2.183 Beiträge
 
Delphi XE5 Professional
 
#8

AW: ForceDirectories geht mit Metzwerklaufwerk unter Win 10 nicht.

  Alt 21. Jan 2019, 13:27
In dem MS Link fehlt am Ende eine Klammer zu. Der Darstellungstext ist richtig.
https://docs.microsoft.com/en-us/pre...44140(v=ws.10)
  Mit Zitat antworten Zitat
just beginner

Registriert seit: 23. Feb 2007
Ort: Norddeutschland
20 Beiträge
 
Delphi 10.3 Rio
 
#9

AW: ForceDirectories geht mit Metzwerklaufwerk unter Win 10 nicht.

  Alt 22. Jan 2019, 07:44
Danke generic.
Frank
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 06:58 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf