AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Cross-Platform-Entwicklung [Fmx, Osx, VmWare] Mojave: Boot partition missing nach Absturz

[Fmx, Osx, VmWare] Mojave: Boot partition missing nach Absturz

Ein Thema von Rollo62 · begonnen am 20. Feb 2019 · letzter Beitrag vom 21. Feb 2019
Antwort Antwort
Rollo62

Registriert seit: 15. Mär 2007
2.014 Beiträge
 
Delphi 10.3 Rio
 
#1

[Fmx, Osx, VmWare] Mojave: Boot partition missing nach Absturz

  Alt 20. Feb 2019, 08:12
Hallo zusammen,

ich habe mal wieder ein seltsames Problem in meiner OSX-VM, die ich auf einer externen SSD-Platte laufen lasse.
- OSX-Mojave läuft auf VmWare
- Normalerweise ist dort kein Prozess besonders am Arbeiten, ist halt StandBy
- Lediglich zum Deployment auf iOS Gerät muss die VM etwas arbeiten
- Jetzt ist über Nacht der Host-Rechner runtergefahren, die Platte wurde ausgeworfen.
- Während des Absturzes war das OSX aber quasi ohne irgendeeine Last
- Das ist so ähnlich wie wenn ich am PC den Stecker ziehe
- Ist schonmal öfter passiert, ohne Probleme

Aber jetzt fehlt die Boot-Partition, ungefähr so wie hier beschrieben
https://discussions.apple.com/thread/8494156

Ich denke das liegt im Wesentlichen an OSX, was sich irgendwie nicht sauber absichert.
Könnte natürlich auch an VmWare liegen (VmWare Fusion 11.0.2), das beim Absturz irgendwas nicht sauber speichert.

Meine Frage ist, wie stabil ist OSX/Mojave (oder VmWare) eigentlich gegen solche PowerDown Abstürze ?
Eigentlich sollte soetwas doch nicht mehr passieren, oder kann man das Verhalten irgendwie verbessern ?

Jedenfalls ist es bei mir jetzt zum ersten Mal passiert, und da gehen gleich die Alarmglocken an

(Keine Sorge, ich habe Backups, ist aber trotzdem sehr ärgerlich).

Geändert von Rollo62 (20. Feb 2019 um 08:15 Uhr)
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
2.014 Beiträge
 
Delphi 10.3 Rio
 
#2

AW: [Fmx, Osx, VmWare] Mojave: Boot partition missing nach Absturz

  Alt 21. Feb 2019, 10:56
Habe den möglichen Fehler gefunden (zumindest könnte es das gewesen sein).

VmWare hat die Ausführung des Images gestoppt mit der Meldung "Speicherplatz voll, machen sie 137MB frei".

Die SSD-Festplatte wurde von VmWare als voll erkannt, obwohl lt. Finder noch 4GB frei waren,
das hatte wohl mit 137MB nicht mehr gereicht.
Das war seltsam, denn insgesamt waren aber noch 80GB frei, allerdings im Papierkorb.

Nach Leeren des Papierkorbes ging es dann auch weiter.

Also: Öfters mal den Papierkorb checken.
Andererseite habe ich immer gerne solche Dummy-Daten, die ich dann in so einem Fall einfach löschen kann.
Denn eine echte, volle Platte kann viel mehr Kopfzerbrechen machen.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 14:44 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf