AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Unerklärlicher Speicherfresser

Ein Thema von TurboMagic · begonnen am 26. Jun 2019 · letzter Beitrag vom 27. Jun 2019
Antwort Antwort
Seite 4 von 4   « Erste     234
peterbelow

Registriert seit: 12. Jan 2019
Ort: Hessen
355 Beiträge
 
Delphi 10.3 Rio
 
#31

AW: Unerklärlicher Speicherfresser

  Alt 27. Jun 2019, 10:20
Single steppen auf meinem PC (die anderen Tests waren gestern auf dem PC eines Kollegen) im Vergleich zu seinem PC ergibt, dass bei mir das DIsassembly an der LEA Stelle von GetMem einen JMP zeigt, bei ihm jedoch LEA.
Siehe screenshots.

Was passiert hier?
Was haben wir irgendwo während des Programmumbaus vermurkst, das uns den Speicher irgendwie ruiniert?
Wenn ihr den exakt gleichen Sourcecode auf zwei verschiedenen Rechnern kompiliert und dann solche Unterschiede im erzeugten Binärkode findet würde ich mal den Problemrechner sehr gründlich auf Malware prüfen. Vergleicht auch, was auf beiden Rechnern in der IDE als add-ons und sonstigen 3rd-party packages installiert ist.

Da die Diskrepanz in einem Kode-Segment auftritt kann es eigentlich kein einfacher memory overwrite zur Laufzeit sein, da Kode-Segmente ja dort read-only sind und daher ein Schreibversuch zu einer access violation führen müßte. Die Änderung muss also schon beim Kompilieren oder Linken der Anwendung erfolgen, aber halt nur auf deinem Rechner, nicht dem deines Kollegen. An den precompilierten dcus der RTL kann es nicht liegen, sonst würde der Fehler auch in deinem Testprogramm auftreten.
Peter Below
  Mit Zitat antworten Zitat
Benutzerbild von Stevie
Stevie

Registriert seit: 12. Aug 2003
Ort: Soest
3.543 Beiträge
 
Delphi 10.1 Berlin Enterprise
 
#32

AW: Unerklärlicher Speicherfresser

  Alt 27. Jun 2019, 10:26
Das Log sah eigentich völlig normal aus, keine ungewöhnlichen Allokationen und der erste Eintrag der medium block list passt auch zu deinem Record.
Keineswegs, man sieht, dass die ganzen 10 Byte allokationen nirgendwo zu finden, sind - der erste Block müsste mindestens 896 Allokationen aufweisen.

Single steppen auf meinem PC (die anderen Tests waren gestern auf dem PC eines Kollegen) im Vergleich zu seinem PC ergibt, dass bei mir das DIsassembly an der LEA Stelle von GetMem einen JMP zeigt, bei ihm jedoch LEA.
Ein Jump direkt als erste Anweisung, sieht nach einem Codepatch/Hook aus - Code mal durchsuchen danach (z.b. nach $E8 oder anderen Repräsentationen des jmp opcodes gefolgt von 4 Byte für die Zieladdresse) - suchen nach WriteProcessMemory kann auch was zutage fördern. Ob man einen Databreakpoint auf ausführbaren Speicher setzen kann, weiß ich nicht, aber wäre auch eine Möglichkeit den Verursacher zu finden.
Stefan
“Simplicity, carried to the extreme, becomes elegance.” Jon Franklin

Delphi Sorcery - DSharp - Spring4D - TestInsight
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 05:40 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf