AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Delphi Select funktioniert nicht

Select funktioniert nicht

Ein Thema von Luckner · begonnen am 18. Nov 2019 · letzter Beitrag vom 18. Nov 2019
Antwort Antwort
Luckner

Registriert seit: 28. Nov 2006
Ort: Berlin
366 Beiträge
 
Delphi 7 Enterprise
 
#1

Select funktioniert nicht

  Alt 18. Nov 2019, 13:50
Datenbank: MS-Access • Version: 2002 • Zugriff über: ADOQuery
Hallo Gemeinde,

ich versuche eine Select-Anweisung mit einer ADOQuery auf eine Access-Tabelle auszuführen und die lautet:
('select * from [Versandpreise DHL] where Zone = 0 order by Datum'). Beim ausführen dieser Anweisung erfolgt eine Fehlermeldung: "unbekannter Fehler beim ....". Ein ('select * from [Versandpreise DHL] order by Datum') funktioniert. Ein ('select * from [Versandpreise DHL] order by Zone') funktioniert nicht. Es liegt an "Zone". In der Tabelle ist es eine "Zahl" mit der Feldgrösse "Byte".

Wird das Feld mit der "Byte-Grösse) anders behandelt als Integer oder Andere?

Gruß, Luckner
  Mit Zitat antworten Zitat
Benutzerbild von sakura
sakura

Registriert seit: 10. Jun 2002
Ort: München
11.506 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#2

AW: Select funktioniert nicht

  Alt 18. Nov 2019, 13:54
Ändere mal nach:
Code:
select * from [Versandpreise DHL] where [Zone] = 0 order by Datum
ZONE ist ein reserviertes Wort (TIME ZONE)

......
Daniel W.
Ich bin nicht zurück, ich tue nur so
  Mit Zitat antworten Zitat
jobo

Registriert seit: 29. Nov 2010
2.678 Beiträge
 
Delphi 2010 Enterprise
 
#3

AW: Select funktioniert nicht

  Alt 18. Nov 2019, 13:55
Vielleicht ist "zone" schlicht ein reserviertes Wort.
Mach mal eckige Klammern drum oder wie das eben geht bei ACCESS.
Gruß, Jo
  Mit Zitat antworten Zitat
Luckner

Registriert seit: 28. Nov 2006
Ort: Berlin
366 Beiträge
 
Delphi 7 Enterprise
 
#4

AW: Select funktioniert nicht

  Alt 18. Nov 2019, 15:06
Vielen Dank,

wäre ich nie drauf gekommen. Man, und da sitze ich schon 2 Stunden dran. Danke

Luckner
  Mit Zitat antworten Zitat
Benutzerbild von sakura
sakura

Registriert seit: 10. Jun 2002
Ort: München
11.506 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#5

AW: Select funktioniert nicht

  Alt 18. Nov 2019, 15:09
wäre ich nie drauf gekommen. Man, und da sitze ich schon 2 Stunden dran
Es ist allgemein besser, alle eigenen Tabellen und Feldbezeichner in [zu packen], falls in zukünftigen Updates einer der Feldnamen doch als reserviertes Wort erkannt wird

......
Daniel W.
Ich bin nicht zurück, ich tue nur so
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 09:33 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf