AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Sprachen und Entwicklungsumgebungen Sonstige Fragen zu Delphi Delphi VCL Delphi XE7 seltsamer Fehler unter Windows 10 [18362]

VCL Delphi XE7 seltsamer Fehler unter Windows 10 [18362]

Ein Thema von Harry Stahl · begonnen am 2. Dez 2019 · letzter Beitrag vom 3. Dez 2019
Antwort Antwort
Benutzerbild von Harry Stahl
Harry Stahl

Registriert seit: 2. Apr 2004
Ort: Bonn
1.789 Beiträge
 
Delphi 10.3 Rio
 
#1

VCL Delphi XE7 seltsamer Fehler unter Windows 10 [18362]

  Alt 2. Dez 2019, 19:11
Habe ein VCL-Programm, das unter XE7 kompiliert wurde. Bei Verwendung von Styles kommt an einer Stelle eine Fehlermeldung (Out of Ressources), wenn einfach nur per Tab von einer Dropdownliste in ein Edit-Feld gesprungen werden soll. Da passiert gar nichts an der Stelle in meinem Programm, wie man dem anliegenden MAD-Except Protokoll entnehmen kann, findet der Fehler auch nicht in einer meiner Units statt, sondern in der VCl.Graphis (und zwar beim Zeichnen der TComboBox mit Style).

Ohne Styles tritt das Problem nicht auf.

Das gleich Programm läuft (auch mit Styles) ohne Probleme unter Windows 7 und Windows 10, Build 17134 (hatte ich noch auf einem Notebook zum Testen).

Wenn ich das betroffene Programmteil mit Delphi 10.3 kompiliere, tritt der Fehler nicht auf (kann leider das Programm im Moment nicht auf Delphi 10.3 umstellen).

Sieht mir alles nach einer eindeutigen Windows 10 Problematik aus (mangelnde Rückwärtskompatibilität?). Hat jemand evtl. schon davon gehört und kennt eine Abhilfe?
Miniaturansicht angehängter Grafiken
mad.jpg  
  Mit Zitat antworten Zitat
Benutzerbild von Harry Stahl
Harry Stahl

Registriert seit: 2. Apr 2004
Ort: Bonn
1.789 Beiträge
 
Delphi 10.3 Rio
 
#2

AW: VCL Delphi XE7 seltsamer Fehler unter Windows 10 [18362]

  Alt 3. Dez 2019, 00:09
Hab noch mal etwas genauer hingesehen:

War keine TComboBox, sondern eine TComboBoxEx, da gibt es anscheinend ein Windows 10 Kompatibilitätsprogramm.

Die brauch ich an der Stelle nicht, schnell durch eine TComboBox ersetzt und alles ist wieder gut...
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 14:12 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf