AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Swissbit DLL - Diverse Fragen

Ein Thema von hhcm · begonnen am 16. Dez 2019 · letzter Beitrag vom 27. Feb 2020
Antwort Antwort
Seite 6 von 6   « Erste     456
Madjid

Registriert seit: 28. Jul 2015
Ort: Oldenburg
16 Beiträge
 
Delphi 10.3 Rio
 
#51

AW: Swissbit DLL - Diverse Fragen

  Alt 26. Feb 2020, 17:46
Hallo und danke für die Antwort.

bei der Enwicklerkit habe ich kein Problem läuft immer noch mit:
// adminPuk = '123456';
// adminPin = '12345';
// timeAdminPin = '98765';
// credentialSeed = 'SwissbitSwissbit';
// CLIENT_ID = 'SwissbitDemo';

es geht um eine neue TSE, die noch nicht initiiert ist.

Selftest kommt mit Fehler "WORM_ERROR_CLIENT_NOT_REGISTERED" zurück.

der Setup danach liefert auch einen Fehler "WORM_ERROR_AUTHENTICATION_FAILED"
  Mit Zitat antworten Zitat
hhcm

Registriert seit: 12. Feb 2006
Ort: Wegberg
216 Beiträge
 
Delphi 10.3 Rio
 
#52

AW: Swissbit DLL - Diverse Fragen

  Alt 26. Feb 2020, 18:31
Wie gesagt der erste Selbsttest gibt IMMER den Fehler zurück, das steht auch so in der Doku.

Ist denn der CredentialSeed bei den "echten" TSE´s immer noch SwissbitSwissbit? Wenn sich dieser geändert hat bringt das nichts.
Chris
  Mit Zitat antworten Zitat
Madjid

Registriert seit: 28. Jul 2015
Ort: Oldenburg
16 Beiträge
 
Delphi 10.3 Rio
 
#53

AW: Swissbit DLL - Diverse Fragen

  Alt 26. Feb 2020, 19:11
Ja credentialSeed ist eine konstante ('SwissbitSwissbit'), habe ich nicht geändert.

hier sind meine Befehle und Rückmeldungen

worm_tse_runSelfTest: WORM_ERROR_CLIENT_NOT_REGISTERED
Failed to setup: WORM_ERROR_AUTHENTICATION_PIN_BLOCKED
Failed to factory reset: WORM_ERROR_CMD_NOT_FOUND
  Mit Zitat antworten Zitat
hhcm

Registriert seit: 12. Feb 2006
Ort: Wegberg
216 Beiträge
 
Delphi 10.3 Rio
 
#54

AW: Swissbit DLL - Diverse Fragen

  Alt 27. Feb 2020, 06:44
Ja credentialSeed ist eine konstante ('SwissbitSwissbit'), habe ich nicht geändert.
Die Frage ist, ist der Seed auch bei den echten TSE immer noch SwissbitSwissbit. Bei den Entwicklerkits war es so.

Einen Factory Reset gibt es für Endkunden nicht.

Da hilft jetzt nur mit der PUK den PIN ändern. Wenn das nicht geht dürfte das Ding nun ein Türstopper sein.
Chris
  Mit Zitat antworten Zitat
Neumann

Registriert seit: 6. Feb 2006
Ort: Moers
449 Beiträge
 
Delphi 10.3 Rio
 
#55

AW: Swissbit DLL - Diverse Fragen

  Alt 27. Feb 2020, 09:29
Einfach mal die 3 Schritte hintereinander ausführen:

Init
Selbsttest mit Fehler
Setup (mit Clientid setzten)
Dann Programm beenden und neu starten.

Dann mit der neuen Clientid auf die TSE zugreifen.
Ralf
Gruß vom Niederrhein
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 09:39 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf