AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Delphi Umlaute in Feldnamen werden nicht importiert - bricht ab

Umlaute in Feldnamen werden nicht importiert - bricht ab

Ein Thema von mcinternet · begonnen am 13. Mai 2020 · letzter Beitrag vom 14. Mai 2020
Antwort Antwort
Seite 3 von 3     123
Benutzerbild von p80286
p80286

Registriert seit: 28. Apr 2008
Ort: Stolberg (Rhl)
6.651 Beiträge
 
Delphi 7 Personal
 
#21

AW: Umlaute in Feldnamen werden nicht importiert - bricht ab

  Alt 14. Mai 2020, 11:59

Eigentlich wäre es sehr hilfreich, wenn der Datenlieferant mal kundtuen könnte, mit welchen Optionen, welchem Zeichensatz, ... er das Script erstellt.
Dir ist aber klar, das Du mit dieser Anforderung mindestens 60% aller "Programmierer" vollkommen überforderst?
Das ist erst einmal nicht sooo schlimm wenn man sich dessen bewusst ist. Kriminell wird es erst, wenn "Profies" nach dem Motto arbeiten, keine Fehlermeldung alles in Ordnung. Und dann tauchen dann irgendwann verstümmelte Daten und Texte auf die sich niemand erklären kann (es waren ja die Amateure im eigenen Hause nicht an den Daten).
Ich für mein Teil traue übrigens keiner Zeichensatzangabe, sondern mache wann immer möglich eine vollständige Datenanalyse und konvertiere die Daten per Hand (wofür hab ich Delphi, da bastelt man sich was man braucht selbst). Das mag aufwendig sein, aber dann ist hinterher wenigstens alles stimmig.

Gruß
K-H

P.S.
Wer Umlaute in Feldnamen benutzt ist mit Kreuzigen noch human behandelt.
Programme gehorchen nicht Deinen Absichten sondern Deinen Anweisungen
R.E.D retired error detector
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
35.861 Beiträge
 
Delphi 10.4 Sydney
 
#22

AW: Umlaute in Feldnamen werden nicht importiert - bricht ab

  Alt 14. Mai 2020, 12:11
Oder andersrum.

Den Praktikant die Daten importieren lassen, der importiert die Daten (z.B. UTF-8) als ANSI (ISOirgendwas), das geht alles ohne Probleme und ohne Fehlermeldungen, also alles Gut.




Aber die Umlaute in den Daten sind dann bissl kaputt.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
2.502 Beiträge
 
Delphi 10.3 Rio
 
#23

AW: Umlaute in Feldnamen werden nicht importiert - bricht ab

  Alt 14. Mai 2020, 12:12
und dabei geht das schon seit mindestens 10 Jahren
Dabei ist es witzig sein Program damit aufzuwerten.
Bei über 20 Tausend möglichen Zeichen, kannst jedem Bezeichner (Typen/Klassen, Properties, Variablen, Konstanten und Funktionsnamen) je ein Zeichen geben ... chinesisch bietet sich besonders an.

Schon ist dein Code schön kurz und extrem übersichtlich.

Bei Google suchenobfuscation
<WERBUNG>
Dabei fällt mir gerade eine neue Produkt-Idee ein (Ok, von JS geklaut).

Hat jemand Interessan einem PascalMinifier, mit "security by obfuscation" ?

Warum darf das nur JS, wer könnte einen Obfuscator für Pascal-Code gebrauchen ?
Das würde doch die OpenSource-Welt revolutionieren

Also, Bestellungen bitte an mich, die Marketing-Seite mit vielen Buzzwords ist leider gerade noch im Aufbau

</WERBUNG>
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
35.861 Beiträge
 
Delphi 10.4 Sydney
 
#24

AW: Umlaute in Feldnamen werden nicht importiert - bricht ab

  Alt 14. Mai 2020, 12:14
Hey, ich hatte mal aus Spaße in einer OpenSource-Komponente eine unsichtbare Variable verbaut, denn einige Space-Chars sind im Unicode/Compilier nicht als Space/Puncturation markiert.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
Delphi.Narium

Registriert seit: 27. Nov 2017
1.239 Beiträge
 
Delphi 7 Professional
 
#25

AW: Umlaute in Feldnamen werden nicht importiert - bricht ab

  Alt 14. Mai 2020, 12:43

Eigentlich wäre es sehr hilfreich, wenn der Datenlieferant mal kundtuen könnte, mit welchen Optionen, welchem Zeichensatz, ... er das Script erstellt.
Dir ist aber klar, das Du mit dieser Anforderung mindestens 60% aller "Programmierer" vollkommen überforderst?
60%?
Oh, Du unverbesserlicher Optimist

@himitsu
alt+255?

Ging auch schon zu Turbopascalzeiten (wenn ich mich recht erinnere)

Kennst Du noch die Computerzeitschrift DOS?
Da gab es mal lange Zeit 'nen Wettbewerb über eine Kilo-Mark (1024 DM) als Preisgeld.
Aufgabe war es, ein möglichst sinnvolles Programm in maximal 1024 Byte Quelltext zu packen.

Da waren dann kurze (sehr kurze) Variabel-, Funktions- ... -Namen wesentlich. Auf Leerzeichen, Zeilenumbrüche (immerhin jeweils 2 Byte) wurde verzichtet ...

Das war dann Obfuscation in Reinkultur

@mcInternet

Latin1 kommt mit 'Am_Pr\xFCffrequ' zurecht?

Kann ich mir nicht ernsthaft vorstellen. Da ist garantiert noch "irgendeine Übersetzungsstelle" dazwischen, die Dir momentan potentielle Probleme behebt. Ob das dauerhaft gutgehen wird?

Witzig wäre in dem Zusammenhang zu erfahren, ob das ü eventuell nur in diversen Anzeigetools zu sehen ist, die ein \xFC implizit bei der Anzeige übersetzen.
Nicht dass in der Quelldatenbank der Spaltenname tatsächlich 'Am_Pr\xFCffrequ' lautet und nicht, wie erwartet 'Am_Prüffrequ'.
Würde das auf jeden Fall mal prüfen, auch wenn die Idee jetzt erstmal etwas "abgefahren" klingt.
  Mit Zitat antworten Zitat
mcinternet

Registriert seit: 22. Apr 2010
Ort: Odenwald
188 Beiträge
 
Delphi 10.3 Rio
 
#26

AW: Umlaute in Feldnamen werden nicht importiert - bricht ab

  Alt 14. Mai 2020, 12:46
@mcInternet

Latin1 kommt mit 'Am_Pr\xFCffrequ' zurecht?

Kann ich mir nicht ernsthaft vorstellen. Da ist garantiert noch "irgendeine Übersetzungsstelle" dazwischen, die Dir momentan potentielle Probleme behebt. Ob das dauerhaft gutgehen wird?

Witzig wäre in dem Zusammenhang zu erfahren, ob das ü eventuell nur in diversen Anzeigetools zu sehen ist, die ein \xFC implizit bei der Anzeige übersetzen.
Nicht dass in der Quelldatenbank der Spaltenname tatsächlich 'Am_Pr\xFCffrequ' lautet und nicht, wie erwartet 'Am_Prüffrequ'.
Würde das auf jeden Fall mal prüfen, auch wenn die Idee jetzt erstmal etwas "abgefahren" klingt.
Der kommt damit auf jeden Fall zurecht, übersetzt es auch korrekt. Ich werde es in der finalen Version der Software abstellen und mit ue arbeiten. Ich baue sowas in mein Importproggi ein. Damit sollte es dann Geschichte sein.

beste Grüße

mcinternet
Jörg
  Mit Zitat antworten Zitat
Delphi.Narium

Registriert seit: 27. Nov 2017
1.239 Beiträge
 
Delphi 7 Professional
 
#27

AW: Umlaute in Feldnamen werden nicht importiert - bricht ab

  Alt 14. Mai 2020, 12:53
@mcInternet

Latin1 kommt mit 'Am_Pr\xFCffrequ' zurecht?

Kann ich mir nicht ernsthaft vorstellen. Da ist garantiert noch "irgendeine Übersetzungsstelle" dazwischen, die Dir momentan potentielle Probleme behebt. Ob das dauerhaft gutgehen wird?

Witzig wäre in dem Zusammenhang zu erfahren, ob das ü eventuell nur in diversen Anzeigetools zu sehen ist, die ein \xFC implizit bei der Anzeige übersetzen.
Nicht dass in der Quelldatenbank der Spaltenname tatsächlich 'Am_Pr\xFCffrequ' lautet und nicht, wie erwartet 'Am_Prüffrequ'.
Würde das auf jeden Fall mal prüfen, auch wenn die Idee jetzt erstmal etwas "abgefahren" klingt.
Der kommt damit auf jeden Fall zurecht, übersetzt es auch korrekt. Ich werde es in der finalen Version der Software abstellen und mit ue arbeiten. Ich baue sowas in mein Importproggi ein. Damit sollte es dann Geschichte sein.

beste Grüße

mcinternet
Sorry, wenn ich da nochmal nachhake:

Zurechtkommen heißt für mich, dass es momentan geht, aber nicht das es dauerhaft geht. Da bleibt dann ein Risiko.

Für 'nen Datenbankkonvertierung, die einmalig gemacht werden muss, um System A durch System B zu ersetzen, ist das absolut ok. Für einen Dauerbetrieb nicht.

Und das Umbauen das alten System auf ein System ohne ü ... im Importproggi ist eine sehr weise Entscheidung. Hut ab. Denn sowas machen nur die wenigsten aus eigener Entscheidung (zumindest bezogen auf die Programmierer, Datenbankentwickler, ..., die ich im Laufe meines Berufslebens haben kennen lernen dürfen - daher auch meine ironische Kritik an den 60% von p80286 )
  Mit Zitat antworten Zitat
mcinternet

Registriert seit: 22. Apr 2010
Ort: Odenwald
188 Beiträge
 
Delphi 10.3 Rio
 
#28

AW: Umlaute in Feldnamen werden nicht importiert - bricht ab

  Alt 14. Mai 2020, 13:08

Zurechtkommen heißt für mich, dass es momentan geht, aber nicht das es dauerhaft geht. Da bleibt dann ein Risiko.

Für 'nen Datenbankkonvertierung, die einmalig gemacht werden muss, um System A durch System B zu ersetzen, ist das absolut ok. Für einen Dauerbetrieb nicht.

Und das Umbauen das alten System auf ein System ohne ü ... im Importproggi ist eine sehr weise Entscheidung. Hut ab. Denn sowas machen nur die wenigsten aus eigener Entscheidung (zumindest bezogen auf die Programmierer, Datenbankentwickler, ..., die ich im Laufe meines Berufslebens haben kennen lernen dürfen - daher auch meine ironische Kritik an den 60% von p80286 )
Am bestehenden Produktivsystem (Delphi 7) habe ich keinerlei Chance irgendwas zu ändern. Das Ding läuft, läuft, pfeift aus dem letzten Loch. Valider compilierfähiger Quellcode ist auch nicht mehr vorhanden. Da haben später viele dran verschlimmbessert und versucht auf neuere Versionen zu heben, bis hin nach XE, was aber dann nie lief, nicht einmal, bzw. nur ein Teilen compilierfähig ist und nie produktiv ging. Es ist auch auf 1000 einzelne DLLs aufgeteilt. Somit läuft das bestehende System seit ~2003. Daher entwickle ich auf Basis der alten Formulare einen komplett neuen Unterbau. Dazu existiert meine Entwicklungsumgebung und eine Labor-/Testumgebung beim Kunden. Um eben alle Daten (es ist ein sehr spezifisches ERP-System mit bis jetzt über 110 Formularen, 330.000 Zeilen Code - das wird sich noch verdoppeln!) übernehmen zu können, habe ich ein Importprogramm gebaut, welches auch ALLE Veränderungen in der Datenbank macht. Bis jetzt sind es 133 Änderungen in der Datenbank. Damit ich das nicht alles beim Live-Gehen händisch machen muss (wäre dann auch zu fehlerbehaftet), mache ich das über dieses Import-/Konvertierprogramm, welches Bestandteil des ERP-Systemes ist: Beim Start werden Software- und Datenbankversion abgeglichen und noch bevor das Anmeldeformular erscheint, werden die notwendigen Updates gemacht. Somit sind alle Fehlerquellen ausgemerzt, da ich das ja in der Entwicklungsumgebung so teste und ansonsten nicht starten kann. Also ist der Import dann wirklich 100% fehlerfrei, da ich ja auch einmal im Monat die Daten vom Produktivsystem ziehe.

beste Grüße

mcinternet
Jörg
  Mit Zitat antworten Zitat
Benutzerbild von p80286
p80286

Registriert seit: 28. Apr 2008
Ort: Stolberg (Rhl)
6.651 Beiträge
 
Delphi 7 Personal
 
#29

AW: Umlaute in Feldnamen werden nicht importiert - bricht ab

  Alt 14. Mai 2020, 20:22
Beim Start werden Software- und Datenbankversion abgeglichen und noch bevor das Anmeldeformular erscheint, werden die notwendigen Updates gemacht. Somit sind alle Fehlerquellen ausgemerzt, da ich das ja in der Entwicklungsumgebung so teste und ansonsten nicht starten kann. Also ist der Import dann wirklich 100% fehlerfrei, da ich ja auch einmal im Monat die Daten vom Produktivsystem ziehe.
Ich nehme zu Deinen Gunsten mal an, daß Du ungeschickt formuliert hast. Alleine 100% Fehlerfreihet ist schon sehr ambitioniert. Und auch die anderen Folgerungen sind doch sehr gewagt.

@Delphi.Natrium
Unverbesserlicher Optimist?? Hier lesen genug Lernwillige mit, da erreichen wir die 60% bestimmt irgendwann

Gruß
K-H
Programme gehorchen nicht Deinen Absichten sondern Deinen Anweisungen
R.E.D retired error detector
  Mit Zitat antworten Zitat
mcinternet

Registriert seit: 22. Apr 2010
Ort: Odenwald
188 Beiträge
 
Delphi 10.3 Rio
 
#30

AW: Umlaute in Feldnamen werden nicht importiert - bricht ab

  Alt 14. Mai 2020, 20:28
Ich nehme zu Deinen Gunsten mal an, daß Du ungeschickt formuliert hast. Alleine 100% Fehlerfreihet ist schon sehr ambitioniert. Und auch die anderen Folgerungen sind doch sehr gewagt.
Gruß
K-H
Die Datenbankanpassung, sowie der Import laufen zu 100% fehlerfrei. Das gesamte System mit Sicherheit nicht.

Gruss

mcinternet
Jörg
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 01:39 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf