AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Sprachen und Entwicklungsumgebungen Object-Pascal / Delphi-Language Problem mit TRESTClient/TRESTResponse und Authentifizierung (GELÖST!)

Problem mit TRESTClient/TRESTResponse und Authentifizierung (GELÖST!)

Ein Thema von freejay · begonnen am 9. Jun 2020 · letzter Beitrag vom 9. Jun 2020
Antwort Antwort
freejay

Registriert seit: 26. Mai 2004
Ort: Nürnberg
203 Beiträge
 
Delphi 10.3 Rio
 
#1

Problem mit TRESTClient/TRESTResponse und Authentifizierung (GELÖST!)

  Alt 9. Jun 2020, 10:48
Delphi-Version: 5
Hallo zusammen,

ich hänge beim Versuch Daten von einem Webservice mittels der REST-Komponenten abzurufen.

Zur Authentifizierung muss nur ein Header-Parameter "Authorization" mit einem bestimmten Wert abgestellt werden. Ansonsten muss nur eine URL aufgerufen werden - ohne weitere Parameter oder so.

Ich habe das in Postman mal ausprobiert und es funktioniert problemlos - ohne dass man noch irgendwas irgendwie extra einstellen müsste.

Ich habe in Delphi im RESTClient die BaseURL eingetragen, in den Parametern den für die Authentifizierung nötigen Header-Parameter "Authorization" eingetragen, aber es kommt immer ein 401 Fehler.

Was mache ich hier falsch bzw. habe ich vergessen zu tun?

Vielen Dank im Vorraus!

Gruß

Freejay

PS: Im Anhang ein Bild mit den Einstellungen in Delphi und Postman (und dem erfolgreichem Ergebnis im Postman...).
Miniaturansicht angehängter Grafiken
restclientproblem.jpg  
[Delphi 10.3.2 Rio Enterprise; Win10; MySQL; VCL]

Geändert von freejay ( 9. Jun 2020 um 12:04 Uhr)
  Mit Zitat antworten Zitat
Bbommel

Registriert seit: 27. Jun 2007
Ort: Köln
500 Beiträge
 
Delphi 10.3 Rio
 
#2

AW: Problem mit TRESTClient/TRESTResponse und Authentifizierung

  Alt 9. Jun 2020, 11:13
Etwas ähnliches hatten wir neulich erst hier.

Die Lösung des damaligen Problems ist dann im letzten Post ganz gut zusammengefasst, entscheidend damals war vor allem, der Parameter [TRESTRequestParameterOption.poDoNotEncode] , damit nicht irgendein Encoding auf deinen Schlüssel angewendet wird.

Vielleicht hilft dir das ja auch schon.
  Mit Zitat antworten Zitat
freejay

Registriert seit: 26. Mai 2004
Ort: Nürnberg
203 Beiträge
 
Delphi 10.3 Rio
 
#3

AW: Problem mit TRESTClient/TRESTResponse und Authentifizierung

  Alt 9. Jun 2020, 11:56
Das hat tatsächlich geholfen! Super!

Danke Bbommel!

[Delphi 10.3.2 Rio Enterprise; Win10; MySQL; VCL]
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 18:12 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf