AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Problem bei Programmstart - (0xc000007b)

Ein Thema von Tom-Tom · begonnen am 15. Jul 2020 · letzter Beitrag vom 16. Jul 2020
Antwort Antwort
Seite 4 von 4   « Erste     234
Tom-Tom

Registriert seit: 19. Apr 2010
Ort: Remscheid
21 Beiträge
 
#31

AW: Problem bei Programmstart - (0xc000007b)

  Alt 15. Jul 2020, 14:28
Die gesamte VM habe ich speziell für 10.4 neu erstellt. Also hab ich natürlich auch bei allen Komponenten darauf geachtet,
dass sie für 10.4 freigegeben sind.
Danach dann das 10.3er Projekt in einen neuen Ordner kopiert, die DCUs etc gelöscht, die BPls von 10.3 gegen die von 10.4 ersetzt.
(also z.B. vcl260.* gegen vcl270.*) und die Projektdatei (.dproj) gelöscht.
Danach die Projekt Optionen neu eingegeben (hauptsächlich "Runtime packages", 5 Stk. von denen wie in der 10.3)

Dann das Projekt compiliert und fertig. Auf der VM läuft es 1a.

Ich wüsste nicht, was ich da falsch gemacht haben sollte...
  Mit Zitat antworten Zitat
TiGü

Registriert seit: 6. Apr 2011
Ort: Berlin
2.408 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#32

AW: Problem bei Programmstart - (0xc000007b)

  Alt 15. Jul 2020, 14:36
1. Hast du das Kompilat aus der VM mal auf dem Problemrechner getestet?
2. Hast du TMS deswegen schon kontaktiert?
  Mit Zitat antworten Zitat
Tom-Tom

Registriert seit: 19. Apr 2010
Ort: Remscheid
21 Beiträge
 
#33

AW: Problem bei Programmstart - (0xc000007b)

  Alt 15. Jul 2020, 14:38
Die 10.3er Version läuft überall, die 10.4er nur auf der VM. Auf anderen Maschinen tut sich nix - bis auf die Fehlermeldung.

TMS hat heute eine neue Version dieser Komponenten rausgebracht. Die installiere ich gerade...
  Mit Zitat antworten Zitat
Tom-Tom

Registriert seit: 19. Apr 2010
Ort: Remscheid
21 Beiträge
 
#34

AW: Problem bei Programmstart - (0xc000007b)

  Alt 15. Jul 2020, 15:01
LÄUFT !

Nach der Installation der neuesten TMS Komponenten verlangte die Anwendung noch eine weitere BPL Datei
(vclsmp270.bpl) und dann funktionierte es !


HABT VIELEN DANK !!!

Speziell an TiGü, Du hast echt lange durchgehalten ! 1A Leistung !!!

Das soll aber auch nicht die Ideen der "anderen" hier im Forum schmälern !

OHNE EUCH hätte ich es wohl nicht auf die Kette bekommen.

Also nochmals VIELEN, VIELEN DANK AN EUCH ALLE !!!
  Mit Zitat antworten Zitat
Benutzerbild von Sherlock
Sherlock

Registriert seit: 10. Jan 2006
Ort: Offenbach
3.513 Beiträge
 
Delphi 10.3 Rio
 
#35

AW: Problem bei Programmstart - (0xc000007b)

  Alt 15. Jul 2020, 15:17
Packages haben wohl ihre Vorteile, aber ich liebe die Möglichkeit eine monolithische Anwendung ausliefern zu können, die zur Not ohne Installer "installiert" werden kann. Die IT meiner Kunden liebt es übrigens auch, nur eine EXE austauschen zu müssen.

Sherlock
Geändert von Sherlock (Morgen um 16:78 Uhr) Grund: Weil ich es kann
  Mit Zitat antworten Zitat
Benutzerbild von Dalai
Dalai

Registriert seit: 9. Apr 2006
1.486 Beiträge
 
Delphi 5 Professional
 
#36

AW: Problem bei Programmstart - (0xc000007b)

  Alt 15. Jul 2020, 16:11
Noch zwei Tips fürs nächste Mal:
  • Screenshots sind in fast allen Fällen im Format PNG besser aufgehoben, damit sind sie kleiner und ohne JPG-Artefakte. Zum anderen wäre es gut, wenn Screenshots in der Originalgröße hochgeladen werden. Die Schrift auf deinem Bild kann man nur unter Schwierigkeiten lesen (hätte ich Augenprobleme oder so würde ich wohl gar nichts mehr entziffern können).

  • Noch besser als Screenshots sind ggf. Kopien der Inhalte. Auch im Process Monitor kann man Zeilen markieren und mit Strg+C kopieren. Das als Code ins Forum und jeder kann sich den Text so groß machen wie nötig, und dadurch werden die Inhalte sogar durchsuchbar.

Grüße
Dalai
  Mit Zitat antworten Zitat
TiGü

Registriert seit: 6. Apr 2011
Ort: Berlin
2.408 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#37

AW: Problem bei Programmstart - (0xc000007b)

  Alt 15. Jul 2020, 16:30

HABT VIELEN DANK !!!

Speziell an TiGü, Du hast echt lange durchgehalten ! 1A Leistung !!!
  Mit Zitat antworten Zitat
Tom-Tom

Registriert seit: 19. Apr 2010
Ort: Remscheid
21 Beiträge
 
#38

AW: Problem bei Programmstart - (0xc000007b)

  Alt 16. Jul 2020, 07:23
@Dalai: Du hast recht, beim nächsten Mal werde ich das als Code einfügen.

@Sherlock: Das wäre auch mein Wunsch, aber da meine Anwendung PlugIns verwendet, die sich automatisch in die Anwendung einklinken, bleibt mir leider keine Wahl. (Ich verwende die HYDRA Komponenten von RemObjects, eine andere Möglichkeit kenne ich nicht)

Also nochmals ein großes DANKE an alle Beteiligten hier !!

Tom
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 11:03 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf