AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Mailversand funktioniert nicht

Ein Thema von haentschman · begonnen am 18. Feb 2021 · letzter Beitrag vom 19. Feb 2021
Antwort Antwort
Seite 2 von 2     12
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.669 Beiträge
 
Delphi 10.1 Berlin Professional
 
#11

AW: Mailversand funktioniert nicht

  Alt 18. Feb 2021, 15:14
Zitat:
Würde der SMTP-Server, über den du es verschickst, das Mail blockieren, müsstest du berites beim Abschicken einen Fehler erhalten.
...genau. Da ist aber keine Meldung.
Host=securesmtp.t-online.de
  Mit Zitat antworten Zitat
venice2

Registriert seit: 5. Dez 2019
Ort: Köln
503 Beiträge
 
Delphi 2010 Architect
 
#12

AW: Mailversand funktioniert nicht

  Alt 18. Feb 2021, 15:31
Zitat:
Würde der SMTP-Server, über den du es verschickst, das Mail blockieren, müsstest du berites beim Abschicken einen Fehler erhalten.
...genau. Da ist aber keine Meldung.
Host=securesmtp.t-online.de
secureimap.t-online.de ?
sorry war quatsch.

Geändert von venice2 (19. Feb 2021 um 00:16 Uhr)
  Mit Zitat antworten Zitat
Delphi.Narium

Registriert seit: 27. Nov 2017
1.542 Beiträge
 
Delphi 7 Professional
 
#13

AW: Mailversand funktioniert nicht

  Alt 18. Feb 2021, 15:37
Mailheader aus David anschauen und den mit dem aus Deinem Programm vergleichen.

Z. B. https://www.verbraucherzentrale.de/w...ailheader-6077
https://www.mailjet.de/blog/news/email-header/
https://www.antispam-ev.de/wiki/EMai...lscht%20werden.

Was hat David, was Deine Software nicht hat bzw. umgekehrt.

Es soll Mailserver geben, die da auf bestimmte Sachen achten, ob vorhanden oder ob nicht vorhanden und daran erkennen, dass der Absender ein Spammer sein könnte oder eben auch nicht.

Sprich: Es könnte sein, dass in diesem Bereich Deine Software irgendwelchen Anforderungen (beim Versand mit Anhängen) nicht genügt, denen David aber genügt.

Zitat:
...nochmal geschaut. Der Spam Ordner, und alle anderen Ordner der Empänger Mail, sind auf dem Empänger Server (Telekom) leer.
Das reicht nicht zwingend, früher (vor gefühlt 15 Jahren) hat unser Exchange-Server die Mails bereits vorher grob nach Spam / nicht Spam aussortiert, also bevor sie in den Bereich des Mailservers kamen, in die man als Nutzer einsehen kann.
Die Mails lagen dann auf der Festplatte (Textdatei im Filesystem) des Exchange-Servers in einem definierten Ordner (Verzeichnis UCEArchive), quasi noch vor der Haustüre und noch nicht hinter der Haustüre, geschweigedenn in einem Schrank der Postverteilanlage (Briefkästen). (Ausserhalb des über die Administration des Exchangeservers erreich- bzw. einsehbaren Bereiches.)

Aber: Wenn die Mails und die Anhänge aus Deinem Programm heraus oder über David verschickt identisch sind, sollte hier bei beiden das gleiche Verhalten seitens des Mailservers zu erwarten sein.

Ansonsten:

Mach aus den Mailanhängen bitte mal Zips und schau, ob die aus Deinem Programm heraus dann ankommen.

Dann hält sich eventuell "irgendwer unterwegs" an diese Regeln: https://www.secumail.de/2016/05/10/e...ie-blockieren/

Kannst Du eine Mail aus Deinem Programm heraus an 'nen Freemailaccount bei Web.de, GMail, Yahoo, oder was auch immer, verschicken? Gleiches Problem? Wenn nein, dann ist die Ursache beim Empfängerserver der Telekom zu suchen.
  Mit Zitat antworten Zitat
Benutzerbild von ULIK
ULIK

Registriert seit: 25. Sep 2006
Ort: Regensburg
368 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#14

AW: Mailversand funktioniert nicht

  Alt 18. Feb 2021, 15:42
Mailversand aus dem Programm heraus mit TclSmtp: ...

Der Wrapper gibt keine Fehlermeldung beim Versenden aus. (FMail.Send(FMailMessage)) Nach dem Versand wird die Bestätigungsmeldung angezeigt. (über Result = True und Event)
Nur so eine Idee: wenn es sich bei FMail um die SMTP Client Komponente der Clever Internet Suite handelt: Kannst Du da denn da nicht über deren Events mitkriegen, wenn was nicht geht, oder wie der Fortschritt ist?
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.669 Beiträge
 
Delphi 10.1 Berlin Professional
 
#15

AW: Mailversand funktioniert nicht

  Alt 18. Feb 2021, 16:33
Zitat:
Kannst Du eine Mail aus Deinem Programm heraus an 'nen Freemailaccount bei Web.de, GMail, Yahoo, oder was auch immer, verschicken?
Ja, ohne Probleme.
Zitat:
Nur so eine Idee: wenn es sich bei FMail um die SMTP Client Komponente der Clever Internet Suite handelt
Ich werde mal ein Log mitschreiben OnReceiveResponse
Zitat:
Mailheader aus David anschauen und den mit dem aus Deinem Programm vergleichen.
...mach ich.
Zitat:
Mach aus den Mailanhängen bitte mal Zips und schau, ob die aus Deinem Programm heraus dann ankommen.
Das sind die nächsten Tests:
1. Gleiche "function" im Programm -> ohne Anhänge
2. Gleiche "function" im Programm -> mit Anhänge ZIP

Danke...

Geändert von haentschman (18. Feb 2021 um 16:41 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.669 Beiträge
 
Delphi 10.1 Berlin Professional
 
#16

AW: Mailversand funktioniert nicht

  Alt 19. Feb 2021, 08:35
Moin...
1. Response OK Homeoffice (beliebige Mailadresse)
Zitat:
220 fwd21.t-online.de T-Online ESMTP receiver fmsad15465 ready.
******************************************
250-fwd21.t-online.de ready.
250-SIZE 52428800
250-8BITMIME
250-AUTH=LOGIN PLAIN
250-AUTH LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250 HELP
******************************************
334 VXNlcm5hbWU6
******************************************
334 UGFzc3dvcmQ6
******************************************
235 2.5.0 Authentication successful.
******************************************
+++++++++
ich@Bla.de
noreply@Bla.de
XXX-Technik
E:\Projects\Projects_Delphi\xxx\_out\Development_R untime\_tmp\yyy\2020_RE_2014_invoice.pdf
E:\Projects\Projects_Delphi\xxx\_out\Development_R untime\_tmp\yyy\2020_RE_2014_attachment.pdf
+++++++++
250 2.1.0 Sender accepted.
******************************************
250 2.1.5 Recipient accepted.
******************************************
354 Ok, start with data.
******************************************
250 2.0.0 Message accepted.
******************************************
221 2.0.0 fwd21.t-online.de closing.
******************************************
2. Response OK Homeoffice (Empfänger Mail)
Zitat:
220 fwd02.t-online.de T-Online ESMTP receiver fmsad15465 ready.
******************************************
250-fwd02.t-online.de ready.
250-SIZE 52428800
250-8BITMIME
250-AUTH=LOGIN PLAIN
250-AUTH LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250 HELP
******************************************
334 VXNlcm5hbWU6
******************************************
334 UGFzc3dvcmQ6
******************************************
235 2.5.0 Authentication successful.
******************************************
+++++++++
ich@Bla.de
noreply@Bla.de
XXX-Technik
E:\Projects\Projects_Delphi\xxx\_out\Development_R untime\_tmp\yyy\2020_RE_2014_invoice.pdf
E:\Projects\Projects_Delphi\xxx\_out\Development_R untime\_tmp\yyy\2020_RE_2014_attachment.pdf
+++++++++
250 2.1.0 Sender accepted.
******************************************
250 2.1.5 Recipient accepted.
******************************************
354 Ok, start with data.
******************************************
250 2.0.0 Message accepted.
******************************************
221 2.0.0 fwd02.t-online.de closing.
******************************************
3. Response FAIL Firma (Empfänger Mail)
Zitat:
220 fwd38.t-online.de T-Online ESMTP receiver fmsad15465 ready.
******************************************
250-fwd38.t-online.de ready.
250-SIZE 52428800
250-8BITMIME
250-AUTH=LOGIN PLAIN
250-AUTH LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250 HELP
******************************************
334 VXNlcm5hbWU6
******************************************
334 UGFzc3dvcmQ6
******************************************
235 2.5.0 Authentication successful.
******************************************
+++++++++



+++++++++
221 2.0.0 fwd38.t-online.de closing.
******************************************
Da fehlt die Message...

Zwischen den +++ ist vereinfacht die übergebene Message...

Geändert von haentschman (19. Feb 2021 um 09:11 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von mikhal
mikhal

Registriert seit: 11. Sep 2003
Ort: Linz am Rhein
777 Beiträge
 
Delphi 10.3 Rio
 
#17

AW: Mailversand funktioniert nicht

  Alt 19. Feb 2021, 10:08
Stört sich euer Server am Leerzeichen in DEVELOPMENT_R UNTIME ?
Grüße
Mikhal
Michael Kraemer
Computer erleichtern die Arbeit...
...und die Erde ist eine Scheibe!
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.669 Beiträge
 
Delphi 10.1 Berlin Professional
 
#18

AW: Mailversand funktioniert nicht

  Alt 19. Feb 2021, 10:22
Zitat:
DEVELOPMENT_R UNTIME
...Editor Probleme in der DP.
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.669 Beiträge
 
Delphi 10.1 Berlin Professional
 
#19

AW: Mailversand funktioniert nicht

  Alt 19. Feb 2021, 12:34
Lösung:

Wie immer saß der Fehler vorm Bildschirm...

Ich hatte das HTML Formular vergessen auf den Server zu kopieren. Damit ist das LoadFromFile an die Wand gelaufen und das Programm ist in den Exception Block gelaufen...Der Exception Block hat meinen MadExcept verhindert...
Warum aber die "Bestätigung" angezeigt wurde...ist noch zu klären.

Danke für´s Mitgefühl.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 17:06 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf