Delphi-PRAXiS

Delphi-PRAXiS (https://www.delphipraxis.net/forum.php)
-   Sonstige Fragen zu Delphi (https://www.delphipraxis.net/19-sonstige-fragen-zu-delphi/)
-   -   Adminkonto defekt, Delphi 6 Komponenten weg (https://www.delphipraxis.net/189106-adminkonto-defekt-delphi-6-komponenten-weg.html)

kdf 4. Mai 2016 10:52

Adminkonto defekt, Delphi 6 Komponenten weg
 
Hallo,

ich habe das Upgrade von Winodws 7 > Windows 10 prof. durchgeführt.

1. habe ich die Platte geklont. Auf der geklonten Platte habe ich dann das Windows Upgrade durchgeführt. Delphi 6 Prof. lief auf dem Klon nach etwas Handarbeit einwandfrei. Diese Platte ist noch unverändert da.

2. habe ich dann das Upgrade auf der Originalplatte durchgeführt. Es lief augenscheinlich alles, bis auf Adobe Lightroom. Wie sich später heraus stellte, war mein Adminkonto bei dem Upgrade beschädigt worden. Nachdem ich mit einem neuen Adminkonto das Lightroom laufen hatte, habe ich die Ordner meines alten Kontos umbenannt. Dann habe ich das alte Adminkonto gelöscht und neu angelegt. Danach waren bei Delphi 6 die Komponenten der Drittanbieter weg. Habe mir dann die Registry angesehen. Da fiel es wie Schuppen von den Augen. Mit dem Löschen des Adminkontos wurde einiges aus der Registry gelöscht.

Wie bekomme ich das ohne Neuinstallation aller wieder hin?

Die vorher geklonte Platte liegt da mit einem laufenden Windows 10 und komplett eingerichteten Delphi 6 Prof.

Gruß
K.-D.

Morphie 4. Mai 2016 11:12

AW: Adminkonto defekt, Delphi 6 Komponenten weg
 
Kannst du die geklonte - lauffähige - Installation nicht wieder auf die Originalplatte klonen? ;-)

kdf 4. Mai 2016 11:21

AW: Adminkonto defekt, Delphi 6 Komponenten weg
 
dann habe ich ja wieder das kaputte Adminkonto. Ein Weg könnte sein, wenn man gelöschte Teile der Delphiinstallation in der Registry der geklonten Platte exportiert und wieder in die Registry importiert. Habe sowas aber noch nicht gemacht. Die Frage ist da auch, hat das ggf. Nebenwirkungen?

K.-D.

AlexII 4. Mai 2016 11:51

AW: Adminkonto defekt, Delphi 6 Komponenten weg
 
Mein Beileid. Nachdem ich von sowas satt wurde, mache ich fast vor jeder Bitänderung ein Backup.

Eine Lösung habe ich nicht, höre aber gerne wie man das zurecht biegt.

uligerhardt 4. Mai 2016 11:59

AW: Adminkonto defekt, Delphi 6 Komponenten weg
 
Zitat:

Zitat von kdf (Beitrag 1337446)
dann habe ich ja wieder das kaputte Adminkonto. Ein Weg könnte sein, wenn man gelöschte Teile der Delphiinstallation in der Registry der geklonten Platte exportiert und wieder in die Registry importiert. Habe sowas aber noch nicht gemacht. Die Frage ist da auch, hat das ggf. Nebenwirkungen?

K.-D.

Sagen wir so: Ich hab schon öfter Teile des Delphi-Registry-Zweigs ex- und wieder importiert, ggfs. nach geeigneter Modifikation. Das hat bisher immer funktioniert oder vielleicht mal leicht behebbare Fehler produziert. An deiner Stelle wäre ich also zuversichtlich. :mrgreen:
Außerdem kannst du ja immer noch den Zweig im vorherigen Zustand sichern.

himitsu 4. Mai 2016 12:16

AW: Adminkonto defekt, Delphi 6 Komponenten weg
 
Zitat:

Zitat von AlexII (Beitrag 1337447)
Mein Beileid. Nachdem ich von sowas satt wurde, mache ich fast vor jeder Bitänderung ein Backup.

Er hatte ja eine Kopie (Clone), nur hat er erst die Kopie und dann das Original "zerstört".

So lange die Dateipfade gleich geblieben sind, könnte er den D6-Registry-Pfad kopieren, aber wenn noch mehr fehlt (die Chance ist groß), dann hilft das auch nichts.

jaenicke 4. Mai 2016 13:47

AW: Adminkonto defekt, Delphi 6 Komponenten weg
 
Sinnvoller dürfte sein eine richtige Installationsanleitung zu schreiben was alles installiert und konfiguriert werden muss. Die Einrichtung von Delphi inkl. aller Komponenten und Einstellungen geht dann so schnell, dass es deutlich länger dauert die bestehende Version wieder lauffähig zu machen, wenn so etwas passiert...

Jedenfalls sollte es wirklich wie schon gesagt wurde reichen den Registryzweig wieder zu importieren, denn da steht ja nur drin wo die kompilierten Packages liegen usw., und die Dateien, auf die da verwiesen wird, sind ja noch an der gleichen Stelle vorhanden. Das habe ich auch schon gemacht.

kdf 4. Mai 2016 14:04

AW: Adminkonto defekt, Delphi 6 Komponenten weg
 
der Klon ist ja nicht zerstört, hat lediglich auch schon das kaputte Adminkonto. Das hatte ich aber so geschrieben. Delphi sitzt da exakt an der gleichen Stelle in exakt gleicher Konfiguration. Auf der aktuellen Platte wurde es nur einmal gestartet, als ich feststellte, die Komponenten sind weg. Ich werde also die Klonplatte nochmals einbauen, aus der Registry alle Schlüssel unter D6 exportieren. Aus der Registry der aktuellen Platte werde ich die Schlüssel von D6 sichern und dann alle D6-Schlüssel vom Klon importieren. Wenn das scheitern sollte, installiere ich die Komponenten neu.

K.-D.


PS: gibt es eine Möglichkeit, die komplette Registry des Klon so zu sichern, dass man später noch einzelne Schlüssel daraus exportieren kann?

kdf 4. Mai 2016 16:48

AW: Adminkonto defekt, Delphi 6 Komponenten weg
 
bevor ich etwas hinrichte nochmal die Frage:

Registry von Klon
Delphi-6.0 Knoten exportieren

Registry von aktueller Platte
die *.reg vom Export des Klon importieren

Ist das so richtig?

Sind weitere Schritte notwendig?

K.-D.

jaenicke 4. Mai 2016 21:36

AW: Adminkonto defekt, Delphi 6 Komponenten weg
 
Das sollte reichen, ja.


Alle Zeitangaben in WEZ +1. Es ist jetzt 15:06 Uhr.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf