Delphi-PRAXiS

Delphi-PRAXiS (https://www.delphipraxis.net/forum.php)
-   .NET-Framework (managed code) (https://www.delphipraxis.net/79-net-framework-managed-code/)
-   -   C# Unterschied zwischen Assembly.Load und Assembly.LoadFrom (https://www.delphipraxis.net/193963-unterschied-zwischen-assembly-load-und-assembly-loadfrom.html)

Neutral General 29. Sep 2017 10:08

Unterschied zwischen Assembly.Load und Assembly.LoadFrom
 
Hallo,

Eigentlich wollte ich ja hier im Delphi Forum nicht posten, aber nachdem ich auf Stackoverflow (Crosspost) erst 2 Antworten bekam von Leuten die scheinbar höchstens die Überschrift gelesen haben und die Antworten dann ein paar Stunden später gelöscht waren hoffe ich dass ich hier vielleicht etwas mehr Glück habe :roll:

Ich habe eine Anwendung die ihre benötigten DLLs als Resource in sich trägt und diese im AppDomain.CurrentDomain.AssemblyResolve Event lädt.
Das funktioniert soweit auch gut und das Programm läuft auch. Jetzt habe ich in einer DLL Default Styles für Controls drin.
Wenn ich die DLL allerdings per Assembly.Load(byte[]) lade werden diese Styles scheinbar nicht korrekt geladen bzw. sie werden schon geladen aber aus irgendeinem Grund nicht auf die Controls angewandt.
Wenn ich die DLL aus den Resourcen lade und erst auf die Festplatte speicher und dann von dort aus mit Assembly.LoadFrom lade, dann funktioniert alles:

Code:
private static Assembly OnResolveAssembly(object sender, ResolveEventArgs args)
{
    var executingAssembly = Assembly.GetExecutingAssembly();
    var assemblyName = new AssemblyName(args.Name);
    var path = assemblyName.Name + ".dll";

    using (var stream = executingAssembly.GetManifestResourceStream(path))
    {
        if (stream != null)
        {
            using (var zip = new GZipStream(stream, CompressionMode.Decompress))
            {
                // Damit werden die Styles der DLL nicht "richtig" geladen
                byte[] buffer;
                using (var decompressedStream = new MemoryStream())
                {
                    zip.CopyTo(decompressedStream);
                    buffer = new byte[decompressedStream.Length];
                    decompressedStream.Seek(0, SeekOrigin.Begin);
                    decompressedStream.Read(buffer, 0, buffer.Length);
                }
                return Assembly.Load(buffer);
               
                // Wenn ich stattdessen die DLLs zuerst speichere und dann per Assembly.LoadFrom lade dann gehts!
             
                //using (var decompressedStream = File.Create(path))
                //{
                //    zip.CopyTo(decompressedStream);
                //    decompressedStream.Flush();
                //}
                //return Assembly.LoadFrom(path);
            }
        }

        return null;
    }
}
Bin echt am verzweifeln!

Phoenix 29. Sep 2017 12:28

AW: Unterschied zwischen Assembly.Load und Assembly.LoadFrom
 
Ich würde mal nachschauen ob das Problem eher kein Unterschied zwischen Load und LoadFrom ist, sondern das eigentliche Laden der Styles.

Wenn der Code der die Styles laden soll die Assembly Location ermittelt, und dann versucht die Styles aus der Datei mit dieser Location zu laden, kann das nicht funktionieren wenn die Assembly keine location hat (also aus dem Byte[] geladen wurde).

Das dürfte ja irgendwo im Framework passieren - vielleicht da mal reindebuggen und gucken was da innen drin passiert.

Morphie 29. Sep 2017 13:16

AW: Unterschied zwischen Assembly.Load und Assembly.LoadFrom
 
Oder mal in den Quellcode schauen:
https://referencesource.microsoft.co...on/assembly.cs

Neutral General 29. Sep 2017 16:01

AW: Unterschied zwischen Assembly.Load und Assembly.LoadFrom
 
In den Code hatte ich schon geschaut aber nix gefunden was mir weitergeholfen hat.
Hab das Problem jetzt allerdings behoben.
Es lag nicht daran wie die Assemblies geladen wurden, sondern dass meinen CustomControls das hier gefehlt hat:
Code:
static MyControl()
{
    DefaultStyleKeyProperty.OverrideMetadata(typeof(MyControl), new FrameworkPropertyMetadata(typeof(MyControl)));
}
Ich weiß zwar trotzdem nicht warum es dann mit LoadFrom geht und mit Load nicht, aber das unterliegende Problem war wohl das da. :gruebel:


Alle Zeitangaben in WEZ +1. Es ist jetzt 22:19 Uhr.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf