Delphi-PRAXiS
Seite 1 von 2  1 2   

Delphi-PRAXiS (https://www.delphipraxis.net/forum.php)
-   Die Delphi-IDE (https://www.delphipraxis.net/62-die-delphi-ide/)
-   -   Editor wird nicht richtig gezeichnet (https://www.delphipraxis.net/199248-editor-wird-nicht-richtig-gezeichnet.html)

Codehunter 9. Jan 2019 07:09

Editor wird nicht richtig gezeichnet
 
Hallo!

Ich habe folgendes Problem: Ich habe Delphi (10.2.3) in einer VM installiert. Wenn ich per STRG-Click und/oder Vorwärts-Rückwärts-Navigation hin und her springe, dann wird der Editor nicht richtig gezeichnet. Die Zeilen werden versetzt gepinselt. Das bereinigt sich, wenn ich ein bisschen mit dem Mauswheel herum scrolle. Dennoch ist das sehr lästig. Allerdings kann ich das Problem nicht genau eingrenzen. Ich habe schon vergeblich alle IDE-Extensions deinstalliert und neu installiert. Auch ganz ohne Extensions das selbe Problem. Ich vermute, sicher bin ich da nicht, dass es was mit der VM zu tun haben könnte. VirtualBox und Intelgrafik sind einfach keine Freunde. Bisher habe ich das Problem auch nur auf diesem einen Rechner. Vielleicht kennt das ja jemand von euch auch?

Grüße
Cody

PS: Auch wenns so ähnlich klingt, es ist nicht dieses Problem. Der Textcursor steht in der richtigen Zeile, nur wird der Editor auf seinen Canvas falsch gezeichnet.

EDIT: Kleine Ergänzung noch: Das Problem tritt NICHT auf, wenn ich alle im Quelltext vorhandenen {$REGION} aufklappe. Es scheint also mit dem Codefolding zu tun zu haben.

Sherlock 9. Jan 2019 08:33

AW: Editor wird nicht richtig gezeichnet
 
Hab ich auch immer wieder. Insbesondere wenn ich nach größeren Änderungen den Code neu formatieren lasse. Eine weitere Formatierung richtet es dann in aller Regel wieder.

Sherlock

Codehunter 9. Jan 2019 13:42

AW: Editor wird nicht richtig gezeichnet
 
Bei dir auch in einer VM?

Sherlock 9. Jan 2019 14:10

AW: Editor wird nicht richtig gezeichnet
 
Parallels in MacOS. Also ja. Ich glaube aber, daß es eher an Zusatzprodukten wie CnPack, GXperts etc. liegt.

Sherlock1

TigerLilly 10. Jan 2019 06:55

AW: Editor wird nicht richtig gezeichnet
 
VMWare Tools installiert + aktuell?

Pfaffe 10. Jan 2019 07:22

AW: Editor wird nicht richtig gezeichnet
 
Habe VMWare Fusion 11.0.2 und die VMWare Tools 10.3.2 im Einsatz, CnPack und GXperts sind installiert und habe das Problem nicht.

Codehunter 10. Jan 2019 15:50

AW: Editor wird nicht richtig gezeichnet
 
Bei mir isses kein VMWare.

Codehunter 11. Jan 2019 08:02

AW: Editor wird nicht richtig gezeichnet
 
Update: Die Intel-basierte Grafik der Hostmaschine kann ich inzwischen als Ursache ausschließen. Ich habe die VM auf einem Ryzen/Vega11 ausprobiert, da sind die Darstellungsfehler identisch. Extensions kann ich wie gesagt inzwischen auch ausschließen, weil auch wenn komplett deinstalliert die selben Fehler auftreten. Damit scheint es wohl ein Delphi-internes Problem zu sein, das irgendwie mit dem Codefolding zusammen hängt. Dieses scheint wohl nach wie vor etwas buggy zu sein, denn neben den Darstellungsfehlern gibt es auch das oben verlinkte Navigationsproblem. Vielleicht hängen die sogar ursächlich zusammen, wer weiß.

Uwe Raabe 11. Jan 2019 08:07

AW: Editor wird nicht richtig gezeichnet
 
Manchmal sind fehlerhafte Zeichen oder Zeilenumbrüche in den pas-Dateien die Ursache für solche Probleme.

Codehunter 11. Jan 2019 09:20

AW: Editor wird nicht richtig gezeichnet
 
Zitat:

Zitat von Uwe Raabe (Beitrag 1423099)
Manchmal sind fehlerhafte Zeichen oder Zeilenumbrüche in den pas-Dateien die Ursache für solche Probleme.

Ist nicht auszuschließen. Grad wenn man z.B. Strings aus PDF-Dateien kopiert, was bei uns häufiger vorkommt. Die Frage ist, wie findet man die am elegantesten? Die Units sind ja recht umfangreich.


Alle Zeitangaben in WEZ +1. Es ist jetzt 21:39 Uhr.
Seite 1 von 2  1 2   

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf