Delphi-PRAXiS

Delphi-PRAXiS (https://www.delphipraxis.net/forum.php)
-   Die Delphi-IDE (https://www.delphipraxis.net/62-die-delphi-ide/)
-   -   Debugger in Delphi 10.2.3 spinnt bei Unit (https://www.delphipraxis.net/199285-debugger-delphi-10-2-3-spinnt-bei-unit.html)

devidespe 11. Jan 2019 16:15

Debugger in Delphi 10.2.3 spinnt bei Unit
 
Hallo zusammen,

in einem bewährten Delphi Projekt auf einem frischen PC spinnt der Delphi-Debugger total. Er verhindert das Setzen von Breakpoints in erlaubten Codezeilen, stattdessen in Begin- und End-Zeilen sowie in Leerzeilen, beim Durchsteppen per F7/F8 springt er zu Leerzeilen, Codeblöcke mit bedingter Kompilierung überspring er völlig usw. Dies betrifft jedoch nur 1 Unterunit des Projektes - die keine Kompilerschalter im Stil {$ enthält.

Ich habe alle Debug-Optionen in den Projektoptionen aktiv und auch alle DCUs gelöscht sowie neu erzeugt - das gleiche Ergebnis.

Es ist ein Delphi 10.2.3 Tokyo sowie ein Windows 7 32 Bit mit allen Updates. Hat jemand eine Idee?

Danke.

Delphi.Narium 11. Jan 2019 16:27

AW: Debugger in Delphi 10.2.3 spinnt bei Unit
 
https://stackoverflow.com/questions/...g-in-delphi-10

Im Zweifelsfalle mal alle DCUs löschen und dann vollständig neu kompilieren.

Quelltext in 'nem anderen Editor (Notepad ...) öffnen und speichern, dann erneut versuchen.

https://www.delphipraxis.net/1423113-post11.html

bytecook 11. Jan 2019 16:28

AW: Debugger in Delphi 10.2.3 spinnt bei Unit
 
Zitat:

Zitat von devidespe (Beitrag 1423142)
Hallo zusammen,

in einem bewährten Delphi Projekt auf einem frischen PC spinnt der Delphi-Debugger total. Er verhindert das Setzen von Breakpoints in erlaubten Codezeilen, stattdessen in Begin- und End-Zeilen sowie in Leerzeilen, beim Durchsteppen per F7/F8 springt er zu Leerzeilen, Codeblöcke mit bedingter Kompilierung überspring er völlig usw. Dies betrifft jedoch nur 1 Unterunit des Projektes - die keine Kompilerschalter im Stil {$ enthält.

Ich habe alle Debug-Optionen in den Projektoptionen aktiv und auch alle DCUs gelöscht sowie neu erzeugt - das gleiche Ergebnis.

Es ist ein Delphi 10.2.3 Tokyo sowie ein Windows 7 32 Bit mit allen Updates. Hat jemand eine Idee?

Danke.

Hallo Devid,

Hatte ein ähnliches Problem, kommt hier bei mir ab und an vor. Ich verwende auch 10.2.3. Dann hast du ggf ein nicht sichtbares Zeichen drin... Öffne die betreffende Unit mal in Notepad++, dann unter "Bearbeiten", "Format Zeilenende" auf "Unix" umstellen, danach zurückwechseln auf "Windows", speichern und wieder in Delphi öffnen.

HTH!

devidespe 11. Jan 2019 20:42

AW: Debugger in Delphi 10.2.3 spinnt bei Unit
 
Danke für Eure Hilfe, das war die Lösung.


Alle Zeitangaben in WEZ +1. Es ist jetzt 08:05 Uhr.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf