Delphi-PRAXiS

Delphi-PRAXiS (https://www.delphipraxis.net/forum.php)
-   Cross-Platform-Entwicklung (https://www.delphipraxis.net/91-cross-platform-entwicklung/)
-   -   TOrientationSensor (https://www.delphipraxis.net/205105-torientationsensor.html)

MechMac666 31. Jul 2020 18:13

TOrientationSensor
 
Hallo,

ich wollte nochmal das Beispielprojekt "OrientationSensor" aus den Samples von Delphi 10.3 testen,
da ging der Tilt-Bereich auf dem Zielgerät nicht mehr. (Es hat aber definitiv schon mal funktioniert). Zeigt nur noch drei mal 0 an.
Heading geht jedoch noch.
Ich dachte zunächst das ich was dran verändert habe, aber als ich das Original wiederhergestellt hatte,
war das Problem immer noch da.
Dann habe ich auf irgendeiner Webseite gelesen das da etwas an Android hinsichtlich des Sensors geändert wurde.
(K.a. ob das etwas mit meinem Problem zu tun hat.)

Da es eh noch ausstand, habe ich die Delphi Version 10.4 sowie die Patches aus dem Downloadbereich installiert.
Aber auch das hat nichts gebracht. Ich hatte auch versucht in 32 und 64 Bit zu kompilieren. Das gleiche Problem.

Hardware: Samsung Galaxy S8 und S5. (Bei beiden das gleiche Problem)

Ist das ein Bug, oder übersehe ich da etwas?
(Was mir so gar nicht in den Kopf will, ist das es auf dem S8 zwei Tage zuvor noch funktioniert hat)

Gruß, Andreas

EDIT:
Habe es auch auf einem Galaxy Tab S (SM-T705) ausprobiert, auch hier weder Tilt noch Heading.
Nach einem Neustart des S8 geht auch hier Heading nicht mehr.
Somit funktionieren jetzt auf allen drei Geräten weder Tilt noch Heading.

TurboMagic 31. Jul 2020 21:58

AW: TOrientationSensor
 
Schon mal in QP (https://quality.embarcadero.com) geschaut ob da etwas dazu eingestellt wurde?

MechMac666 1. Aug 2020 07:37

AW: TOrientationSensor
 
Da gibt's einige Einträge, jedoch keine Lösung(en).
Und das Problem scheint schon sehr lange zu bestehen, wenn man schaut wie alt die Einträge teils sind.

Auch bei mir ist's so, dass die meisten Sensoren nach dem Start einer Delphi-Sensor App für ALLE anderen Apps
funktionsunfähig sind. Erst nach einem Neustart des Gerätes können Apps wieder mit den Sensoren arbeiten (Delphi Apps ausgenommen).

TurboMagic 1. Aug 2020 15:26

AW: TOrientationSensor
 
Wenn ich nach TOrientationSensor suche, finde ich nur diesen einen Eintrag:
https://quality.embarcadero.com/browse/RSP-16284

Was natürlich schlimm genug ist. Hab' mal wo angefragt wie die Chancen auf einen Fix sind.

Grüße
TurboMagic

MechMac666 1. Aug 2020 19:02

AW: TOrientationSensor
 
Zu den Sensoren hatte ich hier etwas gefunden. Bin mir aber nicht sicher ob das etwas bedeutet.

Und hier hat jemand das Problem, das die Sensoren nach dem aktivieren nicht mehr funktionieren. Es ist zwar ein anderer Sensor, aber das scheint ja ganz offensichtlich ein generelles Problem zu sein.
Ich hatte als Suchbegriff übrigens nur "Sensor" eingegeben. Nicht jeder nennt das Kind beim Namen.

borstenei 1. Aug 2020 19:29

AW: TOrientationSensor
 
...auch ich hatte 2015 Probleme mit dem Beschleunigungssensor...die App hat immer nur einmal Daten geliefert danach nicht mehr...
Erst nach einem Neustart des Handys hat es wieder funktioniert..aber auch nur einmal bis zum nächsten Neustart.
Es war damals ein Samsung S9.
Das merkwürdige ist , habe ich gerade getestet , die selbe App läuft jetzt auf einem S9+ ohne Probleme..

TurboMagic 2. Aug 2020 09:42

AW: TOrientationSensor
 
Ich glaubt nicht daran, dass du das 2015 auf einem Galaxy S9 gesehen hast, das meinen Infos zufolge erst 2018 auf den Markt kam ;-)
Oder besitzt du einen Flux-Kompensator? ;-)

borstenei 2. Aug 2020 13:26

AW: TOrientationSensor
 
Ohhhh..sorry sollte S6 heissen :oops:

TurboMagic 2. Aug 2020 14:00

AW: TOrientationSensor
 
Kein großes Problem, wollte nur niemand auf der falschen Fährte unterwegs sehen...


Alle Zeitangaben in WEZ +1. Es ist jetzt 16:59 Uhr.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf