Delphi-PRAXiS

Delphi-PRAXiS (https://www.delphipraxis.net/forum.php)
-   Cross-Platform-Entwicklung (https://www.delphipraxis.net/91-cross-platform-entwicklung/)
-   -   Delphi 10.4.2 Probleme beim Umstieg von 10.4 auf 10.4.2 (https://www.delphipraxis.net/207187-delphi-10-4-2-probleme-beim-umstieg-von-10-4-auf-10-4-2-a.html)

FreddyH 2. Mär 2021 14:18

Delphi 10.4.2 Probleme beim Umstieg von 10.4 auf 10.4.2
 
Hallo an Alle :-)

Wir haben im Unternehmen von 10.4 auf 10.4.2 umgestellt.
Nun bekommen wir bei bestehenden Projekten folgende Fehlermeldung, beim Debuggen und Starten einer Andorid Anwendung:

[Warning Warnung] Missing provisioning information for the "Application Store" platform configuration, the file '.\Android64\Debug\Sc_Testprojekt\bin\Sc_Testproje kt.aab' has been sucessfully generated but it has not been signed and it is a non-instalable package.

Delphi legt immer nur eine Datei "Sc_Testprojekt.aab" im Verzeichnis "Android64\Debug\Sc_Testprojekt\bin" an, sonst stand da immer Sc_Testprojekt.apk drin.
Die Projekte werden ohne Probleme oder Fehler compiliert.

Wir haben das AndroidManifest.template.xml und den Ordner Android64 gelöscht, leider immer mit dem gleichen Ergebnis.

Wenn wir neue Projekte anlegen, dann funktioniert das Debuggen und Starten.
Habt Ihr vielleicht eine Lösung für uns?

Schöne Grüße von der Mecklenburger Seenplatte

TurboMagic 2. Mär 2021 18:51

AW: Delphi 10.4.2 Probleme beim Umstieg von 10.4 auf 10.4.2
 
Hallo,

was willst du genau tun?
Wie es aussieht bist du auf "Anwendungs Store" statt "Entwicklung" im Projektmanager.
Stell das mal um, dann wird denke ich auch eine APK erzeugt und du solltest debuggen können.
Ggf. auch noch auf "Debug" Konfiguration stellen.

Grüße
TurboMagic

FreddyH 2. Mär 2021 22:34

AW: Delphi 10.4.2 Probleme beim Umstieg von 10.4 auf 10.4.2
 
Ich probiere es morgen aus u d werde dann berichten.
Danke dir

FreddyH 3. Mär 2021 13:19

AW: Delphi 10.4.2 Probleme beim Umstieg von 10.4 auf 10.4.2
 
Hallo TurboMagic,

danke für deinen Rat aber leider hatte das auch nicht geholfen.
Ich habe die Projektdatei gelöscht, neues Projekt wieder angelegt,
alle Units eingefügt, die selben Berechtigungen, Symbole und KeyStore Datei wieder hinzugefügt.

Und alles funktioniert jetzt.
Trotzdem Danke


Alle Zeitangaben in WEZ +1. Es ist jetzt 23:44 Uhr.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf