Delphi-PRAXiS
Seite 3 von 9     123 45     Letzte » 

Delphi-PRAXiS (https://www.delphipraxis.net/forum.php)
-   Software-Projekte der Mitglieder (https://www.delphipraxis.net/26-software-projekte-der-mitglieder/)
-   -   myCine: Die Filmverwaltung (https://www.delphipraxis.net/43362-mycine-die-filmverwaltung.html)

leddl 23. Apr 2006 18:49

Re: myMoviesXP: Die Filmverwaltung
 
Zitat:

Zitat von MPirnstill
3. Der DB-Converter 2 hat meine Covers nicht wieder richtig zugewiesen.

Haben wir jetzt schon mehrfach gesagt ;) Einfach in den Einstellungen den Coverordner richtig setzen (da fehlt nämlich ein "\") und es funktioniert wieder.
Zitat:

Zitat von MPirnstill
6. Ich war ja mit Verion 8.1.2 registriert, warum erkennt die neue Version dies nicht oder muß ich mich neu
registrieren.

Du mußt einfach deine Daten nochmal neu eintragen. Etwas unschön, aber is halt so.

Zitat:

Zitat von MPirnstill
Sorry, aber ich glaube ich bleibe erstmal bei der alten Version. :(

Beide haben ihre Vor- und Nachteile ;) Ich denke, es kann nichts schaden, die neue Version zu benutzen und Fehler und Wünsche hier zu posten. Bei welcher Software hat man denn schon die Chance zu sowas ;)

MCXSC 23. Apr 2006 18:58

Re: myMoviesXP: Die Filmverwaltung
 
Wie gesagt: Arbeite bereits an v9.1, es fehlen nur noch ein paar Kleinigkeiten...

Zitat:

Beim Laden flackert die Übersichtsliste. Du solltest vielleicht disableControls / enableControls verwenden.
Wird behoben.

Zitat:

Wenn die Progressbar schon am Ende und es rührt sich immer noch nicht.
Der Taskmanager zeigt noch 20 bis 30 volle Prozessorauslastung und erst dann reagiert das Programm wieder.
Da weiß ich auch nicht wo das Problem direkt liegt: Aber habe nun enmal eine andere Kompo eingebaut und die Bar wieder entfernt... ist nun schneller...

Zitat:

Auch wenn man einen Film bearbeiten will, dauert allein er Aufruf dieses Fenster 5 bis 10 Sekunden. Das kann
ganz schön nervig werden. Bei Neu übrigens auch.
Das dürfte bei der 8ter Version aber auch so sein? Werd aber noch ne Funktion einbauen, das Laden der ComboBoxen zu deaktivieren. Daran legt denk ich mal das Problemchen.

Zitat:

Und beim Speichern von Änderungen hat sich das Programm schlíeßlich aufgehängt.
Das kann ich nicht behaupten :-) Nee im ernst: bei mir funzt es..

Zitat:

Ich war ja mit Verion 8.1.2 registriert, warum erkennt die neue Version dies nicht oder muß ich mich neu
registrieren.
en, die alten Daten funktionieren weiterhin. Musste nur ein wenig darn umbauen, da es nun auch bei nächsten Versionen (neue Kompo) übergreift.

Zitat:

Ich denke, es kann nichts schaden, die neue Version zu benutzen und Fehler und Wünsche hier zu posten. Bei welcher Software hat man denn schon die Chance zu sowas Wink
Genau :-)

Aber generell hoffe ich, dass ich mit v9.1 die Geschwindigkeit endlich mal ein wenig optimiert bekomme... des war schon immer das Hauptproblem von myMovies...

MPirnstill 24. Apr 2006 06:52

Re: myMoviesXP: Die Filmverwaltung
 
Hi,

Zitat:

Zitat von leddl
Zitat:

Zitat von MPirnstill
3. Der DB-Converter 2 hat meine Covers nicht wieder richtig zugewiesen.

Haben wir jetzt schon mehrfach gesagt ;) Einfach in den Einstellungen den Coverordner richtig setzen (da fehlt nämlich ein "\") und es funktioniert wieder.;)

Sorry, so schlau war ich auch schon, aber die Dateinamen der Image-Dateien wurden anscheinend in numerische Werte umgewandelt und deswegen werden die Bilder nicht mehr gefunden.


Zitat:

Zitat von leddl
Zitat:

Zitat von MPirnstill
Sorry, aber ich glaube ich bleibe erstmal bei der alten Version. :(

Beide haben ihre Vor- und Nachteile ;) Ich denke, es kann nichts schaden, die neue Version zu benutzen und Fehler und Wünsche hier zu posten. Bei welcher Software hat man denn schon die Chance zu sowas ;)

Hey, was habe ich hier denn gemacht. Nennt sich doch glaube ich, "Fehler posten". Okay, sorry, habe gestern nicht mehr den ganzen Thread (immerhin schon 6 Seiten) gelesen. Dann kann man schon mal etwas doppelt monieren. Und außerdem habe ich nur gesagt, das ich "erstmal" bei der alten Version bleibe.

Und Wünsche habe ich bei früheren Version auch schon gepostet. Ein Wunsch, den ich immer noch hab, wurde leider nicht berücksichtigt. Okay, ich verleihe jetzt nicht mehr so viele Filme an Freunde, fände die Funktion eine Verleih-Historie trotzdem ganz praktisch. Gerade weil mir das dies Mißgeschick bei meinem Lieblingsfilm passiert ist. Hatte den Verliehen und als ich den Film zurück bekam war die DVD nicht mehr drin. Nur da ich nicht sofort nachgesehen hab, wußte ich nicht mehr wer den Film zuletzt hatte. Hab natürlich rumgefragt, aber der eine (ein Schlitzohr) den ich in Verdacht hatte, war da aus versch. Gründen, auch schon nicht mehr in meinem engeren Bekanntenkreis.

Zitat:

Zitat von MCXSC
Zitat:

Zitat von MPirnstill

Auch wenn man einen Film bearbeiten will, dauert allein er Aufruf dieses Fenster 5 bis 10 Sekunden. Das kann
ganz schön nervig werden. Bei Neu übrigens auch.

Das dürfte bei der 8ter Version aber auch so sein? Werd aber noch ne Funktion einbauen, das Laden der ComboBoxen zu deaktivieren. Daran legt denk ich mal das Problemchen.

Auf alle fälle dauert das bei der 8er nicht so extrem lange. Ich hab jetzt nicht gestoppt, aber die 8er noch mal aufgerufen und geschaut, ob das Fenster hier ín annehmbarer Geschwindigkeit angezeigt wird. Wenn die ComboBoxen so lange zum Laden brauchen, könntest du die vielleicht in verschiedenen Threads laden. Vielleicht bringt das was!?

Ich finde das Prog ja sonst auch echt toll, sonst würde ich es nicht benutzen. Außerdem ist die Erfahrung wie sich die Anwender fühlen, wenn der Programmierer etwas ändert auch ganz interessant, muß ich sagen. Da verstehe ich vielleicht eher, wenn die meine Anwender auf der Arbeit motzen, weil ich was korrigiert hab und dafür vielleicht was anderes nicht mehr richtig funktioniert.

Gruß

leddl 24. Apr 2006 08:13

Re: myMoviesXP: Die Filmverwaltung
 
@MPirnstill:
Sorry, wenn du meinen Post falsch verstanden hast. Das ist allerdings nun wirklich kein Grund, gleich so beleidigt zu reagieren :roll: Ich wollte dir in keinster Weise an den Karren fahren...

MPirnstill 24. Apr 2006 08:20

Re: myMoviesXP: Die Filmverwaltung
 
Zitat:

Zitat von leddl
@MPirnstill:
Sorry, wenn du meinen Post falsch verstanden hast. Das ist allerdings nun wirklich kein Grund, gleich so beleidigt zu reagieren :roll: Ich wollte dir in keinster Weise an den Karren fahren...

Bin nicht beleidigt! Wollte nur darauf hinweisen, daß das ich eigentlich genau das getan hab, was du geschrieben hast. Vielleicht hätte es irgendwie anders formulieren sollen. Auch Sorry! :wink:

Gruß

MCXSC 24. Apr 2006 14:45

Re: myMoviesXP: Die Filmverwaltung
 
Hey jetzt streitet euch doch nicht :-)

Zitat:

Wenn die ComboBoxen so lange zum Laden brauchen, könntest du die vielleicht in verschiedenen Threads laden. Vielleicht bringt das was!?
Muss ganz ehrlich sagen: Hab mich mit Threads noch nie bschäftigt... ann also nicht sagen ob es funze würde... geschweige denn, ob ich es überhaupt hinbekommen würde...

MPirnstill 24. Apr 2006 15:29

Re: myMoviesXP: Die Filmverwaltung
 
Hi Marcel!

Zitat:

Wenn die ComboBoxen so lange zum Laden brauchen, könntest du die vielleicht in verschiedenen Threads laden. Vielleicht bringt das was!?
Muss ganz ehrlich sagen: Hab mich mit Threads noch nie bschäftigt... ann also nicht sagen ob es funze würde... geschweige denn, ob ich es überhaupt hinbekommen würde...[/quote]

Ob es mit threads besser wird kann ich dir leider auch nicht definitiv sagen, aber falls du dich damit beschäftigen willst gibt es ein Tutorial
Thread-Tutorial von Luckie
Auch wenn sich das Tutorial stark auf die API-Schnittstelle konzentriert, am Ende beschreibt er das TThread-Object von Delphi. Da gibt es auch noch 'ne ZIP-Datei mit Beispielen. Mir hat es jedenfalls geholfen.

Und im Delphi Ordner findest du unter Demos auch ein Beispiel für Threads. Ich muß sagen habe auch eerst kürzlich meinen ersten Thread programmiert. Übrigens auch um eine Combobox zu laden (Postleitzahlen 44000 Datensätze). Starte den Thread am Anfang des FormCreate während gleichzeitig die restlichen Befehle in FormCreate ablaufen. In dem Augenblick in dem das Formular angezeigt wird, ist die Combobox zwar noch nicht geladen, aber bis der Anwender reagiert und weitere Aktionen starten kann vergehen ja meist auch noch ein bis zwei Sekündchen. Und dann sind auch die Postleitzahlen geladen.

Nur falls du es mal probieren willst.

Gruß

MCXSC 24. Apr 2006 15:54

Re: myMoviesXP: Die Filmverwaltung
 
Ein Versuch ist es wert, werd mich heut abend mal dransetzen...

Eichhoernchen 24. Apr 2006 16:12

Re: myMoviesXP: Die Filmverwaltung
 
hab auch ein Problem, ich weiß nicht ob es schon erwähnt wurde, aber bei mir wird kein Cover angezeigt(hab die mit dem Porgramm geladen). Die aktuellste Version hab ich benutzt!
Mior ist außerdem aufgefallen, dass des öfter mal Zugriffsverletzungen gibt wenn ich auf einen der Filme zugreife. Fehler beim lesen von Adresse 0. Scheinst wohl irgendwie das die Liste immer auf NIL steht.

MCXSC 24. Apr 2006 16:33

Re: myMoviesXP: Die Filmverwaltung
 
Zitat:

hab auch ein Problem, ich weiß nicht ob es schon erwähnt wurde, aber bei mir wird kein Cover angezeigt(hab die mit dem Porgramm geladen). Die aktuellste Version hab ich benutzt!
Ja, schon oft. Geh einfach auf "Datei | Einstellungen" und wähl den Coverordner neu aus, dann klappts...

Zitat:

Mior ist außerdem aufgefallen, dass des öfter mal Zugriffsverletzungen gibt wenn ich auf einen der Filme zugreife. Fehler beim lesen von Adresse 0. Scheinst wohl irgendwie das die Liste immer auf NIL steht.
Wann genau? Vll. Screenshot?

Eichhoernchen 24. Apr 2006 16:50

Re: myMoviesXP: Die Filmverwaltung
 
*grummel* jetzt kommt der Fehler net mehr, er kam aber als ich am Anfang alle Filme hinzugefügt hatte, dor hatte ich dann 10 filme schon drinn, die waren dann auch schon alle als Tab angezeigt, und wenn ich mir diese dann angeguckt habe und dann hin und her zwischen den Tabs gegangen bin, dann kam wenn ich das 2. Tab auswählte immer der Fehler: Fehler beim Lesen von Adresse 0.


Mit den Covern hat geklappt, hätte wohl lesen sollen *schäm*

Aufgefallen ist mir noch wenn ich mehrere Filme in der Detailansicht als tab habe, dann nen noch einen als Tab anzeigen lasse, dann wird er nicht ans Ende eingeordnet, sondern ?willkürlich? zwischen den anderen Tabs, er wird aber auch nicht nach film nummer eingeordnet, war ungefähr so:

film: 13 5 23 7 3
als ich dann film nr. 18 auf detail gegangen bin war es so
film: 13 5 18 23 7 3

ist zwar eher unwichtig aber ist mir eben aufgefallen!

MCXSC 24. Apr 2006 17:21

Re: myMoviesXP: Die Filmverwaltung
 
Zitat:

Aufgefallen ist mir noch wenn ich mehrere Filme in der Detailansicht als tab habe, dann nen noch einen als Tab anzeigen lasse, dann wird er nicht ans Ende eingeordnet, sondern ?willkürlich? zwischen den anderen Tabs, er wird aber auch nicht nach film nummer eingeordnet, war ungefähr so:
Weiß nicht, bei mir wird der neue Tab immer am Ende eingefügt... Wie ists denn bei anderen?

@Eichhoernchen: Kannst mir vielleicht deine DB per Mail/PN schicken?

leddl 24. Apr 2006 17:29

Re: myMoviesXP: Die Filmverwaltung
 
Zitat:

Zitat von Eichhoernchen
film: 13 5 23 7 3
als ich dann film nr. 18 auf detail gegangen bin war es so
film: 13 5 18 23 7 3
ist zwar eher unwichtig aber ist mir eben aufgefallen!

Kann ich bei mir nicht bestätigen, hier wird alles der Reihe nach aufgelistet.

Ich hab gerade mal wieder ein paar Filme eingegeben und hab sofort wieder was zu bemängeln (weiß allerdings nicht, was alles du davon schon verbessert hast) :mrgreen:
  • Im "Film hinzufügen"-Fenster wird der Fokus beim OnShow nicht gesetzt (sondern wohl nur im OnCreate). Der Cursor sitzt immer in dem Feld, in dem ich beim letzten Film etwas gemacht habe ;)
  • Es wäre schön, wenn man die Dinge, die bei mehreren Filmen gleich sein können (Medienanzahl, Qualität, FSK,...) auch für mehrere Filme gleichzeitig ändern könnte => MultiSelect ermöglichen und ein angepasstes "Ändern"-Formular
  • Wie wäre es, die Tabelle an sich auch als Tab anzuzeigen, so daß man nicht einfacher zwischen den Ansichten wechseln kann?

:gruebel: Irgendwas war noch, aber mir fällts grad nich mehr ein :lol: Ich meld mich dann nochmal, das meiste hab ich ja schon gesagt. Bin mal gespannt auf die nächste Version :mrgreen:

MCXSC 24. Apr 2006 18:23

Re: myMoviesXP: Die Filmverwaltung
 
Zitat:

Im "Film hinzufügen"-Fenster wird der Fokus beim OnShow nicht gesetzt (sondern wohl nur im OnCreate). Der Cursor sitzt immer in dem Feld, in dem ich beim letzten Film etwas gemacht habe
Ja, ist schon verbessert...

Zitat:

Es wäre schön, wenn man die Dinge, die bei mehreren Filmen gleich sein können (Medienanzahl, Qualität, FSK,...) auch für mehrere Filme gleichzeitig ändern könnte => MultiSelect ermöglichen und ein angepasstes "Ändern"-Formular
Hmmm... müsste mir das aber erstmal genauer anschauen... Von MultiSelect halte ich persönlich nicht viel von, egal in welchem Programm ;-)

Zitat:

Wie wäre es, die Tabelle an sich auch als Tab anzuzeigen, so daß man nicht einfacher zwischen den Ansichten wechseln kann?
Die Idee hatte ich anfangs, als mir die Tab-Idee gekommen ist, auch schonmal gehabt. Habe dieses aber aus folgendem Grund wieder verworfen: Wenn du mehrere Tabs geöffnet hast, kommt es - je nach Anzahl der geöffneten Tabs - vor, dass der Reiter für die Tabelle nicht sichtbar ist...

@MPirnstill: Habe es jetzt einmal mit Threads gelöst, laut meiner Kopfzeitmessung liegt das öffnen bei "nur" noch 1-2 Sekunden (diese Version ist allerdings noch nicht veröffentlicht)

Eichhoernchen 26. Apr 2006 18:43

Re: myMoviesXP: Die Filmverwaltung
 
Mir ist noch folgendes aufgefallen:

ich habe einen Film hinzugefügt, der kein Cover hatte, heruntergeladen wurde aber na.gif, diese lässt sich aber nicht betrachten[windows bildbetrachter]. Nun versucht das Programm diese beim Programmstart zu laden, okay gibt dann nen Fehler. Aber wenn ich dann im Film-Browser gucke, sind alle Filme ab dem mit dem na.gif Cover ohne Cover oder mit dem Cover vom 1. Film, in der Detailansicht haben alle[bis auf den mit na.gif] ein Cover!


Habe bei dem Beispiel nach Animatrix gesucht und habe dann Second Renaissance Part I, The [Kurzfilm] ausgewählt!
Dann sollte der Fehler kommen außer man entfernt das gif aber das ist ja klar.

MCXSC 26. Apr 2006 19:44

Re: myMoviesXP: Die Filmverwaltung
 
Zitat:

heruntergeladen wurde aber na.gif, diese lässt sich aber nicht betrachten
Liegt denk ich mal daran, dass Delphi ohne Kompo keine GIFSs unterstützt...?

Aber wenn ich dann im Film-Browser gucke, sind alle Filme ab dem mit dem na.gif Cover ohne Cover oder mit dem Cover vom 1. Film, in der Detailansicht haben alle[bis auf den mit na.gif] ein Cover!
Salopp gesagt: Ein Fehler resultiert aus dem anderen.... ;-)

Zitat:

Habe bei dem Beispiel nach Animatrix gesucht und habe dann Second Renaissance Part I, The [Kurzfilm] ausgewählt!
Für den Film gibt es auf OFDB.de kein Cover, deshalb auch die na.gif (siehe hier).

^^^Werde dann mal noch ne Prüfung einbauen, ob es ein Cover für den Film gibt und ob es auch im JPEG-Format vorliegt, dann sollte der Fehler behoben sein. Vielen Dank für den Hinweis.

leddl 5. Mai 2006 17:18

Re: myMoviesXP: Die Filmverwaltung
 
Moin moin!

Wie sieht es denn aus mit der neuen Version? ;)

MCXSC 6. Mai 2006 11:37

Re: myMoviesXP: Die Filmverwaltung
 
Ich stze bereits daran. Wird wohl doch etwas mehr Zeit in Anpruch nehmen...

[EDIT:] Wird wohl doch erst einmal nur eine Fehlerbereinigte und ein wenig erweiterte Version. Werde dann komplett neu coden, diesesmal mit Hilfe einer richtigen DB... Da wird es dann viele neue Features und Funktionen geben, vielleicht auch einen neuen oder abgeänderten Namen... myMoviesVista wär doch was feines ;-) Aber mal sehen...

MCXSC 8. Mai 2006 21:52

Re: myMoviesXP: Die Filmverwaltung
 
Wer Interesse hat, bei der Entwicklung von der Version 10 beratent und testent zu helfen, kann sich im Forum unter http://filmverwaltung.mcxsc-online.de/ anmelden...

leddl 8. Mai 2006 22:01

Re: myMoviesXP: Die Filmverwaltung
 
Generell ja. Nur hab ich momentan überhaupt keine Zeit für ein größeres Projekt. Zum einen weil ich momentan noch in der Theoriephase bin und demnächst Klausuren anstehen und zum anderen, weil ich dann nach den Klausuren wohl bereits ein anderes Projekt haben werden. Aber ich kann mich ja mal melden, falls doch Zeit da ist. ;)

MCXSC 8. Mai 2006 22:04

Re: myMoviesXP: Die Filmverwaltung
 
Soll ja eigentlich nichts anderes sein, als das was du hier gemacht hast... Nur ebend strukturierter und aufgeteilter - ebend nicht alles in einem Thread ;-))...

leddl 8. Mai 2006 22:09

Re: myMoviesXP: Die Filmverwaltung
 
Ah, weil du die ganze Zeit von "Entwicklung" redest :lol: Das is natürlich was anderes ;)

MCXSC 24. Dez 2006 15:57

Re: myMoviesXP: Die Filmverwaltung
 
von "myMovies" (bzw. neu: "myCine") gibt es nun mal eine kleine Testversion, die hoffentlich soweit fehlerfrei ist, dass man sie offiziell veröffentlichen kann :)

Wer will darf gerne auf Fehlersuche gehen...

Den Download gibts hier

drschubi 24. Dez 2006 23:52

Re: myMoviesXP: Die Filmverwaltung
 
Hallo Marcel, gefällt mir gut das Programm.
Mir ist aufgefallen, daß in der Coveransicht sich das Fenster nicht schliessen läßt, wenn ich den "Fenster schliessen"-Button anklicke.

Die Suchfunktion ist eine Komponente?

Auch die Watch a movie today Funktion ist super, würde den Rechtsklick aber verbieten.

Gruß aus Filderstadt und frohe Weihnachtsfeiertage.

René

MCXSC 25. Dez 2006 00:45

Re: myMoviesXP: Die Filmverwaltung
 
Zitat:

Zitat von drschubi
Mir ist aufgefallen, daß in der Coveransicht sich das Fenster nicht schliessen läßt, wenn ich den "Fenster schliessen"-Button anklicke.

Behoben

Zitat:

Zitat von drschubi
Die Suchfunktion ist eine Komponente?

Hm?

Zitat:

Zitat von drschubi
Auch die Watch a movie today Funktion ist super, würde den Rechtsklick aber verbieten.

Ist eingebaut.

Zitat:

Zitat von drschubi
frohe Weihnachtsfeiertage.

Dir und allen anderen natürlich auch! :mrgreen:

drschubi 25. Dez 2006 07:47

Re: myMoviesXP: Die Filmverwaltung
 
Hallo Marcel,

ich meine natürlich die Suchbox oben rechts, sorry hab mich blöd ausgedrückt.
Ist das eine Komponente oder wie hast Du die realisiert?
Gruß René

MCXSC 25. Dez 2006 13:14

Re: myMoviesXP: Die Filmverwaltung
 
Zitat:

Zitat von drschubi
die Suchbox oben rechts,
Ist das eine Komponente oder wie hast Du die realisiert?

Nee sie besteht im Prinzip nur aus 3 Grafiken und einer Editbox... Ich denke mal Komponenten dafür gibts, nur so siehts schöner aus :D

jmit 26. Dez 2006 16:56

Re: myMoviesXP: Die Filmverwaltung
 
Hallo MCXSC,

ich hatte Dir heute schon eine Mail geschickt. Ich habe mir die rc1 des "myMoviesXP"-Nachfolgers "myCine" heruntergeladen, aber beim Hinzufügen von Filmen läßt sich das aktuelle Fenster nicht mehr schliessen. Ich kann das Programm nur über den Taskmanager schliessen. Dies passiert aber nicht beim Hinzufügen aller Filme. Es tritt nur sporadisch auf.

Was mich aber viel mehr interessiert:
Warum lassen sich bei der Version 9.0.1 keine Datenbanken erstellen. Ich habe einen Rechner mit allen Updates für Windows XP, und nichts verändert. Muss ich noch zusätzlich etwas installieren? Die Converter muss ich ja sicherlich nicht verwenden, oder? Macht ja eigentlich keinen Sinn, da das Programm die Datenbank im richtigen Format erstellen wird.

Gruß Jörg

MCXSC 26. Dez 2006 18:47

Re: myMoviesXP: Die Filmverwaltung
 
Zitat:

Zitat von jmit
beim Hinzufügen von Filmen läßt sich das aktuelle Fenster nicht mehr schliessen. Ich kann das Programm nur über den Taskmanager schliessen. Dies passiert aber nicht beim Hinzufügen aller Filme. Es tritt nur sporadisch auf.

Das ist auch etwas, was ich nicht nachvollziehen kann, da diser Fehler bei mir noch nie aufgetreten ist... :(

Zitat:

Zitat von jmit
Warum lassen sich bei der Version 9.0.1 keine Datenbanken erstellen. Ich habe einen Rechner mit allen Updates für Windows XP, und nichts verändert. Muss ich noch zusätzlich etwas installieren? Die Converter muss ich ja sicherlich nicht verwenden, oder? Macht ja eigentlich keinen Sinn, da das Programm die Datenbank im richtigen Format erstellen wird.

Nee, bei einer neuen DB ist der Converter uninteressant. Aber auch das Problem habe ich auch nach mehrmaligem Testen nicht gehabt, und auch sonst habe ich davon noch nie gehört... :( Kannst du mir vll. die Datenbankdatei per E-Mail zukommen lassen?

jmit 26. Dez 2006 19:11

Re: myMoviesXP: Die Filmverwaltung
 
Hallo,

ich habe Dir meine Ergebnisse per Mail zugeschickt.

Gruß Jörg

MCXSC 26. Dez 2006 19:18

Re: myMoviesXP: Die Filmverwaltung
 
Okay, den Fehler mit der nicht zuladenden DB habe ich gefunden. Öffne mal die Datei mit dem Notepad und ersetze das "ö" mal durch "oe". Ich weiß zwar nicht wieso er damit nicht klarkommt (weil Umlaute bei den Filmen funktionieren), aber das war wohl der Fehler...

MrKnogge 26. Dez 2006 19:48

Re: myMoviesXP: Die Filmverwaltung
 
Gibt es einen DB-Converter in das 10er Format ?

MCXSC 26. Dez 2006 19:52

Re: myMoviesXP: Die Filmverwaltung
 
Zitat:

Zitat von MrKnogge
Gibt es einen DB-Converter in das 10er Format ?

Aktuell noch nicht, wird es aber geben.

//Edit: So, habe mal einen kleinen Converter hochgeladen (Download)

Und auch eine neue Version (rc2), ist online (es wurden diverse Fehlerchen beseitigt) --> Download

phXql 30. Dez 2006 11:12

Re: myMoviesXP: Die Filmverwaltung
 
Liste der Anhänge anzeigen (Anzahl: 2)
Hi MCXSC,

ich hab MyMoviesXP Version 9.0.1 vom 22.04.2006. Mir sind beim Einpflegen meiner Filme ein paar Bugs aufgefallen:

- Online-Update: Er sagt, es ist keine neue Version verfügbar, zeigt aber einen Downloadlink an (Siehe Screenshot update.png)
- Darsteller-Kategorie im Navigationsbaum: Es werden zwar die Darsteller der Filme angezeigt, aber wenn ich dann auf einen Darsteller klicke, dann erhalte ich eine leere Liste. Sollten da nicht die Filme erscheinen, wo dieser Schauspieler mitspielt? (Siehe darsteller.png)
- Sporadischer Bug: Manchmal wird mir das Genre des Films in der Spalte Regisseur angezeigt. Konnte noch nicht ausmachen, wann dieser Fehler auftritt.

Ansonsten super Programm :thumb:

// Edit: Ach ja, was ich vermisse ist eine Funktion, mit der man mehrere Filme gleichzeitig bearbeiten kann, z.B. TV-Aufnahme bei mehreren Gleichzeitig anhakeln.

// Edit 2: Beim Holen der Informationen zu einem Film von der Online-Datenbank wird manchmal die Beschreibung nicht geholt. Klicke ich dann nochmal auf "Informationen herunterladen", dann erscheint die Beschreibung.

MCXSC 25. Jun 2007 01:56

Re: myCine: Die Filmverwaltung
 
Seit heute Nacht ist es soweit: "myCine" steht in der Version 0.9 zum Download bereit.

Außerdem habe ich den ersten Post mal von "myMoviesXP" zu "myCine" bearbeitet, da "myMoviesXP" nicht mehr entwickelt wird, sondern es eine Änderung von "myMoviesXP 9.1" zu "myCine 0.x" gab.^^

MCXSC 27. Jun 2007 00:46

Update
 
Zitat:

Zitat von MCXSC
Aktuellste Version: 0.9.1 (27. Juni 2007)

Änderungen zur Version 0.9 zu 0.9.1

» Verbesserung im Auto-Update
» Datenbanken können über ziehen ins "myCine"-Fenster (Drag'n'Drop) geladen werden
» Korrektur beim runterladen der Beschreibung vom Filmserver
» Kleinere Fehlerbehebungen

Links:

» Download von "myCine"
» F.A.Q.
» KOSTENLOSE Registrierung


MCXSC 30. Jun 2007 00:16

Re: myCine: Die Filmverwaltung
 
Hmm...erst so einen riesen Andrang und jetzt gar nichts mehr? :D :wiejetzt: :angel2:

calculon 30. Jun 2007 18:36

Re: myCine: Die Filmverwaltung
 
Aaargh,

nachdem ich über 150 Filme eingebunden hab' lässt' sich nix mehr über ofdb.de einladen, dann kommt immer folgende Fehlermeldung. Neustart und so bringt au nix mehr :wall:

Zitat:

---------------------------
mCine
---------------------------
Listenindex überschreitet das Maximum (0)
---------------------------
OK
---------------------------
Dann noch zwei Bugs:

(1) "Zuletzt bearbeitet am" lässt sich über das PopUpMenu, das beim Rechtsklick auf die Leiste, erscheint nicht an- bzw. ausschalten.

(2) Hier ein reproduzierbarer Fehler:
Links bei den Lupen-Icons, wenn "Genre" geöffnet ist, und ein Genre ausgewählt, beispielsweise "Drama"; man einen Eintrag in der Filmliste anschließend bearbeitet und dabei das Genre wechselt kommt folgende schöne Meldung, wenn man dann den Tab schließt:

Zitat:

---------------------------
mCine
---------------------------
Zugriffsverletzung bei Adresse 00458294 in Modul 'myCine.exe'. Lesen von Adresse 00000004.
---------------------------
OK
---------------------------
So nach soviel Kritik auch was schönes; ich find' des Programm im Design und in der Bedienung spitze :thumb: und würde es gern' weiterbenutzen...:stupid:

Zu meinem ersten Problem, ist da was an der Datenbankstruktur kaputt gegangen?

Gruß

Calculon
--

MCXSC 30. Jun 2007 19:48

Re: myCine: Die Filmverwaltung
 
Zitat:

Zitat von calculon
nachdem ich über 150 Filme eingebunden hab' lässt' sich nix mehr über ofdb.de einladen, dann kommt immer folgende Fehlermeldung. Neustart und so bringt au nix mehr :wall:

Hmmm... ich hab über 200 und es funzt. Werd mir aber nochmal genauer anschauen wo der Fehler sein _könnte_... Wann kommt denn die Meldung?

Zitat:

Zitat von calculon
(1) "Zuletzt bearbeitet am" lässt sich über das PopUpMenu, das beim Rechtsklick auf die Leiste, erscheint nicht an- bzw. ausschalten.

Oops :) Wird behoben...

Zitat:

Zitat von calculon
(2) Hier ein reproduzierbarer Fehler:
Links bei den Lupen-Icons, wenn "Genre" geöffnet ist, und ein Genre ausgewählt, beispielsweise "Drama"; man einen Eintrag in der Filmliste anschließend bearbeitet und dabei das Genre wechselt kommt folgende schöne Meldung, wenn man dann den Tab schließt

Wird auch behoben... der Fehler war mir auf andere Weise bekannt.

Zitat:

Zitat von calculon
Zu meinem ersten Problem, ist da was an der Datenbankstruktur kaputt gegangen?

Nö, sollte nicht. Solange die DB nach einem Neustart wieder lädt...

calculon 30. Jun 2007 20:21

Re: myCine: Die Filmverwaltung
 
Zitat:

Zitat von MCXSC
Hmmm... ich hab über 200 und es funzt. Werd mir aber nochmal genauer anschauen wo der Fehler sein _könnte_... Wann kommt denn die Meldung?

Also der Fehler tritt inzwischen nicht mehr auf nachdem ich einen neuen Film hinzugefügt habe. Ich versuche den Tathergang aber nochmal zu rekonstruieren:

Ich wollte Filmdaten vom Server ("Informationen herunterladen") laden. Nachdem etwa die Hälfte der Informationen darunter erschienen war, kam eine Errormeldung, dass kein Internetzugang mehr bestünde. Danach trat der Fehler "Listenindex überschreitet das Maximum (0)" jedesmal auf, wenn ich für bestehende Filmeinträge Filmdaten herunterladen wollte und zwar einige Sekunden nach dem Klick auf "Informationen herunterladen". Erst nachdem ich einen neuen Filmeintrag gemacht hatte, funktionierte alles wieder so wie gehabt.

[edit]Achja, was ich noch etwas nervig finde ist das flackern beim Scrollen in der Listbox. Ließe sich das denn ohne größeren Aufwand beheben?[/edit]

Gruß

Calculon
--


Alle Zeitangaben in WEZ +1. Es ist jetzt 20:09 Uhr.
Seite 3 von 9     123 45     Letzte » 

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf