Delphi-PRAXiS

Delphi-PRAXiS (https://www.delphipraxis.net/forum.php)
-   Multimedia (https://www.delphipraxis.net/16-multimedia/)
-   -   Delphi Buttons auf Panel zentrieren ? (https://www.delphipraxis.net/81062-buttons-auf-panel-zentrieren.html)

-=cats=- 20. Nov 2006 10:14


Buttons auf Panel zentrieren ?
 
Liste der Anhänge anzeigen (Anzahl: 2)
Hi :hi:

Kann man Buttons irgendwie auf einem Panel zentrieren ?
Also, das Problem ist, das die Buttons sich nicht automatisch
ausrichten, wenn ich meine Form auf Vollbild vergrößere.
Ich habe dem Panel gesagt, es soll sich alTop ausrichten.
Nur bei den Buttons ... irgendwie finde ich da nichts.
Die sollen sich gleichmäßig auf dem Panel verteilen, so dass es
nich so blöd aussieht, wenn sie alle in einer Ecke hängen ...
(Siehe Screenshot).
Ich habe es schon versucht, in dem ich den Buttons auch
alTop oder alClient gesagt habe. Aber dann verzerrt sich das alles
total ... :-(

Screenshots sind angehängt :-)
Die Buttons haben noch keine Funktion, deshalb sehen sie erst mal
so grausig aus :-)
Aber geht ja nicht ums aussehen sondern erst mal um das Ausrichten :-)

Gruß,
-=cats=- :coder:

SirThornberry 20. Nov 2006 10:17

Re: Buttons auf Panel zentrieren ?
 
bei buttons sollte das auch gehen. Allerdings nicht über den Objectinspektor sondern per Quelltext.

-=cats=- 20. Nov 2006 10:18

Re: Buttons auf Panel zentrieren ?
 
Cool das war ne schnelle Antwort :-)
Wie meinst Du das, "im Quelltext" ?
Was sollte ich da am besten angeben ?

Luckie 20. Nov 2006 10:19

Re: Buttons auf Panel zentrieren ?
 
In dem du dir left und top ausrechnest und dynamisch zur Laufzeit setzt,

Hawkeye219 20. Nov 2006 10:21

Re: Buttons auf Panel zentrieren ?
 
Vielleicht hilft auch ein Blick in diesen Thread.

Gruß Hawkeye

SirThornberry 20. Nov 2006 10:22

Re: Buttons auf Panel zentrieren ?
 
ich meinte mit Quelltext:
Delphi-Quellcode:
Button1.Align = DeineWahl;

-=cats=- 20. Nov 2006 10:28

Re: Buttons auf Panel zentrieren ?
 
Juhuu es hat funktioniert :-)
Vielen Dank !!

Ich habe einfach bei allen Buttons die Anchors auf false gesetzt :-)
(Stand in dem Beitrag)
Jetzt richten sie sich automatisch aus :-)
Ich hoffe, dadurch treten jetzt nicht noch andere Probleme auf
aber vorerst läuft alles :-)


Alle Zeitangaben in WEZ +1. Es ist jetzt 00:49 Uhr.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf