Delphi-PRAXiS

Delphi-PRAXiS (https://www.delphipraxis.net/forum.php)
-   Sonstige Fragen zu Delphi (https://www.delphipraxis.net/19-sonstige-fragen-zu-delphi/)
-   -   Delphi Debugger auf einmal sehr langsam (Einstellungen verändert?) (https://www.delphipraxis.net/88953-debugger-auf-einmal-sehr-langsam-einstellungen-veraendert.html)

CK_CK 23. Mär 2007 15:07


Debugger auf einmal sehr langsam (Einstellungen verändert?)
 
Hallo,
ich fang' erstmal ganz am Anfang an.
Ich habe ein Programm geschrieben, was eine Exception mehrfach ausgelöst hat und deswegen aus versehen in der Meldung auf "Diesen Exceptiontyp ignorieren" geklickt.
Danach habe ich sämtliche Einstellungen durchsucht und versucht das wieder rückgängig zu machen (hab's nachher auch geschafft...).

Aber irgendwie habe ich wohl noch irgendwas umgestellt. Wenn ich jetzt nämlich eine Programm aus Delphi heraus starte, dann braucht Delphi erstmal ca. 4 Sekunden zum laden der Anwendung (nicht zum kompilieren!) und die Anwendung selbst ruckelt (Listboxen scrollen nur unter heftigstem ruckeln, etc.). Wenn ich die Anwendung über die .exe starte, ist sie "normal" schnell.

Also scheint irgendwas im Debugger falsch zu sein (vielleicht protokolliert er irgendwas zu viel). Weiß jemand von euch Rat, was falsch eingestellt sein könnte?
So wie es jetzt ist, kann ich nicht arbeiten... :(

Viele Grüße und danke für's durchlesen des langen Textes :stupid:,
Chris

CK_CK 24. Mär 2007 11:18

Re: Debugger auf einmal sehr langsam (Einstellungen veränder
 
Hallo,
ich hab' das Problem gelöst. Ich habe einfach den integrierten Debugger deaktiviert, Delphi neu gestartet und dann den Debugger wieder aktiviert.
Jetzt funktioniert alles wieder so schnell wie früher.
Was genau das Problem war kann ich allerdings nicht sagen... :?

Naja, haupsache es funktioniert wieder alles... :stupid:

Viele Grüße,
Chris

Sankt Rochus 30. Nov 2012 10:29

AW: Debugger auf einmal sehr langsam (Einstellungen verändert?)
 
Schön, das ich jetzt erst mal so einen alten Thread wieder aufrollen lassen muss.
Tatsache ist jedenfalls, dass ich an demselben Problem hänge.
Ich sehe es nur leider nicht als Lösung, das integrierte Debuggen abzuschalten,
da damit sämtliche Debug-Funktionalitäten, die die Delphi-IDE zur Verfügung stellt,
deaktiviert werden. Dazu gehört beispielsweise das zeilenweise Debuggen oder einfach nur das
Anhalten des Programmablaufen mittels Breakpoints.

Auch bei mir sind ggf. die Delphi-Optionen schuld. Bei anderen Projekten läuft das Debuggen genauso langsam,
wobei bei kleineren Projekten (z.B. leere Forms-Anwendung) die Performance-Schwäche nicht sehr ins Gewicht fällt.
Ich gehe deshalb nicht von falschen Projekteinstellungen aus, sondern wirlich von fehlerhaften globalen Delphi-Einstellungen.

himitsu 30. Nov 2012 11:21

AW: Debugger auf einmal sehr langsam (Einstellungen verändert?)
 
Welche Delphi-Version?

Alle Updates und eventuell vorhandene (nötige) HotFixes installiert?


PS:
vor Delphi 2006 den FastMM nutzen (weiß nicht, ob man den notfalls über ShareMem auch in die alten IDEs reinbekommt)

und schau dich auch mal dort um (das sind quasi "inoffizielle" BugFixes)
http://andy.jgknet.de/blog/ide-tools/
(vorallem DelphiSpeedUp und IDE-Fix-Pack, bzw. eventuell auch die DDevExtensions)

Sankt Rochus 5. Dez 2012 06:59

AW: Debugger auf einmal sehr langsam (Einstellungen verändert?)
 
Dort habe ich nun gepostet, was mir zur Lösung verholfen hat.

´http://www.delphipraxis.net/171887-debuggen-der-delphi-ide-extrem-langsam.html#post1194376

Sorry nochmal für das Crossposten, hätte nicht gedacht, dass auf einen so alten Thread noch jemand antwortet.
Danke für eure Hilfe!!!


Alle Zeitangaben in WEZ +1. Es ist jetzt 13:14 Uhr.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf