AGB  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Netzwerke Delphi Bild im TWebbrowser Edit-Modus verschieben...

Bild im TWebbrowser Edit-Modus verschieben...

Ein Thema von horst · begonnen am 23. Jan 2004 · letzter Beitrag vom 24. Jan 2004
Antwort Antwort
horst

Registriert seit: 1. Jul 2003
347 Beiträge
 
Delphi 2007 Professional
 
#1

Bild im TWebbrowser Edit-Modus verschieben...

  Alt 23. Jan 2004, 23:40
Wer weiß wie ich ein Bild/Image im TWebbrowser Edit-Modus verschieben kann?
ich würde es ja am liebsten so machen, (s. code unten) aber das
funktioniert nur bei elementen (div), die per stylesheet mit absoluter positionierung definiert wurden.
Das Problem wäre dann ja das Einfügen neuer Bilder.
Wäre aber schon froh wenn ich die Bilder einfach mit der Maus verschieben könnte...

Delphi-Quellcode:
 HTMLDocument2Ifc: IHTMLDocument2;
begin
  HTMLDocument2Ifc := WebBrowser1.Document as IHTMLDocument2;
  (WebBrowser1.Document as IHTMLDocument2).designMode := 'On';
  HTMLDocument2Ifc.ExecCommand('2D-Position', false, true);
  HTMLDocument2Ifc.ExecCommand('LiveResize', true, true);
  Mit Zitat antworten Zitat
Benutzerbild von APP
APP

Registriert seit: 24. Feb 2003
Ort: Graz (A)
705 Beiträge
 
Delphi 7 Enterprise
 
#2

Re: Bild im TWebbrowser Edit-Modus verschieben...

  Alt 24. Jan 2004, 15:50
Hallo Horst,
ich habe hier ein HTML-Bookmarklet,
Code:
<HTML>
<SCRIPT LANGUAGE=javascript>
[color=red]var __w=document.body.contentEditable = 'true'; [/color]
document.designMode='on';
[color=red]void 0;[/color]
[color=red]if(__w!=null)document.write(__w);[/color]
</SCRIPT>
</HTML>
das z.B. mit der DP Webseite funktioniert, wo ich im Code zumindest keine DIV Tags entdecken konnte.
Ich bin kein HTML-Profi, aber vielleicht hilft es Dir weiter...
Armin P. Pressler

BEGIN
...real programmers are using C/C++ - smart developers Delphi;
END;
  Mit Zitat antworten Zitat
horst

Registriert seit: 1. Jul 2003
347 Beiträge
 
Delphi 2007 Professional
 
#3

Re: Bild im TWebbrowser Edit-Modus verschieben...

  Alt 24. Jan 2004, 17:29
Danke für deine Antwort,
(WebBrowser1.Document as IHTMLDocument2).designMode := 'On'; verwende ich ja schon.
Die DIV-Tags sind nur nötig wenn:
HTMLDocument2Ifc.ExecCommand('2D-Position', false, true); benutzt wird.
Habe den Fehler gefunden...
hatte den EmbeddetWebbrowser benutzt, der kann das wohl irgendwie nicht.
Grüße Horst
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 14:11 Uhr.
Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2014 by Daniel R. Wolf