AGB  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

TMainMenu: Bug

Ein Thema von BlackSeven · begonnen am 12. Apr 2012 · letzter Beitrag vom 14. Apr 2012
Antwort Antwort
BlackSeven

Registriert seit: 25. Sep 2004
78 Beiträge
 
Delphi XE2 Enterprise
 
#1

TMainMenu: Bug

  Alt 12. Apr 2012, 11:24
Hallo!


Ist dem MainMenu eine Image-Liste zugewiesen, werden die "SubMenu-Pfeile" unter Windows 7 nicht angezeigt.
Kann das jemand bestätigen?
Miniaturansicht angehängter Grafiken
mainmenu.png  
  Mit Zitat antworten Zitat
Benutzerbild von Bummi
Bummi

Registriert seit: 15. Jun 2010
Ort: Augsburg Bayern Süddeutschland
3.449 Beiträge
 
Delphi XE3 Enterprise
 
#2

AW: TMainMenu: Bug

  Alt 12. Apr 2012, 11:33
Kann ich zumindest für XE nicht bestätigen, wenn der Imageindex an der entscheidenden Stelle -1 ist
Miniaturansicht angehängter Grafiken
menu.png  
Thomas Wassermann H₂♂
Das Problem steckt meistens zwischen den Ohren
DRY DRY KISS
H₂ (wenn bei meinen Snipplets nichts anderes angegeben ist Lizenz: WTFPL)
  Mit Zitat antworten Zitat
BlackSeven

Registriert seit: 25. Sep 2004
78 Beiträge
 
Delphi XE2 Enterprise
 
#3

AW: TMainMenu: Bug

  Alt 12. Apr 2012, 11:46
Danke.
Fehler tritt bei mir immer auf. Egal ob ein Image per ImageIndex zugewiesen ist oder nicht.
  Mit Zitat antworten Zitat
Benutzerbild von SimplySimon
SimplySimon

Registriert seit: 7. Jun 2011
Ort: NRW
38 Beiträge
 
Delphi XE2 Professional
 
#4

AW: TMainMenu: Bug

  Alt 13. Apr 2012, 19:57
Ich glaube der Pfeil wird generell weiß beim OnMouseOver-Ereignis und verschwindet nicht.
Da ist er auf jeden Fall wenn es ein Untermenü gibt
Miniaturansicht angehängter Grafiken
menu.png  
  Mit Zitat antworten Zitat
BlackSeven

Registriert seit: 25. Sep 2004
78 Beiträge
 
Delphi XE2 Enterprise
 
#5

AW: TMainMenu: Bug

  Alt 14. Apr 2012, 09:48
Hier mal ein Screenshot der Delphi-IDE. So sollte das Hauptmenü eigentlich aussehen.
Miniaturansicht angehängter Grafiken
ide.png  
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
26.398 Beiträge
 
Delphi XE3 Professional
 
#6

AW: TMainMenu: Bug

  Alt 14. Apr 2012, 10:00
Theoretisch sollte es eigentlich nichts mit dem Aussehn zu tun haben (optisch sollten sie ja gleich sein),
aber das im Delphi ist kein TMainMenu ... du könntest es aber notfalls dennoch mal mit der TActionMainMenuBar versuchen.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2013
  Mit Zitat antworten Zitat
BlackSeven

Registriert seit: 25. Sep 2004
78 Beiträge
 
Delphi XE2 Enterprise
 
#7

AW: TMainMenu: Bug

  Alt 14. Apr 2012, 10:38
Zitat:
das im Delphi ist kein TMainMenu
Stimmt. Ist eine TActionMainMenuBar. Werde mein Glück mal damit versuchen.
Oder vielleicht doch auf Ribbon umsatteln.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 04:07 Uhr.
Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2014 by Daniel R. Wolf