AGB  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Programmieren allgemein MainMenu unsichtbar nach Update auf XE10.2.2

MainMenu unsichtbar nach Update auf XE10.2.2

Ein Thema von norwegen60 · begonnen am 11. Jan 2018 · letzter Beitrag vom 12. Jan 2018
Antwort Antwort
norwegen60

Registriert seit: 23. Dez 2007
228 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#1

MainMenu unsichtbar nach Update auf XE10.2.2

  Alt 11. Jan 2018, 17:36
Hallo,

ich habe am Wochenende von XE10.2 auf XE10.2.2 upgedatet. Ich habe zwei Anwendung ohne Änderungen einfach neu kompiliert.
Eine Anwendung funktioniert einwandfrei.
Bei der zweiten ist auf manchen Rechnern das MainMenu unsichtbar.
Bei manchen Rechnern wurde es nach mehreren Starts sichtbar, bei manchen war es von Anfang an sichtbar.
Die ShortKeys, die manchen Einträgen hinterlegt sind, funktionieren überall.
Das MainMenu ist per IDE angelegt und im ganzen Prpgramm gibt es keinen Zugriff auf MainMenu1. Es müsste also auf allen Rechnern gleich gehandhabt werden.


Kennt jemand das Problem und hat eine Lösung oder einen Lösungsansatz?

Vielen Dank
Gerd
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
5.993 Beiträge
 
Delphi XE4 Professional
 
#2

AW: MainMenu unsichtbar nach Update auf XE10.2.2

  Alt 11. Jan 2018, 20:57
Hallo,
ist das wirklich immer die gleiche Installation?

Erst mal:
Minimal-Beispiel (neues Projekt) erzeugen
und auf den entsprechenden Rechner testen.
Heiko

Geändert von hoika (11. Jan 2018 um 20:59 Uhr)
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
1.206 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#3

AW: MainMenu unsichtbar nach Update auf XE10.2.2

  Alt 12. Jan 2018, 08:01
Könnte das eventuell auch an Win10 1709 Update liegen ?
Ich habe sowas ähnliches schon bei anderen Programmen, z.B. Tobit David, gesehen,
wo Fenster nicht mehr sichtbar oder einfach weiss sind, erst nach Pgn-Update sind sie wieder da.

Rollo
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
5.269 Beiträge
 
Delphi 10.2 Tokyo Architect
 
#4

AW: MainMenu unsichtbar nach Update auf XE10.2.2

  Alt 12. Jan 2018, 10:50
Sind die Laufzeit-Themes in dem Projekt aktiv? Es häufen sich in letzter Zeit die Fälle, bei denen Programme ohne aktive Laufzeit-Themes massive Darstellungsprobleme haben.
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
norwegen60

Registriert seit: 23. Dez 2007
228 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#5

AW: MainMenu unsichtbar nach Update auf XE10.2.2

  Alt 12. Jan 2018, 16:20
Sind die Laufzeit-Themes in dem Projekt aktiv?
Wenn die Einstellung Projekt - Optionen - Anwendung gemeint ist. Dort ist der Haken bei "Laufzeit-Themes aktivieren" gesetzt, aber ausgegraut, da als Manifestdatei "Benutzerdefiniert" gesetzt ist. Als Manifest ist dann None angegeben. Setze ich die Auswahl auf "Automatisch erzeugen" geht das Hauptfenster noch auf. Bei einigen Child-Fenstern bekomme ich dann aber Exceptions. Habe nie was mit den Themes gemacht. Werde es mir anschauen woher die Exceptions kommen. Auf die schnelle lande ich mit dem Debugger im CPU-Fenster.

ist das wirklich immer die gleiche Installation?.
Alle Rechner rufen die gleiche EXE direkt in Netzwerk auf. Die wenigen INI-Daten, die benötigt werden, liegen im Programmverzeichnis. Was ich aber mal prüfen kann. Persönliche Einstellungen, z.B. letzte Fensterposition werden in der Registry gepeichert. Ich lösche am Montag mal den kompletten Registry-Pfad.
Und wie schon gesagt: Eine andere Anwendung funktioniert einwandfrei.
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie
(Moderator)

Registriert seit: 29. Mai 2002
36.752 Beiträge
 
Delphi 2006 Professional
 
#6

AW: MainMenu unsichtbar nach Update auf XE10.2.2

  Alt 12. Jan 2018, 16:44
Und was passiert, wenn die Exe lokal auf den betreffenden Rechner gestartet wird? Eventuell bereitet das Starten über das Netzwerk Probleme.
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
norwegen60

Registriert seit: 23. Dez 2007
228 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#7

AW: MainMenu unsichtbar nach Update auf XE10.2.2

  Alt 12. Jan 2018, 18:28
Und was passiert, wenn die Exe lokal auf den betreffenden Rechner gestartet wird?
Drei Varianten:
1. Citrix: Bisher keien Probleme bekannt
2. Lokale Installation: Ca. 60% arbeiten korrekt
3: Start vom Netzlaufwerk: Auf 2 Rechnern geht es, bei 8 geht es nicht

Bin aber nicht sicher, ob das Zufall ist. Im Moment weiß ich auch nicht, welche mit Win7 und welche mit Win 10 laufen

Auf meinem Entwickler-PC (Win10) hatte ich folgendes Verhalten:
  • Keinerlei Problem mit der auf dem PC kompilierten Version
  • Kopieren dieser Version aif Netzlaufwerk und Start vom Netlaufwerk => ohne Menü
  • Kopieren dieser Version auf lokales Laufwerk => mit Menü
  • Nach mehreren Wechseln plötzlich auch Start aus dem Netz mit Menü.
  • Danach klappte es bei mir immer mit Menü
  • Wie gesagt gibt es aber auch Fälle, wo der Start vom lokalen Laufwerk immer ohne Menü erfolgt

Werde am Montag die aktuellen Sources mit XE10.2 kompilieren und Testen ob es dann wieder bei allen klappt. Rückspielen der Vorversion hat Problem überall behoben.

Geändert von norwegen60 (12. Jan 2018 um 19:08 Uhr)
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
1.206 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#8

AW: MainMenu unsichtbar nach Update auf XE10.2.2

  Alt 12. Jan 2018, 19:10
Zitat:
1. Citrix: Bisher keien Probleme bekannt
2. Lokale Installation: Ca. 60% arbeiten korrekt
Exakt, kann ich bestätigen.
Ich rede jetzt nicht von Delphi Anwendungen, aber ziemlich massive Probleme auf lokalen Rechnern mit Win10 Creators Fall Update und diversen Programmen.
Citrix läuft gut, weiss aber im Moment gar nicht welche Windows-Version das ist.

Nach Updates der Programme war es dann aber oft OK, habe jetzt nicht gecheckt womit die entwickelt wurden (David Tobit, FoxitReader, um mal zwei zu nennen).

Rollo
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 23:19 Uhr.
Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2017 by Daniel R. Wolf