Einzelnen Beitrag anzeigen

Benutzerbild von Ralf Kaiser
Ralf Kaiser

Registriert seit: 21. Mär 2005
Ort: Wuppertal
926 Beiträge
 
Delphi 10.3 Rio
 
#1

Komponenteninstallation XE5 schlägt fehl [gelöst]

  Alt 8. Jan 2014, 10:53
Halli Hallo,

Wir habe da einige selbst entwickelte Komponenten die bisher immer in allen Delphi-Versionen problemlos installiert werden konnten.

Wenn ich diese nun in Delphi XE5 installieren will passiert etwas sehr seltsames (ich kann es mir zumindest nicht erklären):

Neben einer Reihe von anderen Komponenten existiert in diesem Package eine Komponente, nennen wir sie mal TAbgeleitet, die von einer Basisklasse, nennen wir sie mal TBasisklasse, abgeleitet ist. Die TBasisklasse befindet sich in einem anderen Package und ist bereits in der IDE registriert.

Registriert wird diese Komponente (TAbgeleitet) mit diesem Aufruf:

Delphi-Quellcode:

RegisterComponents('Komponenten', [TAbgeleitet]);
Daraufhin erhalte ich dann diese Fehlermeldung beim der Installation in der IDE:

Code:
---------------------------
Fehler
---------------------------
Registrierungsprozedur, dclMyPackage190.Register in Package dclMyPackage190.bpl hat die Exception-Klasse EFilerError: Klasse mit der Bezeichnung TBasisKlasse existiert bereits ausgelöst.
---------------------------
OK  
---------------------------
Kommentiere ich diese Registrierungszeile aus dann wird das Package ohne Probleme in der IDE registriert (es enthält noch eine Reihe anderer Komponenten).

In allen früheren Delphi-Versionen wurde diese Komponente immer anstandslos installiert. In DXE5 nicht.

Hat jemand eine Idee, was die Ursache sein könnte?

Danke schon mal,
Ralf
Ralf Kaiser

Geändert von Ralf Kaiser ( 9. Jan 2014 um 09:27 Uhr)
  Mit Zitat antworten Zitat