Einzelnen Beitrag anzeigen

Delbor

Registriert seit: 8. Okt 2006
Ort: St.Gallen/Schweiz
901 Beiträge
 
Delphi 10.3 Rio
 
#22

AW: Das System kann den Pfad nicht finden

  Alt 5. Jul 2016, 14:10
Hi zusammen

Wieso fällt mir erst jetzt auf, dass hier immer von einer URL die Rede ist?
Der Inhalt von Request.PathInfo stammt aus dieser HTML-Anweisung im Hauptdokument:
Delphi-Quellcode:
  <div id="Titellogo">&nbsp;,&nbsp; <!--<div id="imglogo">&nbsp;-->
     <!--<div id="img1">&nbsp;<img alt="DelborPunktCH" src="./Images/jpeg150/DSC_5751.jpg"/></div>-->
    <h2>Willkommen auf den Seiten von</h2>
    <img src ="Images/Logo/Delbor_8.jpg" alt="Losggosrc=" /> //Genau genommen hier

  </div>
Also nix mit URL.

So, wie ich das bisher verstanden habe, ist der Wert von Request.Pathinfo beim ersten Eintreffen der Anfrage '/'. Die Antwort ist [DELPHI]Response.Content := PageproducerHome.Content Und der ist erstmal das komplette HTML der Seite.
Anschliessend liest der Browser den HTML-Text, und wenn er auf bestimmte Tags stösst wie <img>, setzt er nochmal einen Request ab, um das Bild zu erhalten.
Und das ganze wiederholt der Browser solange, bis er alle Infos hat, Erst jetzt wrd die Verbindung geschlossen. Soweit richtig?

Also enthält Request.Pathinfo offenbar nie eine URL.
Wenn, dann müsste die URL in Request.URL enthalten sein. Wobei ich mich frage, ob in einer auf localhost laufenden Anwendung überhaupt eine URL ausgegeben wird (die es aber natürlich gibt).

Gruss
Delbor
Roger
Man muss und kann nicht alles wissen - man muss nur wissen, wo es steht.
Frei nach Albert Einstein
http://roase.ch
  Mit Zitat antworten Zitat