Einzelnen Beitrag anzeigen

Rolf Frei

Registriert seit: 19. Jun 2006
468 Beiträge
 
Delphi 11 Alexandria
 
#26

AW: Compilerfehler F2085

  Alt 20. Sep 2018, 18:28
Danke für den Vorschlag,
wo in der Schweiz bist Du denn? Ich wohne am Bodensee, deutsche Nord-Seite.
Ich hab jetzt Delphi2009 komplett deinstalliert (inkl. manuelles Löschen übrig gebliebener Reste) und neu installiert: es kommt immer noch der Fehler mit den angeblich unpassenden Modulnamen. Dann hab ichs wieder deinstalliert, danach die registry durchstöbert auf Verweise auf das alte Installationsverzeichnis, und diese gelöscht. Dann wieder installiert - WIEDER kam dieselbe Fehlermeldung! Ausserdem hat das neu installierte Delphi2009 ungefragt alle bpl geladen: woher weiss ein frisch installiertes 'jungfräuliches' System überhaupt davon? Ist mit alles sehr rätselhaft. Mein nächster Versuch wäre, einen alternative Rechner zu besorgen, und Delphi2009 dort zu installieren. Damit bin ich erst mal eine Weile 'beschäftigt'. Im Moment deinstalliere ich zum wiederholten Mal..
Gruß: Siegfried
Komme aus dem Aargau.

Dass das Deinstallierern/Instalieren nicht funktioniert, war mir fast klar. Dein Problem liegt zu 100% an deinen ganzen Einstellungen und vermutlich mehrfach vorhanden DLL/BPL/DCU's etc., die da irgendwo "verstreut" auf deinem PC liegen und die mit einer Deinstallation eben nicht verschwinden.

Mein Angebot besteht nachwievor. Bin mir sicher, dass wir das zusammen per TeamViewer (das sagt dir was?) relativ schnell beheben können. Das Ganze wird wahrscheinlich erheblich weniger rätselhaft sein als du denkst, aber ohne dem nötigen KnowHow wirkt das für dich halt rätselhaft. Wenn wir das zusammen lösen wirst du sicher noch was dabei lernen. Du kannst ja dann zuschauen was ich mache.

Verwende doch auch mal den Process Monitor von SysInternals und logge da alles. Dieses Tool ist extrem hilfreich für solche Fälle. Da wirst du genau sehen können, auf was Delphi da alles zugreift und lädt.
  Mit Zitat antworten Zitat