Einzelnen Beitrag anzeigen

knaeuel

Registriert seit: 2. Jul 2007
82 Beiträge
 
Delphi 10.3 Rio
 
#1

super-buggy MultiView-Komponente - Tipps? Workarounds?

  Alt 27. Sep 2018, 14:54
Hallo zusammen,

die MultiView-Komponente von Delphi 10.2 Tokyo nervt mich gewaltig. Ich würde sie aber gerne benutzen, weil es an sich ein schönes Feature ist.

[nicht-so-wichtig]
Damit, dass die Breite nicht sauber aus der IDE übernommen wird und auch mit den dauernd auftretenden Problemen innerhalb der IDE beim Anzeigen/Ausblenden des MultiView kann ich ja noch leben. Breite setze ich halt in OnCreate vom Formular, die Sichtbarkeit notfalls mit einem Klick in die Visible Checkbox. Dann gibts noch diverse Probleme mit Stati von Komponenten, die auf dem Multiview liegen, siehe hier zum Beispiel https://community.embarcadero.com/fo...view-component
Also lassen wir solche Komponenten im Multiview schonmal weg.
[/nicht-so-wichtig]

Aber jetzt gerade habe ich ein neues Problem, nämlich dass das erste Aufklappen nicht animiert wird. War bisher nie so, bisher kannte ich nur das Problem, dass der Multiview-Bereich beim ersten Aufklappen von der linken Seite hereingerutscht ist, wenn/obwohl die Komponente auf der rechten Seite liegt.

Gibt es für das Animationsproblem beim ersten Einblenden einen Workaround? Vielleicht irgendwelche Einstellungen, die man meiden sollte?

hier die aktuellen Einstellungen als Bildchen
multifu.jpg
Wolfgang

Geändert von mkinzler (27. Sep 2018 um 15:21 Uhr)
  Mit Zitat antworten Zitat