Einzelnen Beitrag anzeigen

norwegen60

Registriert seit: 23. Dez 2007
278 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#4

AW: LoadLibrary beendet mit Delphi 10.3 Application

  Alt 13. Feb 2019, 17:52
Danke für das schnelle Feedback. Es gibt keine DllMain und kein Code zwischen begin.

Die dpr sieht so aus
Delphi-Quellcode:
uses
  SysUtils,
  Dialogs,
  Classes,
  ComCtrls,
  Forms,
  Ed_user in 'Ed_user.pas{foedUser},
  Di_uslog in 'Di_uslog.pas{fodiUserLogin},
  int_User in 'int_User.pas',
  U_hilfs1 in '..\..\All\ALL_UNIT\U_hilfs1.pas',
  u_Debug in '..\All_Unit\u_Debug.pas',
  u_NTRegistry in '..\..\All\All_Unit\u_NTRegistry.pas',
  int_Splash in '..\..\All\ALL_Form\int_Splash.pas',
  u_InitDat in '..\All_Unit\u_InitDat.pas',
  u_IniDo in '..\..\All\All_Unit\u_IniDo.pas',
  U_initFo in '..\ALL_UNIT\U_initFo.pas',
  U_InitDb in '..\ALL_UNIT\U_InitDb.pas',
  dm_ConDoQMa in '..\All_Form\dm_ConDoQMa.pas{dmConDoQMa: TDataModule},
  u_RegDo in '..\..\All\All_Unit\u_RegDo.pas';

{$R *.RES}

exports
  edUser,
  GetUser,
  InitUser0,
  SetUser;

end.
Die DLL funktionieren seit Jahren auf verschiedensten Rechnern. (Start mit Delphi 3.0, 5.0, 7.0, XE, 10, 10.1, 10.2.x)
Die EXE und die DLL's liegen in einem GroupProject und wurden alle gleich kompiliert.
Die mit Delphi 10.2.2 kompilierte Version läuft problemlos auf ca. 60 Rechnern. Sie liefen auch auf den den beiden Rechnern, die jetzt Probleme bereiten. (Rücksetzung auf die 10.2.2 Version hat das Problem wieder beseitigt)
Nur mit Delphi 10.3 gibt es wieder ein neues Problem.

Grüße
Gerd
  Mit Zitat antworten Zitat