Einzelnen Beitrag anzeigen

Rollo62

Registriert seit: 15. Mär 2007
3.821 Beiträge
 
Delphi 11 Alexandria
 
#18

AW: XCODE 12.2 und Sydney will nicht

  Alt 25. Nov 2020, 09:24
Rollo, du nutzt zwar XCode 12.1, hast aber die SDK in Delphi 10.4.x auch noch mit XCode 11.x-Version erzeugt, oder?
Das kann gut sein, ich warte mit Updates meist recht lange,
und nehme dann immer meine alten SDK's mit.
Weil nachträgliches reinfummeln alter SDK's aus Backups ist ein Horror.
Und das Aktualisieren mit neuem XCode ist manchmal nicht möglich, auch das entsprechende DebugImage muss auf das iOS Gerät.

Weil Apple ständig massive Änderungen am ganzen System macht, die dann alle möglichen Inkompatibilitäten erzeugen kann ich nur raten, mit Updates möglichst lange zu warten.
Aber auch nicht zu lange.
Deshalb mache ich Versuche mit Macos VM's, die ich dann update, was aber auch nicht immer geht.
Man muss ziemlich aufpassen, denn Apple erzwingt of Macos, XCode, iOS Updates,
und der Weg zurück ist sehr steinig bis unmöglich.

Apple Developer, Xamarin, Unity Nutzer haben aber sehr oft die gleichen Probleme mit Apple, so dass man in guter Gesellschaft ist
Apple nimmt wenig Rücksicht auf Kompatibilität, da lob ich mir das gute, alte Microsoft Windows.
  Mit Zitat antworten Zitat