AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Cross-Platform-Entwicklung [Fmx, iOS]: Can't start debugserver on device - device support image was not mounted

[Fmx, iOS]: Can't start debugserver on device - device support image was not mounted

Ein Thema von Rollo62 · begonnen am 18. Aug 2017 · letzter Beitrag vom 15. Mai 2019
Antwort Antwort
Seite 3 von 3     123
Rollo62

Registriert seit: 15. Mär 2007
2.005 Beiträge
 
Delphi 10.3 Rio
 
#21

AW: [Fmx, iOS]: Can't start debugserver on device - device support image was not moun

  Alt 10. Mai 2019, 13:16
Hallo arnof,

da hast Du Glück gehabt.
Normalerweise funktioniert es gut, und Tage/Wochen ohne Problem.
Aber wenn es kommt, dann kann es mal schnell gehen, wie bei dir, oder auch hartnäckig bleiben.

Deshalb habe ich mal meine Checkliste der Möglichkeiten die geholfen/empfohlen werden gemacht:
DebugServer not mounted: # may be enough sometimes
- Check Connection
- Check Provisioning in Options, use right Wildcard
- Check & sync. Target device (sometimes old device is still visible)
- # 1. Try Clean Project
- # 2. Try remove App (via XCode/Devices & Simulators/Apps Delete)
- # 3. Try Close PAServer
- # 4. Try Delete PAServer ScratchDir
- # 5. Try Unplug
- # 6. Try Shutdown iOS
- # 7. Try Close RadStudio
- # 8. Try Close XCode
- # 9. Try Re-Boot VM-OSX
- # 10. Try Re-Open XCode
- # 11. Try Re-Boot iOS
- # 12. Try Re-Plug w/ XCode/Devices&Simulat. open, watch "yellow" DebugServer update
- # 13. Try Re-Start PAServer
- # 13. Try Re-Start RadStudio
- # 14. Try Open Project w/ iOS64
- # 15. Try Check Connection (Project\Edit Connection\Test)
- 16. Try Check SDK (Project\SDK)
- # 17. Check Project settings: Debug --> Development
- # 18. Try Sync. Device (Select Target device)
- # 19. Try BuildAll Project (Debug\Development)
- # 20. Try Debug Project (Debug\Development)
- 21. Try Start XCode dummy project
- 22. Try Start RadStudio dummy project
//
- 23. Try Update latest iOS

Muss nicht immer Alles gemacht werden, aber oft sind einige Schritte nötig.
Ich bin immer noch dabei mal eine definitive Checklist hinzubekommen, das Dumme ist nur das es sich anscheinend jedes Mal anders verhalten kann.

Hier sind die Provisioning-Probleme noch gar nicht mit eingerechnet, die kommen bei mir Ende Mai wieder auf mich zu
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
2.005 Beiträge
 
Delphi 10.3 Rio
 
#22

AW: [Fmx, iOS]: Can't start debugserver on device - device support image was not moun

  Alt 15. Mai 2019, 10:32
Nochmal ein Nachtrag:

Ich habe gerade wieder mal den Fall gehabt, und der "einfache, kurze" Weg hatte wieder nicht gereicht,
ich musste
- # 9. Try Re-Boot VM-OSX ausführen.

Vorher hatte es aber im RadStudio beim Sync'en des iPhones (es war immer dasselbe an dem PC)
eine Exception "ListIndex out of bounds (- 1)" gegeben, bei dem Öffnen der Auswahl der Devices.

Für mich scheint das so als würde RadStudio nicht immer mitbekommen wenn das iPhone an und ab-gesteckt wird,
denn ich sehe oft das bereits lange abgestöpselte Geräte noch in der Liste angezeigt werden.

Weil das am Ende eine Info ist die wohl von XCode oder sogar vom drunterliegenden Macos kommt ist es verständlich warum XCode und evtl. VmWare Images geschlossen werden müssen, wenn irgendwo im System noch ein "Zombie" des Gerätes herumspukt.

Mittlerweile habe ich mich dran gewöhnt, dass dies mal ab und zu alle paar Tage passiert.
Blöd ist nur das der ganze Prozess immer locker 5 Minuten dauert, Zeit für eine Kaffepause

Wenn jemand eine bessere Erklärung hat, oder sogar einen einfacheren Workaround dafür, würde ich mich sehr freuen eine Info zu bekommen.
Denn das Problem nervt mich jetzt schon seit mehreren Jahren.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 21:43 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf