AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

TStringgrid zählt nur bis 10

Ein Thema von akazukilp · begonnen am 15. Okt 2020 · letzter Beitrag vom 22. Okt 2020
Antwort Antwort
Seite 2 von 3     12 3   
Benutzerbild von scrat1979
scrat1979

Registriert seit: 12. Jan 2007
Ort: Sulzbach a.d. Murr
996 Beiträge
 
Delphi 10.4 Sydney
 
#11

AW: TStringgrid zählt nur bis 10

  Alt 16. Okt 2020, 20:31
Stelle doch das Projekt mal als zip rein dann können wir es uns anschauen.

Du scheinst wieder was falsch gemacht zu haben. Vermutlich musst du von 749 bis 0 runterzählen. Außerdem gehen deine beiden Schleifen jetzt von 750 aus...
Michael Kübler
  Mit Zitat antworten Zitat
mmw

Registriert seit: 10. Sep 2019
Ort: OWL
74 Beiträge
 
Delphi 10.3 Rio
 
#12

AW: TStringgrid zählt nur bis 10

  Alt 16. Okt 2020, 20:45
hallo,

Die 750 können nicht stimmen. Lieber so machen.

Delphi-Quellcode:
for i := StringGrid1.RowCount-1 downto 0 do
 for J := StringGrid1.ColCount-1 downto 0 do
Gruß
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
36.888 Beiträge
 
Delphi 10.4 Sydney
 
#13

AW: TStringgrid zählt nur bis 10

  Alt 16. Okt 2020, 22:02
Aber ich find den Fehler nicht warum mir nichts reingeschrieben wird wen ich den Knopf drücke
Antwort #2 schon gelesen?
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
akazukilp

Registriert seit: 3. Sep 2020
17 Beiträge
 
#14

AW: TStringgrid zählt nur bis 10

  Alt 17. Okt 2020, 12:47
Aber ich find den Fehler nicht warum mir nichts reingeschrieben wird wen ich den Knopf drücke
Antwort #2 schon gelesen?
Ja habe ich. Aber mein Problem ist ein neues. Ich hab meine Fehler mit dem Button, dass ich wenn ich auf den Button klicke, dass ganze sich umdrehen soll, also dass oben 750 und unten 1 stehen soll, aber er zählt von -86 zu 672.
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
7.808 Beiträge
 
Delphi XE4 Professional
 
#15

AW: TStringgrid zählt nur bis 10

  Alt 17. Okt 2020, 12:55
Hallo,
beschäftige dich mal mit F5, F7 und F8.
Dazu gibt es in Google schöne Videos.
Heiko
  Mit Zitat antworten Zitat
akazukilp

Registriert seit: 3. Sep 2020
17 Beiträge
 
#16

AW: TStringgrid zählt nur bis 10

  Alt 17. Okt 2020, 13:09
Hallo,
beschäftige dich mal mit F5, F7 und F8.
Dazu gibt es in Google schöne Videos.
Debugen? Gut veruch ich mal
  Mit Zitat antworten Zitat
akazukilp

Registriert seit: 3. Sep 2020
17 Beiträge
 
#17

AW: TStringgrid zählt nur bis 10

  Alt 17. Okt 2020, 18:41
Hm klappt immer noch nicht.
kann mir jemand einen Hint geben was genau ich falsch mache
Code:
procedure TForm1.Button1Click(Sender: TObject);
var
  i, J, z : Integer;
begin
  z := 751;
    with StringGrid1 do
    begin

      for i := 1 downto Stringgrid1.Rowcount -1 do
         for J := 1 downto Stringgrid1.ColCount -1 do

          begin
            z := (z)-1;
            Stringgrid1.Cells[J, i] := IntToStr(z);
          end;
    end;
end;
  Mit Zitat antworten Zitat
bcvs

Registriert seit: 16. Jun 2011
511 Beiträge
 
Delphi 10.3 Rio
 
#18

AW: TStringgrid zählt nur bis 10

  Alt 17. Okt 2020, 19:15
Zitat:
for i := 1 downto Stringgrid1.Rowcount -1 do
Anders rum natürlich. Schau dir Post #12 nochmal genau an. Von 1 kannst du nicht mehr weit runterzählen.

Mit dem Debugger und F8 hättest du das sofort gefunden.
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
7.808 Beiträge
 
Delphi XE4 Professional
 
#19

AW: TStringgrid zählt nur bis 10

  Alt 18. Okt 2020, 02:26
Hallo,
Debuggen. Ja.
F5 auf die z:= 751-Zeile.

Dann mit F8 loslegen.
Deine .-Cells-Zele wird wahrscheinlich nie angesprungen.
Heiko
  Mit Zitat antworten Zitat
akazukilp

Registriert seit: 3. Sep 2020
17 Beiträge
 
#20

AW: TStringgrid zählt nur bis 10

  Alt 18. Okt 2020, 10:07
Hallo,
Debuggen. Ja.
F5 auf die z:= 751-Zeile.

Dann mit F8 loslegen.
Deine .-Cells-Zele wird wahrscheinlich nie angesprungen.
ja danke. hab gesehen wo das Problem liegt. Er Springt auch auf die Zelle 0 drauf. Kann man das irgendwie umgehen mit einer property?
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 04:43 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf