AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Netzwerke Delphi TWebModule und Multipart

TWebModule und Multipart

Ein Thema von Hobbycoder · begonnen am 8. Dez 2020 · letzter Beitrag vom 9. Dez 2020
Antwort Antwort
Seite 2 von 2     12
Bbommel

Registriert seit: 27. Jun 2007
Ort: Köln
572 Beiträge
 
Delphi 10.4 Sydney
 
#11

AW: TWebModule und Multipart

  Alt 8. Dez 2020, 16:38
Ich habe mal geschaut, wie es aussieht, wenn ein Client meinem Server eine Datei sendet, also mal den RawContent aus dem Request ins Log geschrieben:

Code:
-----------------------------167835985122627247241915400059
Content-Disposition: form-data; name="files[]"; filename="changeTimeValue.dcu"
Content-Type: application/octet-stream

[...]

Hier ist also auch "form-data" vorhanden, das sollte soweit kein Problem sein. Liegt es vielleicht schlicht daran, dass dein <input>-Element für die Dateien nicht "files[]" heißt?

Ähnlich wie bei Rolf läuft das eigentliche Senden der Dateien bei mir allerdings auch per Javascript im Browser, wobei ich dafür kein Plugin habe, sondern ein paar Zeilen Code, die ich gerne hier reinstellen kann, falls Interesse besteht. Da passiert aber nicht viel anderes, als das mittels JS ein Formular-Objekt erstellt wird und dort dann eben die Datei als "files[]" angefügt wird.
  Mit Zitat antworten Zitat
Hobbycoder

Registriert seit: 22. Feb 2017
881 Beiträge
 
#12

AW: TWebModule und Multipart

  Alt 8. Dez 2020, 17:35
@Bbommel:

das mit dem RawContent deckt mit mit meinem RawContent, wenn ich den enctype verwende. Jedoch wundert es mich, dass genau dann die Unit Web.ReqMulti nicht verwendet wird (Habe entsprechende Haltepunkte gesetzt, die dann nicht angelaufen werden).
Die Filedaten sind aber definitiv in RawContent vorhanden, das kann man ja schnell sehen.

@Rolf Frei:

Ja, das mit dem .php ist vielleicht etwas unglücklich
Danke für den Tipp, ich werde das wohl auch erst mal so umsetzen. Da aber mit den Bild auch noch Metainformationen gesendet werden sollen, hätte ich das zwar schon gerne in einem Request, aber dazu kann man sich ja einen Workaround bauen.

@all
Was ich jedoch nicht verstehe: Wenn ich die Übertragung so aufteilen muss, damit es funktioniert, also den enctype weglasse, wir die ReqMulti angesprochen, liefert aber immer IsMultipartForm=False zurück. Wenn ich die Übertragung nicht aufteile muss ich den enctype verwenden, aber die ReqMulti wird nie angesprochen. Wofür wäre dann die ReqMulti da? Das in der ReqMulti genau diese RawContent geparst wird, kann man ja im Code schon direkt erkennen.

@Bbommel:
Ich werde mein Input-Element mal Files nennen, aber ich glaube nicht, dass es daran liegt.
Gruß Hobbycoder
Alle sagten: "Das geht nicht.". Dann kam einer, der wusste das nicht, und hat's einfach gemacht.
  Mit Zitat antworten Zitat
Bbommel

Registriert seit: 27. Jun 2007
Ort: Köln
572 Beiträge
 
Delphi 10.4 Sydney
 
#13

AW: TWebModule und Multipart

  Alt 8. Dez 2020, 17:41
@Bbommel:
@Bbommel:
Ich werde mein Input-Element mal Files nennen, aber ich glaube nicht, dass es daran liegt.
Wichtig dabei ist dann vor allem auch das
Code:
[]
im Namen.
  Mit Zitat antworten Zitat
Rolf Frei

Registriert seit: 19. Jun 2006
387 Beiträge
 
Delphi 10.3 Rio
 
#14

AW: TWebModule und Multipart

  Alt 8. Dez 2020, 18:05
Habe das nun mit einer simplen Form getestet und das funktioniert bei mir einwandfrei.

Code:
<form method="POST" action="fileupload" name="MyForm" enctype="multipart/form-data">
  <input type="file" name="filename" value="">
</form>
Die Fielupload Action sieht so aus:
Delphi-Quellcode:
procedure TESWebModule.waFileUploadAction(Sender: TObject;
  Request: TWebRequest; Response: TWebResponse; var Handled: Boolean);
begin
  if Request.Files.Count > 0 then
  begin
    with TFileStream.Create(FUploadDir + Request.Files[0].FileName, fmCreate) do
    try
      CopyFrom(Request.Files[0].Stream, Request.Files[0].Stream.Size);
    finally
      Free;
    end;
  end;
end;
Nach Auswahl einer Datei und Senden des Formulars ist die Datei in meinem Uploadordner vorhanden. Das Ganze habe ich aber mit einer CGI-EXE und IIS getestet. Da ein Standalone Server glaube ich aber auf Indy basiert, könnte es eventuell damit zusammen hängen, dass das da nicht geht. Ist aber reinen Spekulation. Versuche das doch bei dir auch mal mit einer CGI-EXE (oder ISAPI-DLL wenn es komplizierter sein soll) und IIS anstelle eines eigenen Servers.

@Bbommel
Nein das [] ist nicht nötig, das hängt mit dem Server zusammen und ist da unter Umständen nötig, damit der Server mehrere Files verabreiten kann (z.B. PHP). Siehe auch hier: https://wiki.selfhtml.org/wiki/HTML/...t/Datei-Upload

In Firefox wird das Bild mit diesen Angaben geschickt und das funktioniert einwandfrei:
Code:
-----------------------------3165091648410499962260122359
Content-Disposition: form-data; name="filename"; filename="bruch0002.JPG"
Content-Type: image/jpeg

Binäre Daten ....

Geändert von Rolf Frei ( 8. Dez 2020 um 19:22 Uhr)
  Mit Zitat antworten Zitat
Bbommel

Registriert seit: 27. Jun 2007
Ort: Köln
572 Beiträge
 
Delphi 10.4 Sydney
 
#15

AW: TWebModule und Multipart

  Alt 8. Dez 2020, 18:46
Ein Versuch ist das mit dem CGI vielleicht wert, aber bei mir läuft der Server auch immer als Standalone-Anwendung und zumindest bei lokalen Tests auch ohne irgendwas dazwischen und es funktioniert ja. Insofern kommen die Daten ja - ob mit oder ohne Indy - offenbar eigentlich sauber im WebModule an.
  Mit Zitat antworten Zitat
Hobbycoder

Registriert seit: 22. Feb 2017
881 Beiträge
 
#16

AW: TWebModule und Multipart

  Alt 9. Dez 2020, 13:42
Danke für eure Hilfe.

ich habe jetzt noch mal eine ganz neues Projekt aufgesetzt (als Standalone), ReqMulti hinzugefügt, und der Fileupload funktioniert schon mal. Insofern muss ich wohl suchen, warum das in der eignetlichen Anwendung nicht der Fall ist.

Zwei Fragen habe ich aber noch.
1. Jetzt Frage ich ab, ob Request.Files.Count>0 , um festzustellen ob es eine Multipart-Response ist. Gibt es dafür noch einen eleganteren Weg, oder ist das schon die einige Methode?

2. Solange als Method="post" übertragen wird, kann ich zwar die Files abfragen, aber meine QueryFields sind immer leer (obwohl ich alle Parameter im Content finden kann). Erst wenn ich als Method Get verwende, wird QueryFields auch gefüllt.
Es wäre aber schon gut, wenn ich im Post auch die anderen Felder, die das Web-Formular mit überträgt (und sie sind doch im Content enthalten), auch auslesen könnte. Ich könnte mir zwar einen eigenen Parser schreiben, aber sollte das nicht
direkt funktionieren?

Hier mal die Action im Webmodule:
Delphi-Quellcode:
procedure TWebModule1.WebModule1DefaultHandlerAction(Sender: TObject;
  Request: TWebRequest; Response: TWebResponse; var Handled: Boolean);
var
  datatype: string;
  content: string;
begin
  Response.Content :=
    '<html>' +
    '<head><title>Webserver-Anwendung</title></head>' +
    '<body>Webserver-Anwendung</body>' +
    '</html>';
  if Request.Files.Count > 0 then
  begin
    with TFileStream.Create('C:\OrderApp\' + Request.Files[0].FileName, fmCreate) do
    try
      CopyFrom(Request.Files[0].Stream, Request.Files[0].Stream.Size);
    finally
      Free;
    end;
  end;
  with TStreamWriter.Create(TFileStream.Create('C:\OrderApp\Query.txt', fmCreate), TEncoding.UTF8) do
  try
    content:=Request.Content;
    datatype:=Request.QueryFields.Values['DataType'];
    Write(datatype);
    Write(content);
    Flush;
    Close;
  finally
    BaseStream.Free;
    Free();
  end;
end;
Und hier mal die html-seite mit der ich testweise den Upload mache:
Code:
<html>
    <head>
        <meta charset="utf8">
        <meta name="viewport" content="width=device-width, initial-scale=1.0">
   
    </head>
    <body>
        <form id="myForm" action="http://localhost:8443/senddata.php" method="post" enctype="multipart/form-data">
            <input type="text" name="DataType" value="fileupload">
            <input type="file" size="120" name="myfile">
            <input type="text" size="20" name="mimetype" value="image/bmp">
            <input type="submit" value="upload">
        </form>
    </body>
</html>
Gruß Hobbycoder
Alle sagten: "Das geht nicht.". Dann kam einer, der wusste das nicht, und hat's einfach gemacht.

Geändert von Hobbycoder ( 9. Dez 2020 um 13:44 Uhr)
  Mit Zitat antworten Zitat
Rolf Frei

Registriert seit: 19. Jun 2006
387 Beiträge
 
Delphi 10.3 Rio
 
#17

AW: TWebModule und Multipart

  Alt 9. Dez 2020, 14:12
Du kannst Request.ContentType abfragen aber brauchst du eigentlich nicht, da Files.Count in deinem Fall ausreicht.

Du hast aber in deinem Code noch eine grossen Fehler. Du nutzt das Request.QueryFields für den Zugriff der gesendeten Formaulardaten. In deinem Fall wirst du da nie etwas drin haben. QueryFields ist nur bei einem Formular mit der method="GET" oder einem Aufruf über eine URL abgefüllt. Bei einem Formular mit method="POST" sind die Formulardaten im Request.ContentFields abgefüllt. Der Unterschied von GET und POST ist der, dass beim GET die Daten per URL-Parameter übergeben werden und es somit Längenbeschränkungen gibt. Dieses sollte man in Formen eher nicht nutzen, insbesondere in deinem Fall wo Filedaten übertragen werden. Bei einem POST werden die Daten im Body (Content) der Anfrage übergeben und sind daher in der Grösse praktisch unbeschränkt. Bei GET Anfragen musst du QueryFields nutzen und bei POST ContentFields.

Delphi-Quellcode:
    datatype:=Request.QueryFields.Values['DataType'];
müsste so sein:
    datatype:=Request.ContentFields.Values['DataType'];
Ausserdem scheinst du eine Eingabe auf der Form zu haben, die den Dateityp vom Anwender verlangt. Das solltest du nicht so machen, denn der notrmale Anwender wird das kaum richtig eingeben. Die nötige Info steht eigentlich bereits im Request.Files[x].ContentType.

Geändert von Rolf Frei ( 9. Dez 2020 um 14:17 Uhr)
  Mit Zitat antworten Zitat
Hobbycoder

Registriert seit: 22. Feb 2017
881 Beiträge
 
#18

AW: TWebModule und Multipart

  Alt 9. Dez 2020, 14:24
Vielen Dank für die ausführliche Antwort. Das mit QueryFields und ContentFields wußte ich nicht.

Das mit dem Dateitype als Eingabe auf dem Forumlar war nur zum rumtesten.
Gruß Hobbycoder
Alle sagten: "Das geht nicht.". Dann kam einer, der wusste das nicht, und hat's einfach gemacht.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 02:49 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf