AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

canvasobject..alte position löschen

Ein Thema von Haegar · begonnen am 25. Feb 2003 · letzter Beitrag vom 26. Feb 2003
Antwort Antwort
Seite 2 von 2     12
Haegar

Registriert seit: 10. Dez 2002
Ort: Peitz
319 Beiträge
 
Delphi 7 Professional
 
#11
  Alt 26. Feb 2003, 15:17
hmm..naja, so ganz hab ich das noch nicht gepackt - also hier mal was ich alles benutze:
-ein Image (image1) auf Form1
-eine Klasse (TAuto=class(TObject))
-ne Variable (auto1:Tauto)
-den Befehl: BitBlt(Canvas.Handle, Canvas.Left, Canvas.Top, Image.Width, Image.Heigth, Image.Handle, altx, alty, SCRINVERT);
da kommt rein (reihenfolge wie befehl):
Form1.image1.canvas.handle,0,0,40,20,.....,auto1.x ,
auto1.y,SRCINVERT

tja wenn ich nu auto1.handle dahin schreibe, meckert er rum.

vielleicht mal die Klasse aus unit auto;
Delphi-Quellcode:
type TAuto=class(TObject)
  private
  public
   v:Single; //Geschwindigkeit
   x, y:integer; //Position
   farbe:longint; //Lackierung
   constructor erzeugen(xpos,ypos:integer; color:longint);
   procedure schneller(dv:real);
   procedure bremsen (dv:real);
   procedure zeichnen(canvas:TCanvas); //noch drehung/Lenkung
 end;
muss ich denn irgendwie noch eine handle prozedur oder so in der eigenen klasse erwähnen??
*verzweifeln tu*

gruss haegar
  Mit Zitat antworten Zitat
lodda

Registriert seit: 6. Dez 2002
65 Beiträge
 
Delphi 5 Standard
 
#12
  Alt 26. Feb 2003, 15:28
Jetzt versteh ich dein Problem. Also wenn du die Funktion BitBlt nehmen willst, dann musst du in deinen privat-Teil noch eine TCanvaskomponente einfügen. Auf diese musst du dann zeichnen. Das fertig gezeichnete Object kannst du dann mit der BitBlt-Funktion auf dein Image kopieren.
Die 3 größten Lügen der Software- Entwickler:
1. Dieses Feature ist noch nicht implementiert, aber das ist kein Problem dies zu tun.
2. Wir arbeiten an einem Update um den Fehler zu beseitigen.
3. Ihre Software wird nächste Woche fertig sein.
  Mit Zitat antworten Zitat
Haegar

Registriert seit: 10. Dez 2002
Ort: Peitz
319 Beiträge
 
Delphi 7 Professional
 
#13
  Alt 26. Feb 2003, 15:40
sry, ich schon wieder )
jetzt hab ich nur das problem, das ich das auto net mehr sehe! kann das sein, das das zu malende image jetzt hinter dem hintergrundbild ist??
  Mit Zitat antworten Zitat
lodda

Registriert seit: 6. Dez 2002
65 Beiträge
 
Delphi 5 Standard
 
#14
  Alt 26. Feb 2003, 15:52
Das kann eigentlich nicht sein. Schick mir mal den Quelltext als e-mail. Dann schau ich mir das mal an.
Die 3 größten Lügen der Software- Entwickler:
1. Dieses Feature ist noch nicht implementiert, aber das ist kein Problem dies zu tun.
2. Wir arbeiten an einem Update um den Fehler zu beseitigen.
3. Ihre Software wird nächste Woche fertig sein.
  Mit Zitat antworten Zitat
Haegar

Registriert seit: 10. Dez 2002
Ort: Peitz
319 Beiträge
 
Delphi 7 Professional
 
#15
  Alt 26. Feb 2003, 16:04
getätigt
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 23:04 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf