AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Netzwerke [ASP.NET] Falsche "assembly reference"

[ASP.NET] Falsche "assembly reference"

Ein Thema von MrSpock · begonnen am 18. Aug 2005 · letzter Beitrag vom 19. Aug 2005
Antwort Antwort
Seite 2 von 2     12
Robert_G
(Gast)

n/a Beiträge
 
#11

Re: [ASP.NET] Falsche "assembly reference"

  Alt 18. Aug 2005, 18:44
GAC == Global Assembly Cache
Im GAC können mehrere Versionen der gleichen Assembly liegen. Die Runtime wird dann die jeweils passende heraussuchen.
Assemblies im GAC haben immer Vorrang gegenüber denen, die im File system liegen.

Gehe mal in deinem Server auf die Windows-Verwaltung und dort auf die .Net 1.1 Config.
Dort machst du einen Rechstklick auf den Assembly Cache und fügst die Assemblies hinzu.
Das war's für's erste. Du musst jetzt keine Interbase.Dingsbums.dll mit zukünftigen Projekten auf den Server bringen.
  Mit Zitat antworten Zitat
Benutzerbild von MrSpock
MrSpock
(Co-Admin)

Registriert seit: 7. Jun 2002
Ort: Owingen
6.003 Beiträge
 
Delphi 2010 Professional
 
#12

Re: [ASP.NET] Falsche "assembly reference"

  Alt 18. Aug 2005, 18:47
Hallo,

wie ist denn die Fehlermeldung zu lesen?

Zitat:
LOG: Publisher policy file is not found.
LOG: No redirect found in host configuration file (C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspn et.config).
LOG: Using machine configuration file from C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\confi g\machine.config.
LOG: Post-policy reference: Borland.Data.Interbase, Version=2.0.0.0, Culture=neutral, PublicKeyToken=91d62ebb5b0d1b1b
LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/root/e2298e5a/4855754e/Borland.Data.Interbase.DLL.
LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/root/e2298e5a/4855754e/Borland.Data.Interbase/Borland.Data.Interbase.DLL.
LOG: Attempting download of new URL file:///d:/web/xxxx/asp.xxx.de/bin/Borland.Data.Interbase.DLL.
WRN: Comparing the assembly name resulted in the mismatch: Minor Version
Von unten nach oben? Er sucht ja korrekt in dem Verzeichnis file:///d:/web/xxxx/asp.xxx.de/bin/Borland.Data.Interbase.DLL. Dorthin habe ich die DLL ja kopiert. Aber warum kommt darüber:

Zitat:
LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/root/e2298e5a/4855754e/Borland.Data.Interbase/Borland.Data.Interbase.DLL.
@Robert: Da muss ich mal mit Matt sprechen, da ich keinen direkten Zugriff auf die .NET Verwaltung habe.
Albert
Live long and prosper


MrSpock
  Mit Zitat antworten Zitat
Benutzerbild von r_kerber
r_kerber

Registriert seit: 11. Feb 2003
Ort: Trittau
3.538 Beiträge
 
Delphi XE Professional
 
#13

Re: [ASP.NET] Falsche "assembly reference"

  Alt 18. Aug 2005, 20:12
Zitat von MrSpock:
@Robert: Was ist GAC und wie haue ich die Teile darein?
Da Du auf dem WebServer keine Admin-Rechte hast, gar nicht.
Und noch etwas: Ich habe inzwischen mit BDP bei ASPX-Anwendungen abgeschlossen. Das gibt zuviel Probleme. Das gleiche gilt IMHO für einige der Borland-WebControls (DBWebNavigator). Ich verwende jetzt grundsätzlich nur noch .net-Standard. Für Intranets mag das alles ja ganz nett sein, wenn man seinen Server selbst administrieren kann...
  Mit Zitat antworten Zitat
Matt

Registriert seit: 13. Nov 2003
Ort: Hamburg
212 Beiträge
 
#14

Re: [ASP.NET] Falsche "assembly reference"

  Alt 18. Aug 2005, 20:35
also ich muss Rainer da zustimmen. Die Borland .Net Entwicklung macht mir (als Serveradmin) ziemliche Probleme. Keiner kann genau sagen, welche Einstellungen vorgenommen werden müssen und Nachfragen werden so abgetan als wäre man zu blöd.

Die, die mich kennen wissen, das ich alles tun würde, damit Eure Tests/Projekte laufen, nur ohne die konkreten Aussagen vom Hersteller bin ich machtlos!

Die Vorschläge von Robert_G hatte ich vorher schon mal versucht und jetzt nochmal mit den dlls von Mr. Spock, aber damals wie heute ohne Erfolg.

Wenn jemand Infos zu diesem Thema hat bin ich gern bereit diese umzusetzen!

Gruß Matt
  Mit Zitat antworten Zitat
Benutzerbild von MrSpock
MrSpock
(Co-Admin)

Registriert seit: 7. Jun 2002
Ort: Owingen
6.003 Beiträge
 
Delphi 2010 Professional
 
#15

Re: [ASP.NET] Falsche "assembly reference"

  Alt 18. Aug 2005, 21:26
Hallo Matt,

in der Fehlermeldung wird ja der Pfad:

Zitat:
C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/root/e2298e5a/4855754e/Borland.Data.Interbase.DLL
angezeigt. Hast du dorthin mal meine DLL gepackt oder wir Robert gesagt hat in den GAC?
Albert
Live long and prosper


MrSpock
  Mit Zitat antworten Zitat
Robert_G
(Gast)

n/a Beiträge
 
#16

Re: [ASP.NET] Falsche "assembly reference"

  Alt 18. Aug 2005, 21:42
Zitat von Matt:
Die Vorschläge von Robert_G hatte ich vorher schon mal versucht und jetzt nochmal mit den dlls von Mr. Spock, aber damals wie heute ohne Erfolg.
Hi Matt
Schön, dass du vorbeischaust.
Hast du die DLL in den GAC gepackt? Vielleicht sogar beide Verionen?
Wäre ein guter Service, falls du mehrere Kunden hast, die den BDP verwenden möchten.
Die bräuchten dann nämlich nur ihre Binaries und content files hochladen. Könnte aber ein Lizenzproblem geben... (Ich kenne die Lizenz nicht )
  Mit Zitat antworten Zitat
Benutzerbild von MrSpock
MrSpock
(Co-Admin)

Registriert seit: 7. Jun 2002
Ort: Owingen
6.003 Beiträge
 
Delphi 2010 Professional
 
#17

Re: [ASP.NET] Falsche "assembly reference"

  Alt 18. Aug 2005, 21:49
Hallo,

ich hab hier mal den Ausschnitt aus meiner Konfiguration angehängt, der das Problem (möglicherweise) beinhaltet.
Matt kannst du mal die Versionen mit deinem GAC vergleichen?


Ich habe mal weiter gesucht und hier bei Borland einen Artikel gefunden, aus dem hervorgeht, dass D2005 wohl mit der Version 2.0.0.0 der oben genannten DLL ausgeliefert wird. Ich vermute, dass ich die 2.2.0.0 habe, weil ich alle deutschen Updates von D2005 Architekt eingespielt habe.
Miniaturansicht angehängter Grafiken
net_config_140.jpg  
Albert
Live long and prosper


MrSpock
  Mit Zitat antworten Zitat
Matt

Registriert seit: 13. Nov 2003
Ort: Hamburg
212 Beiträge
 
#18

Re: [ASP.NET] Falsche "assembly reference"

  Alt 19. Aug 2005, 11:20
@robert_g
Nein, ich hatte nur die 2.2.0.0 und das hatte nichts geholfen.

Da die Seite aber die 2.0.0.0 gefordert hat, musste man unter "Configured Assemblies" die neuere Version anlegen und die alte Versionsnummer auf die neue setzen. Das Problem haben wir somit zumindest eingegrenzt. Mal schauen was jetzt kommt

DANKE FÜR DEINE HILFE!

Gruß Matt
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 23:28 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf