Einzelnen Beitrag anzeigen

Benutzerbild von Matze
Matze
(Co-Admin)

Registriert seit: 7. Jul 2003
Ort: Schwabenländle
14.987 Beiträge
 
Turbo Delphi für Win32
 
#1

Domain funktioniert im IE nicht

  Alt 17. Mär 2008, 14:45
Hallo,

ich habe bereits bei meinem Hoster angefragt, doch der konnte mir bisher nicht weiterhelfen. Auch erfahrene DP-Mitglieder im Webdesign-/Serverbereich wussten nicht, was los ist.

Es geht um Folgendes:

Im IE7 wird bei Aufruf meiner Domain der Download-Dialog geöffnet: "nackte" Domain
Rufe ich die Startseite bzw. Unterseiten über die "PHP-URL" auf, ist es das gleiche: /index.php?page=home

Mache ich es jedoch mit den umgeschriebenen Links (mod_rewrite leitet lediglich zu soeben genanntem Link weiter): /de/home.html
dann geht alles einwandfrei. In allen anderen Browsern (FF, Opera, Safari) tritt das Problem auch nicht auf, weshalb ich denke, dass es nicht am Server liegt. Da die umgeschriebenen Links gehen, kann's auch nicht am PHP-Code liegen. Und dass es an der .htaccess liegt, kann ich mir auch nicht ganz vorstellen, da es bei allen anderen Browsern ja funktioniert und der Apache somit nichts damit zu tun haben sollte.

Putty, das ich zur Fehlersuche getestet habe, meldet mir das hier:

Zitat:Undefined index: HTTP_HOST in /home/www/confixx/html/gesperrt/index.php on line 23


Der empfangene HTML-Code hierzu ist dieser: site.html. Zu sehen ist diese Meldung von Confixx:

Zitat:
Die Domain "" ist nicht verfügbar.
Was kann die Ursache dafür sein? Ich bin wirklich ratlos.

Verzweifelt grüßt
Matze
  Mit Zitat antworten Zitat