AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

FindComponent findet Label nicht

Ein Thema von day · begonnen am 30. Aug 2006 · letzter Beitrag vom 29. Mär 2011
Antwort Antwort
Seite 3 von 3     123
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
36.983 Beiträge
 
Delphi 10.4 Sydney
 
#21

AW: FindComponent findet Label nicht

  Alt 29. Mär 2011, 16:39
Zitat:
FindComponent: NUR in der Form aufrufen. Die Funktion durchläuft die Components, die nur in der Form gesetzt sind.
Wieso nur da?

Man muß FindControl nur innerhalb des Namesspaces aufrufen, welcher als Owner für die gesuchten Componenten verwendet wurde.

Es ist also vollkommen egal wo die erstellten Komponenten verwaltet werden (also was der Owner ist) und von wo aus FindControl aufgerufen wird.

Die VCL nutzt, für alle über die DFM geladenen Componenten, die zugehörige Form als Owner, weswegen man innerhalb einer Methode der Form FindControl direkt aufrufen kann und da dann alles findet, wovon die Form als Owner fungiert.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 13:30 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2020 by Daniel R. Wolf