AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Suchfunktion Ergebnis der Suchanfrage

Ergebnis der Suchanfrage


Datum des Suchindex: Heute, 14:47

Parameter dieser Suchanfrage:

Suche in Thema: Darstellungsfehler im Twebbrowser
Suche alle Beiträge, die von "froschprinz" geschrieben wurden
• Suchmethode: "Suche nach allen Begriffen"
• Nach Datum (firstpost) sortiert
• Zeige Treffer als Beiträge
Zeige 14 von insges. 14 Treffern
Suche benötigte 0.001s

Es liegen Ergebnisse in folgenden Bereichen vor:

  • Forum: Netzwerke

    AW: Darstellungsfehler im Twebbrowser

      Delphi
      by froschprinz, 3. Okt 2015
    Hey Leute!

    Sorry, dass ich erst jetzt Antworte - ich war leider verhindert.

    Also eines muss ich schon mal sagen: Ihr seid echt der Hit!!:-D

    Der Tipp von Oli73 funktioniert bei mir. Wichtig dabei natürlich, dass die Anwendung in der Reistry bei "\FEATURE_BROWSER_EMULATION" registriert ist.

    Kann mir jemand sagen, was der Befehl 'javascript:void(0)' eigentlich machen soll?
  • Forum: Netzwerke

    AW: Darstellungsfehler im Twebbrowser

      Delphi
      by froschprinz, 1. Okt 2015
    Wenn nicht an der Delphi Version, woran kann es dann liegen?
    Hathor: Kannst Du mir mal deine EXE schicken, mit der Du das getestet hast? Dann kann ich probieren, ob die bei mir auch funktioniert (löst das Problem noch nicht, aber vielleicht ein Schritt weiter)
  • Forum: Netzwerke

    AW: Darstellungsfehler im Twebbrowser

      Delphi
      by froschprinz, 1. Okt 2015
    Warten scheint bei mir nichts zu bringen, Ich habe jetzt 10 Min gewartet.
    Also liegt es vielleicht doch an der Delphiversion?
  • Forum: Netzwerke

    AW: Darstellungsfehler im Twebbrowser

      Delphi
      by froschprinz, 1. Okt 2015
    Hallo,

    wie hast du das geschafft, dass das Loginfenster kommt? Am Anfang ginge es bei Dir doch auch nicht?
  • Forum: Netzwerke

    AW: Darstellungsfehler im Twebbrowser

      Delphi
      by froschprinz, 1. Okt 2015
    Hallo ,

    erstmal danke für die Antworten.

    Nahpets: Mein Gedanke war zuerst auch dass es an "\FEATURE_BROWSER_EMULATION" liegen könnte. Hat aber leider in diesem Fall nichts gebracht.

    Hathor: Bitte klick doch noch auf Anmelden, und schau, ob du dich anmelden könntest, oder ob nur ein leeres Fenster kommt. Die Startseite geht bei mir auch.
  • Forum: Netzwerke

    AW: Darstellungsfehler im Twebbrowser

      Delphi
      by froschprinz, 30. Sep 2015
    Wenn es nicht an der Delphi Version liegt, woran dann? Hat keiner eine Idee? Irgendwie muss das doch zu schaffen sein!
  • Forum: Netzwerke

    AW: Darstellungsfehler im Twebbrowser

      Delphi
      by froschprinz, 30. Sep 2015
    Hallo,

    ich habe mal wieder ein Problem mit dem TWebbrowser:

    Bei z.B. der Internetseite http://learningapps.org/ öffnet sich, wenn ich auf Anmelden klicke, nur eine leere Seite. Im MS-Internetexplorer funktioniert das Anmelden. Einer meiner Kunden möchte aber genau diese Seite mit meiner Software nutzen.
    Hat jemand eine Idee, woran das liegen könnte? Es muss doch eine Möglichkeit geben,...
  • Forum: Netzwerke

    AW: Darstellungsfehler im Twebbrowser

      Delphi
      by froschprinz, 3. Jul 2014
    Also ich bin nun eigentlich schon zufrieden, da mein TWebbrowser mit der oben dargestellten Methode jetzt wieder sauber darstellt. Und "nerver change a running system!
    Da meine Kunden selber auswählen, welche Internetseiten sie anzeigen möchten, kann ich auch nicht am HTML-Code rumspielen. Ich kann ihnen nur mit meiner Software einfache Tools liefern, wie sie die Seiten "dicht" machen können....
  • Forum: Netzwerke

    AW: Darstellungsfehler im Twebbrowser

      Delphi
      by froschprinz, 3. Jul 2014
    Hallo himitsu,

    jetzt steh ich auf dem Schlauch? Also welchen Browser nutzt ihr aktuell, den ihr sehr gut einschränken konntet? Hast du ein Codebeispiel?
  • Forum: Netzwerke

    AW: Darstellungsfehler im Twebbrowser

      Delphi
      by froschprinz, 3. Jul 2014
    mir ging es mit Chromium ebenso!

    Den EmbeddedWB habe ich ebenfalls ausprobiert. Und der hatte exact die gleiche verschobene Darstelllung wie der TWebbrowser.
    Auf einen Standartbrowser kann ich auch nicht zurückgreifen, da die Software im öffentlichen Bereich läuft und ich das freie Serven unterbinden möchte. Des weiteren wird die Darstellung (barrierefrei) für Menschen mit Berhinderungen...
  • Forum: Netzwerke

    AW: Darstellungsfehler im Twebbrowser

      Delphi
      by froschprinz, 3. Jul 2014
    Hi,

    klar, durch die http://weblog.west-wind.com/posts/20...the-IE-Version bin ich ja auch drauf gekommen. Ich wollte nur gleich die fertige Funktion mitliefern, falles sie mal ein anderer benötigt.

    Klar ist auch, dass dies nur bei der Installation durch den Installer gamacht werden muss/sollte. Meine Anwendung ist aber bereits seit Jahren beim Kunden installiert. Die Updates verteile ich...
  • Forum: Netzwerke

    AW: Darstellungsfehler im Twebbrowser

      Delphi
      by froschprinz, 3. Jul 2014
    Hallo,
    ich habe nach viel rumprobieren selber eine Lösung gefunden, die herforragend funktioniert. Eigentlich sollte jeder, der noch TWebbrowser benutzt, standartmäßig SetWebbrowserMode(11,'MeineAnwendung.exe'); setzen. Dann werden die Seiten perfekt dargestellt.
    Bitte nicht vergessen, dass dazu Admin-Rechte nötig sind!
    Übrigens: Auch wenn kein Internetexplorer 11 installiert ist, so führt der...
  • Forum: Netzwerke

    AW: Darstellungsfehler im Twebbrowser

      Delphi
      by froschprinz, 1. Jul 2014
    Hallo,

    danke für Deine Antwort.
    Ich glaube du meint da hier:http://weblog.west-wind.com/posts/2011/May/21/Web-Browser-Control-Specifying-the-IE-Version. Ich habe es probiert, kann aber keinen Unterschied feststellen.
    Irgendwie muss es doch möglich sein, mit Delphi Webseiten vernünftig anzeigen zu lassen?
  • Forum: Netzwerke

    Darstellungsfehler im Twebbrowser

      Delphi
      by froschprinz, 1. Jul 2014
    Hallo,

    ich verwende schon seit Jahren den TWebbrowser (und Delphi 7).
    Nun mehren sich aber immer mehr Internet-Seiten (und damit die Beschwerden der Nutzer), die nicht korrekt angezeigt werden. Z.B. wird die Seite www.nachrichten-leicht.de von Nachrichten-Leicht im Internetexplorer und Firefox korrekt angezeigt. Im TWebbrowser und im EmbeddedWebBrowser kommen diese aber total verschoben.
    ...


URL zu dieser Suchanfrage:

https://www.delphipraxis.net/dp_search.php?do=usersearch&search_username=froschprinz&search_exact_username=1&search_sortby=dateline&search_resulttype=post&search_matchmode=0&searchthreadid=180919
Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 15:03 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf