Delphi-PRAXiS

Delphi-PRAXiS (https://www.delphipraxis.net/forum.php)
-   Multimedia (https://www.delphipraxis.net/16-multimedia/)
-   -   Delphi Kein MCI-Gerät geöffnet - TMediaPlayer (https://www.delphipraxis.net/165004-kein-mci-geraet-geoeffnet-tmediaplayer.html)

Johannes013 9. Dez 2011 16:44

Kein MCI-Gerät geöffnet - TMediaPlayer
 
Hi Leute! :)

bei folgender Anweisung bekomme ich den Fehler: Kein MCI-Gerät geöffnet.

Code:
MusicPlayer := TMediaPlayer.Create(Form1);
MusicPlayer.Parent := Form1;
MusicPlayer.FileName := 'menu.wav';
MusicPlayer.Play();
Das passiert nur bei Laufzeit, wenn die Komponente schon vorher da ist, gibts kein Fehler...

Dank im voraus, Johannes

Klaus01 9. Dez 2011 16:47

AW: Kein MCI-Gerät geöffnet - TMediaPlayer
 
Gab es da nicht auch ein MusicPlayer.open o.ä?

Grüße
Klaus

Bummi 9. Dez 2011 16:56

AW: Kein MCI-Gerät geöffnet - TMediaPlayer
 
Delphi-Quellcode:
procedure TForm2.Button1Click(Sender: TObject);
var
 MusicPlayer : TMediaPlayer;
begin
MusicPlayer := TMediaPlayer.Create(self);// je nach wann und wie TForm2 erzeugt wird kann Form2 nil sein
MusicPlayer.Parent := Self;// s.0.
MusicPlayer.FileName := 'C:\Bummispicker\Wav_resource\4.wav';// voller Pfad
MusicPlayer.Open; // fehlte
MusicPlayer.Play();
end;

Johannes013 9. Dez 2011 16:56

AW: Kein MCI-Gerät geöffnet - TMediaPlayer
 
Ja danke es klappt!


Alle Zeitangaben in WEZ +1. Es ist jetzt 17:38 Uhr.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf