AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Multimedia Delphi Kein MCI-Gerät geöffnet - TMediaPlayer

Kein MCI-Gerät geöffnet - TMediaPlayer

Ein Thema von Johannes013 · begonnen am 9. Dez 2011 · letzter Beitrag vom 9. Dez 2011
Antwort Antwort
Johannes013

Registriert seit: 2. Jun 2009
179 Beiträge
 
Delphi 5 Standard
 
#1

Kein MCI-Gerät geöffnet - TMediaPlayer

  Alt 9. Dez 2011, 16:44
Hi Leute!

bei folgender Anweisung bekomme ich den Fehler: Kein MCI-Gerät geöffnet.

Code:
MusicPlayer := TMediaPlayer.Create(Form1);
MusicPlayer.Parent := Form1;
MusicPlayer.FileName := 'menu.wav';
MusicPlayer.Play();
Das passiert nur bei Laufzeit, wenn die Komponente schon vorher da ist, gibts kein Fehler...

Dank im voraus, Johannes
Johannes
Der folgende Satz ist richtig.
Der vorherige Satz ist falsch.
  Mit Zitat antworten Zitat
Klaus01

Registriert seit: 30. Nov 2005
Ort: München
5.657 Beiträge
 
Delphi 10.4 Sydney
 
#2

AW: Kein MCI-Gerät geöffnet - TMediaPlayer

  Alt 9. Dez 2011, 16:47
Gab es da nicht auch ein MusicPlayer.open o.ä?

Grüße
Klaus
Klaus
  Mit Zitat antworten Zitat
Benutzerbild von Bummi
Bummi

Registriert seit: 15. Jun 2010
Ort: Augsburg Bayern Süddeutschland
3.470 Beiträge
 
Delphi XE3 Enterprise
 
#3

AW: Kein MCI-Gerät geöffnet - TMediaPlayer

  Alt 9. Dez 2011, 16:56
Delphi-Quellcode:
procedure TForm2.Button1Click(Sender: TObject);
var
 MusicPlayer : TMediaPlayer;
begin
MusicPlayer := TMediaPlayer.Create(self);// je nach wann und wie TForm2 erzeugt wird kann Form2 nil sein
MusicPlayer.Parent := Self;// s.0.
MusicPlayer.FileName := 'C:\Bummispicker\Wav_resource\4.wav';// voller Pfad
MusicPlayer.Open; // fehlte
MusicPlayer.Play();
end;
Thomas Wassermann H₂♂
Das Problem steckt meistens zwischen den Ohren
DRY DRY KISS
H₂ (wenn bei meinen Snipplets nichts anderes angegeben ist Lizenz: WTFPL)
  Mit Zitat antworten Zitat
Johannes013

Registriert seit: 2. Jun 2009
179 Beiträge
 
Delphi 5 Standard
 
#4

AW: Kein MCI-Gerät geöffnet - TMediaPlayer

  Alt 9. Dez 2011, 16:56
Ja danke es klappt!
Johannes
Der folgende Satz ist richtig.
Der vorherige Satz ist falsch.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 11:25 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf