Delphi-PRAXiS
Seite 1 von 2  1 2   

Delphi-PRAXiS (https://www.delphipraxis.net/forum.php)
-   Object-Pascal / Delphi-Language (https://www.delphipraxis.net/32-object-pascal-delphi-language/)
-   -   Delphi Wo ist das &-Zeichen geblieben (https://www.delphipraxis.net/20681-wo-ist-das-zeichen-geblieben.html)

HomerGER 21. Apr 2004 13:45


Wo ist das &-Zeichen geblieben
 
Hallo
ich lese aus der registry ein Wert aus
so steht es in der Registry
"http://www.microsoft.com/isapi/redir.dll?prd=ie&ar=iesearch"

wenn ich das mit ShowMessage mir anschaue, kommt das raus
"http://www.microsoft.com/isapi/redir.dll?prd=iear=iesearch"

aus ie&ar wird iear


wenn ich das gleiche aus einer textdatei auslese macht er aus &a nur ein a
:?: :?: :?: :?:
wo ist meine &-Zeichen geblieben ???

mirage228 21. Apr 2004 13:52

Re: Wo ist das &-Zeichen geblieben
 
Zitat:

Zitat von HomerGER
Hallo
ich lese aus der registry ein Wert aus
so steht es in der Registry
"http://www.microsoft.com/isapi/redir.dll?prd=ie&ar=iesearch"

wenn ich das mit ShowMessage mir anschaue, kommt das raus
"http://www.microsoft.com/isapi/redir.dll?prd=iear=iesearch"

aus ie&ar wird iear


wenn ich das gleiche aus einer textdatei auslese macht er aus &a nur ein a
:?: :?: :?: :?:
wo ist meine &-Zeichen geblieben ???

Bei einem Label oder so könntest du ShowAccelChar ändern, aber bei ShowMessage...hm... musst du vielleicht noch ein & hinzufügen, dann zeigt er dieses auch an.

mfG
mirage228

Akut-Programming 21. Apr 2004 13:54

Re: Wo ist das &-Zeichen geblieben
 
Das & Zeichen dient doch z.B. dazu n Shortcut zulegen. z.B. im MainMenu, wenn ich da ne Caption mit "&Beenden" bennene, kann ich wenn ich die ALT Taste gedrückt halte und die B drücke das OnClick Ereignis des MenuItems aufrufen. Vielleicht solltest du mal versuchen, wenn ein & im String ist, es für die Anzeige mit einen && zu ersetzen. :gruebel:

Gruß,

HomerGER 21. Apr 2004 13:59

Re: Wo ist das &-Zeichen geblieben
 
hallo
ich lese aus der registry aus!!!

soll ich nach & suchen und dann gegen && austauschen ???

Akut-Programming 21. Apr 2004 14:00

Re: Wo ist das &-Zeichen geblieben
 
Zitat:

Zitat von HomerGER
soll ich nach & suchen und dann gegen && austauschen ???

So zumindest der Vorschlag von Mirage und mir! :zwinker: Kannst es ja mal versuchen, ich denk schon, das es daran liegt. :angle2:

Gruß,

Phoenix 21. Apr 2004 14:00

Re: Wo ist das &-Zeichen geblieben
 
Wenn Du das dann anzeigen willst: Ja.

HomerGER 21. Apr 2004 14:06

Re: Wo ist das &-Zeichen geblieben
 
wenn ich in die registry schreiben will dann auch?

Akut-Programming 21. Apr 2004 14:09

Re: Wo ist das &-Zeichen geblieben
 
Nein dann nicht, du musst es nur beim anzeigen machen!!

HomerGER 21. Apr 2004 14:11

Re: Wo ist das &-Zeichen geblieben
 
dann noch mal für mich doofen
wenn in mit dem wert in meinem orgramm arbeite (vergleiche usw) dann nicht !?
wenn ich den wert aber zur anzeige bringe willl dann austauschen?

Pseudemys Nelsoni 21. Apr 2004 14:15

Re: Wo ist das &-Zeichen geblieben
 
beim prüfen brauchst du es nicht, nur beim anzeigen, z.b wenn du es einem button(caption) etc zuweist. Ein & in einer caption wird durch _ unter dem buchstabe ersetzt, um das & darzustellen musst du 2 davon verwenden, also &&. Wenn du ein "&" mit unterstrich haben möchtest musst du sogar 3 verwenden, also &&&.(wers brauch). zum schreiben in die registry brauchst du es nicht, zum lesen auch nicht, halt nur zum anzeigen wie showmessage usw...


Alle Zeitangaben in WEZ +1. Es ist jetzt 05:44 Uhr.
Seite 1 von 2  1 2   

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf