Delphi-PRAXiS

Delphi-PRAXiS (https://www.delphipraxis.net/forum.php)
-   Cross-Platform-Entwicklung (https://www.delphipraxis.net/91-cross-platform-entwicklung/)
-   -   Für MACOS 12 und MacMini M1 kompilieren - Linkerfehler (https://www.delphipraxis.net/209460-fuer-macos-12-und-macmini-m1-kompilieren-linkerfehler.html)

Harry Stahl 9. Dez 2021 19:04

Für MACOS 12 und MacMini M1 kompilieren - Linkerfehler
 
Ich habe mir nun einen MacMini mit M1 Prozessor besorgt und wollte eine Binary erstellen.

Habe also ein neues SDK (Montery 12) angelegt und ein Verbindungsprofil für den MacMini erstellt und den lokalen SDK-Zwischenspeicher aktualisiert.

Erhalte aber den Fehler: [dccosxarm64 Fehler] E2597 ld: warning: directory not found for option '-LC:\Users\Harry-Dev\Documents\Embarcadero\Studio\22.0\Imports'
ld: missing required architecture arm64 in file C:\Users\Harry-Dev\Documents\Embarcadero\Studio\SDKs\MacOSX10.14. sdk\System\Library\Frameworks/CoreFoundation.framework/Versions\A\CoreFoundation (1 slices)

Der Ordner

C:\Users\Harry-Dev\Documents\Embarcadero\Studio\SDKs\MacOSX12.0.s dk\System\Library\Frameworks\CoreFoundation.framew ork\Versions\A

existiert auf meiner Entwicklungsmaschine. Aber warum verweist Delphi noch auf das 10.14 SDK, das ich bislang mit meinem iMac verwendet habe. Wo kann ich das anpassen?

Harry Stahl 9. Dez 2021 22:22

AW: Für MACOS 12 und MacMini M1 kompilieren - Linkerfehler
 
OK, man musste natürlich auch das andere Verbindungsprofil wählen...

Compilieren geht jetzt aber jetzt der folgende Fehler:

--put="libFoxitQPL1811-osx-x64.dylib,\Contents\MacOS\,0,libFoxitQPL1811-osx-x64.dylib" Monterey
[PAClient Fehler] Fehler: E0006 Das Kopieren von Dateien in ein Verzeichnis außerhalb von '/Users/harrystahl/PAServer/scratch-dir/Harry-Dev-Monterey/' ist nicht zulässig; PAServer wird im eingeschränkten Modus ausgeführt

OK, ich kann die dyliLib dann manuell in den MacOS Ordner kopieren.

Programm startet auch (yeah, meine erste ARM-App), allerdings geht wohl kein Mix aus Arm-App und Intel Dylib.
Schade. Muss ich halt warten, bis es eine arm-dylib von quickpdf gibt oder ich steige doch auf die Source-Version um...

Rollo62 10. Dez 2021 18:10

AW: Für MACOS 12 und MacMini M1 kompilieren - Linkerfehler
 
Zitat:

Zitat von Harry Stahl (Beitrag 1498874)
.. allerdings geht wohl kein Mix aus Arm-App und Intel Dylib.

Das wäre aber auch zu schön um wahr zu sein, wenn noch nicht mal Intel 32 Bit DLL mit Intel 64 Bit DLL läuft :stupid:


Alle Zeitangaben in WEZ +1. Es ist jetzt 11:26 Uhr.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf