AGB  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Delphi Tabelle existiert nicht

Tabelle existiert nicht

Ein Thema von Delbor · begonnen am 20. Mär 2017 · letzter Beitrag vom 24. Mär 2017
Antwort Antwort
Seite 4 von 4   « Erste     234
Jumpy
Online

Registriert seit: 9. Dez 2010
Ort: Mönchengladbach
1.313 Beiträge
 
Delphi 6 Enterprise
 
#31

AW: Tabelle existiert nicht

  Alt 24. Mär 2017, 07:59
[OT]
Zitat:
"though"(Gedanke,Idee).
"though" ist in dem Zusammenhang aber eher mit "trotz" oder "obwohl" zu übersetzen. Dann wird der Satz für dich vllt. auch klarer.

Gedanke/Idee dagegen ist eigentlich "thought", also noch ein t hinten dran.
[/OT]
Ralph
  Mit Zitat antworten Zitat
Delbor

Registriert seit: 8. Okt 2006
Ort: St.Gallen/Schweiz
317 Beiträge
 
Delphi XE8 Enterprise
 
#32

AW: Tabelle existiert nicht

  Alt 24. Mär 2017, 15:24
Hi Jumpi

Danke für die Übersetzungshilfe. So wie ich das sehe, bestätigt mir das: die Tabellen sind zwar da, können vom Server aber nicht gelesen werden.

Gruss
Delbor
Roger
Was wäre das Leben ohne Delphi ?
http://roase.ch
http://delbor.ch
  Mit Zitat antworten Zitat
Jumpy
Online

Registriert seit: 9. Dez 2010
Ort: Mönchengladbach
1.313 Beiträge
 
Delphi 6 Enterprise
 
#33

AW: Tabelle existiert nicht

  Alt 24. Mär 2017, 15:57
Die Tabellen sind in dem Sinne da (zumindest nach deinem Error-Log) als das die Tabellendatei .frm da ist, aber im Data-Dictionary der Datenbank ist kein Hinweis darauf zu finden.

Vielleicht kannst du als erstes die Datei erstmal entfernen (umbenennen) dann eine gleich Aufgebaute leere Tabelle mit dem entsprechenden Namen neu erzeugen (über irgenein Datanbank-Tool). Anschließend die Dabei generierte .frm datei mit der alten Version austauschen.
Wichtig dabei, das Create Statement muss genau den Aufbau der alten Datei/Tabelle wieder spiegeln.
Ralph
  Mit Zitat antworten Zitat
Delbor

Registriert seit: 8. Okt 2006
Ort: St.Gallen/Schweiz
317 Beiträge
 
Delphi XE8 Enterprise
 
#34

AW: Tabelle existiert nicht

  Alt 24. Mär 2017, 20:35
Hi Jumpy

Es gab zwei Möglichkeiten für mich, vorzugehen: MySQL zu deinstallieren und erneut im Verzeichnis F\: Database 1 zu instalieren (anstelle von C\: Programme). Damit hätte ich den Server auf einer Platte, die zumindest zur Zeit gross genug ist. Ich hab mich aber jetzt dazu entschieden, diee Tabellen meiner bisherigen DB zu löschen (und vorher sicherheitshalber den Server herunterzufahren). Anschliessend soll die DB anhand meines Workbench-Modells neu erstellt werden. Die Syntax wäre dieselbe.

Gruss
Delbor
Roger
Was wäre das Leben ohne Delphi ?
http://roase.ch
http://delbor.ch

Geändert von Delbor (24. Mär 2017 um 20:41 Uhr)
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 09:51 Uhr.
Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2017 by Daniel R. Wolf