AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Color von TLabel funktioniert nicht

Ein Thema von KPBecker · begonnen am 19. Nov 2007 · letzter Beitrag vom 19. Nov 2007
Antwort Antwort
KPBecker

Registriert seit: 1. Mär 2004
Ort: Mannheim
120 Beiträge
 
Delphi 2010 Architect
 
#1

Color von TLabel funktioniert nicht

  Alt 19. Nov 2007, 15:44
Hallo, Delphi-Praktiker,

auf einem ganz normalen Formular habe ich ein ganz normales Label gesetzt.

Problem:
Die Eigenschaft 'Color' im Objekt-Manager hat überhaupt keine Auswirkung auf die Farbe des Labels, weder zur Entwurfs- noch zur Laufzeit. Auch das Setzen beim Programmlauf ändert nichts.

Color (Font) funktioniert: Der Text ist farbig.

Ich möchte eigentlich den Hintergrund des ganzen Labels einfärben. Wo ist der Fehler ?

(Version: Delphi 2007)

Beste Grüße,
Klaus-Peter
  Mit Zitat antworten Zitat
Benutzerbild von leddl
leddl

Registriert seit: 13. Okt 2003
Ort: Künzelsau
1.613 Beiträge
 
Delphi 2006 Professional
 
#2

Re: Color von TLabel funktioniert nicht

  Alt 19. Nov 2007, 15:46
Transparent auf True?
Oder vielleicht auch ParentColor auf True?
Axel Sefranek
A programmer started to cuss, cause getting to sleep was a fuss.
As he lay there in bed, looping round in his head
was: while(!asleep()) ++sheep;
  Mit Zitat antworten Zitat
Benutzerbild von Deep-Sea
Deep-Sea

Registriert seit: 17. Jan 2007
907 Beiträge
 
Delphi XE2 Professional
 
#3

Re: Color von TLabel funktioniert nicht

  Alt 19. Nov 2007, 15:47
Die Eigenschaft Transparent muss auf False stehen.
* blubb *

PS: Wenn man Color ändert, wird ParentColor automatisch auf False gesetzt
Chris
  Mit Zitat antworten Zitat
Hawkeye219

Registriert seit: 18. Feb 2006
Ort: Stolberg
2.227 Beiträge
 
Delphi 2010 Professional
 
#4

Re: Color von TLabel funktioniert nicht

  Alt 19. Nov 2007, 16:12
Hallo,

das einmalige Setzen von TLabel.Transparent im Objektinspektor reicht leider nicht aus. Ohne Programmcode geht es, wenn man die Eigenschaft zunächst auf den Wert True stellt und anschließend wieder auf den Wert False. Dadurch zwingt man Delphi, den notwendigen Wert in die Formulardatei zu schreiben.

Gruß Hawkeye
  Mit Zitat antworten Zitat
KPBecker

Registriert seit: 1. Mär 2004
Ort: Mannheim
120 Beiträge
 
Delphi 2010 Architect
 
#5

Re: Color von TLabel funktioniert nicht

  Alt 19. Nov 2007, 16:23
Vielen Dank,

Transparent:= true war der Schlüssel zum Erfolg !

Klaus-Peter
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 04:32 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf