AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Vista Manifest

Ein Thema von Xzeer · begonnen am 29. Mär 2008 · letzter Beitrag vom 4. Apr 2008
Antwort Antwort
Seite 1 von 2  1 2   
Benutzerbild von Xzeer
Xzeer

Registriert seit: 6. Jul 2007
106 Beiträge
 
#1

Vista Manifest

  Alt 29. Mär 2008, 12:49
Hallo,

Ich habe ein Problem damit, meine Anwendung unter Vista mit Adminrechten zu starten. Ich bin wie folgt vorgegangen:

1.) Habe die XML Manifestdatei erstellt
Zitat:
<?xml version=1.0" encoding="UTF-8" standalone="yes"?>
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
<assemblyIdentity version="1.0.0.0"
processorArchitecture="x86"
name="Leos Studio Anwendung"
type="win32"/>

<trustInfo xmlns="urn:schemas-microsoft-com:asm.v2">
<security>
<requestedPrivileges>
<requestedExecutionLevel
level="requireAdministrator"
uiAccess="false"/>
</requestedPrivileges>
</security>
</trustInfo>

<dependency>
<dependentAssembly>
<assemblyIdentity version="6.0.0.0"
processorArchitecture="*"
name="Microsoft.Windows.Common-Controls"
type="win32"
publicKeyToken="6595b64144ccf1df"
language="*"
/>
</dependentAssembly>
</dependency>

</assembly>
2.) Habe diesen Einzeiler Befehl in eine *.rc datei geschrieben:
Zitat:
1 24 "adman.xml"
3.) Habe beide Dateien in des bin Ordner von Delphi kopiert

4.) Haben den Ressourchen Compiler über die CDM Ausgeführt -> Bild im Anhang
Zitat:
brcc32 -v adman.rc -foadman.res | mit brcc32 -v adman.rc -fo adman.res gehts auch nicht
Immer bekomme ich von diesem Compiler eine Fehlermeldung. Warum geht das nicht????
Miniaturansicht angehängter Grafiken
cmderror_210.jpg  
Marvin
Xzeer
  Mit Zitat antworten Zitat
Benutzerbild von RWarnecke
RWarnecke

Registriert seit: 31. Dez 2004
Ort: Stuttgart
4.408 Beiträge
 
Delphi XE8 Enterprise
 
#2

Re: Vista Manifest

  Alt 29. Mär 2008, 13:04
Sieht Deine XML-Datei genau so aus, wie Du es hier geschrieben hast ? Wenn ja, dann probiere es doch mal so :
Code:
<?xml version=1.0" encoding="UTF-8" standalone="yes"?>
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
<assemblyIdentity version="1.0.0.0" processorArchitecture="x86" name="Leos Studio Anwendung" type="win32"/>
  <trustInfo xmlns="urn:schemas-microsoft-com:asm.v2">
    <security>
      <requestedPrivileges>
        <requestedExecutionLevel level="requireAdministrator" uiAccess="false"/>
      </requestedPrivileges>
    </security>
  </trustInfo>
  <dependency>
    <dependentAssembly>
      <assemblyIdentity version="6.0.0.0" processorArchitecture="*" name="Microsoft.Windows.Common-Controls" type="win32" publicKeyToken="6595b64144ccf1df" language="*"/>
    </dependentAssembly>
  </dependency>
</assembly>
Edit :
Und benutzer für alle Dateien den gleichen Namen, bis auf die Endung.
Rolf Warnecke
App4Mission
  Mit Zitat antworten Zitat
Benutzerbild von Xzeer
Xzeer

Registriert seit: 6. Jul 2007
106 Beiträge
 
#3

Re: Vista Manifest

  Alt 29. Mär 2008, 13:23
immer noch der gleiche Fehler und die dateien heißen schon alle gleich.

Also:
adman.xml -> das manifest
adman.rc -> der Einzeiler
und adman.res möchte ich über die cmd mit dem compiler erstellen

Müsste doch klappen, oder???
Marvin
Xzeer
  Mit Zitat antworten Zitat
Benutzerbild von RWarnecke
RWarnecke

Registriert seit: 31. Dez 2004
Ort: Stuttgart
4.408 Beiträge
 
Delphi XE8 Enterprise
 
#4

Re: Vista Manifest

  Alt 29. Mär 2008, 13:32
Zitat von Leos-Studio:
immer noch der gleiche Fehler und die dateien heißen schon alle gleich.

Also:
adman.xml -> das manifest
adman.rc -&gt; der Einzeiler
und adman.res möchte ich über die cmd mit dem compiler erstellen

Müsste doch klappen, oder???
Rein theoretisch ja. Probiere doch mal die angehängten Dateien im ZIP-File aus.
Angehängte Dateien
Dateityp: zip res_170.zip (677 Bytes, 19x aufgerufen)
Rolf Warnecke
App4Mission
  Mit Zitat antworten Zitat
Benutzerbild von TheMiller
TheMiller

Registriert seit: 19. Mai 2003
Ort: Gründau
2.480 Beiträge
 
Delphi XE7 Architect
 
#5

Re: Vista Manifest

  Alt 29. Mär 2008, 13:45
Moin!

Schau mal hier:

Vista Manifest-Tutorial
  Mit Zitat antworten Zitat
Benutzerbild von Xzeer
Xzeer

Registriert seit: 6. Jul 2007
106 Beiträge
 
#6

Re: Vista Manifest

  Alt 31. Mär 2008, 19:49
Zitat von RWarnecke:
Zitat von Leos-Studio:
immer noch der gleiche Fehler und die dateien heißen schon alle gleich.

Also:
adman.xml -> das manifest
adman.rc -&gt; der Einzeiler
und adman.res möchte ich über die cmd mit dem compiler erstellen

Müsste doch klappen, oder???
Rein theoretisch ja. Probiere doch mal die angehängten Dateien im ZIP-File aus.
super, die klappen problemlos....

vielen dank...
Marvin
Xzeer
  Mit Zitat antworten Zitat
Benutzerbild von Xzeer
Xzeer

Registriert seit: 6. Jul 2007
106 Beiträge
 
#7

Re: Vista Manifest

  Alt 31. Mär 2008, 20:40
öhm doch ein fehler...

also mein vorgehen:

1.) die dateien SystemInfo.exe.manifest und SystemInfo.rc ausgepackt
2.) mit dem compiler die SystemInfo.res erzeugt
3.) eine neue anwendung erstellt und die 3 dateien in den gleichen ordner gelegt
4.) die SystemInfo.res in die Anwendung eingebunden

Delphi-Quellcode:
[...]
implementation

{$R *.dfm}
{$R SystemInfo.res}

end.
[...]
Jetzt bekomme ich beim copilieren einen fehler gemeldet -> Bild

Was ist jetzt scheon wieder falsch???
Miniaturansicht angehängter Grafiken
fehler_319.jpg  
Marvin
Xzeer
  Mit Zitat antworten Zitat
Benutzerbild von RWarnecke
RWarnecke

Registriert seit: 31. Dez 2004
Ort: Stuttgart
4.408 Beiträge
 
Delphi XE8 Enterprise
 
#8

Re: Vista Manifest

  Alt 31. Mär 2008, 20:51
Ich habe nicht beide RES-Dateien im gleichen Pfad liegen. Ich binde meine mit {$R .\res\SystemInfo.res} ein.
Rolf Warnecke
App4Mission
  Mit Zitat antworten Zitat
Benutzerbild von Xzeer
Xzeer

Registriert seit: 6. Jul 2007
106 Beiträge
 
#9

Re: Vista Manifest

  Alt 31. Mär 2008, 21:07
bekomme ich den gleichen fehler...

ich hab einfach die systeminfo.res in einen unterornder "res" der anwendung gelegt
Marvin
Xzeer
  Mit Zitat antworten Zitat
Benutzerbild von RWarnecke
RWarnecke

Registriert seit: 31. Dez 2004
Ort: Stuttgart
4.408 Beiträge
 
Delphi XE8 Enterprise
 
#10

Re: Vista Manifest

  Alt 31. Mär 2008, 22:20
Zitat:
4. Wenn das Manifest "nicht funktioniert"

Ist das Manifest nach den oberen Schritten eingebunden worden und die UAC wird NICHT geladen, ist die Hauptursache das Vorhandensein des Windows-XP-Manifests - WindowsXP und WindowsVista Manifests dürfen nicht kombiniert werden! Es ist vielmehr so, dass das Vista-Manifest alles Erforderliche des WindowsXP-Manifests enthält und die Vista-spezifischen Anweisungen von Windows XP ignoriert werden.

Also auf allen Formularen die XP-Man Komponente entfernen UND aus allen Units des Projekts die dazugehörige Unit XPMan entfernen. Danach das Projekt neu kompilieren und dann sollte es funktionieren!
Hast Du diese Dinge aus dem Tutorial von DJ-SPM beachtet ?
Rolf Warnecke
App4Mission
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 04:42 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf