AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Sprachen und Entwicklungsumgebungen Die Delphi-IDE Probleme mit Indy10 installation/update

Probleme mit Indy10 installation/update

Ein Thema von gsh · begonnen am 20. Mai 2008 · letzter Beitrag vom 9. Feb 2016
Antwort Antwort
Seite 1 von 2  1 2   
Benutzerbild von gsh
gsh

Registriert seit: 24. Okt 2004
1.542 Beiträge
 
Delphi XE Architect
 
#1

Probleme mit Indy10 installation/update

  Alt 20. Mai 2008, 17:37
Hi Leute

Ich hoffe ich bin der richtigen Spalte ... die Entscheidung war nicht leicht.

Also ich hab ein Problem mit den Indys und zwar möchte ich sie updaten (ich hoffe die speicherleaks und probleme werden dadurch weniger). Das hab ich jetzt schon drei mal probiert jedesmal musste ich mein delphi neuinstallieren weil nichts mehr funktionierte.

1) Wo soll ich die dateien eigentlich reinkopieren?
Lib oder Source?

2) bzw. welche Dateien soll/kann/muss ich löschen damit wirklich die neue Version genutzt wird?

3) Wenn ich die das System Packete installieren will dann kommt folgende Fehlermeldung:
Package C:\Dokumente und Einstellungen\alex\Eigene Dateien\Borland Studio-Projekte\Bpl\IndySystem100.bpl kann nicht installiert werden, da es kein Entwurfszeit-Package ist.

Ich hab alle anderen Packte davor kompiliert!

4) Gibt es vllt. eine bessere Anleitung als diese: http://www.indyproject.org/Sockets/D...lation.DE.aspx

Kann mir jemand weiterhelfen?
Alex
"Sage nicht alles, was du weißt, aber wisse alles, was du sagst!" Matthias Claudius
"Wer sich über Kritik ärgert, gibt zu, daß er sie verdient hat." Tacitus
  Mit Zitat antworten Zitat
Benutzerbild von Die Muhkuh
Die Muhkuh

Registriert seit: 21. Aug 2003
7.332 Beiträge
 
Delphi 2009 Professional
 
#2

Re: Probleme mit Indy10 installation/update

  Alt 20. Mai 2008, 17:48
Hi,

1) Ist egal wohin. Du kannst die auch "weiß Gott wohin" legen, musst nur den Such- bzw. den Bibliothekspfad richtig setzen.

2) Du kannst komplett die alten Indy 10 Dateien löschen.

3) RunTime-Packages kannst Du auch nicht installieren, nur kompilieren. Das ist kein Fehler im eigentlichen Sinne, mehr nur ein Hinweis, dass Du keine Laufzeit-Packages installieren kannst.

4) Da steht doch alles drin?

Da steht übrigens nicht, dass Du das System-Package installieren sollst
  Mit Zitat antworten Zitat
Benutzerbild von MSSSSM
MSSSSM

Registriert seit: 18. Apr 2008
223 Beiträge
 
Delphi 7 Professional
 
#3

Re: Probleme mit Indy10 installation/update

  Alt 20. Mai 2008, 18:09
nimm automatic-installation von atozed, auch da zu finden..
mfg
Marius
  Mit Zitat antworten Zitat
Benutzerbild von gsh
gsh

Registriert seit: 24. Okt 2004
1.542 Beiträge
 
Delphi XE Architect
 
#4

Re: Probleme mit Indy10 installation/update

  Alt 20. Mai 2008, 18:11
1) naja ich hab vorallem gemeint wo ist es den am besten aufgehoben das ich am besten keine pfade anpassen muss

2) ja ok und welche dateien sind das alles? alle die mit Id anfangen?

3) aso ok aber die dcl Package kann ich auch nicht installieren. Beim Packet dclIndyCore100.dpk kommt folgende Meldung:
Der Prozedureinsprungpunkt "@Idglobal@IndyStrToInt$qqrx17System@AnsiStrin gi" wurde in der DLL "IndySystem100.bpl" nicht gefunden.
Alex
"Sage nicht alles, was du weißt, aber wisse alles, was du sagst!" Matthias Claudius
"Wer sich über Kritik ärgert, gibt zu, daß er sie verdient hat." Tacitus
  Mit Zitat antworten Zitat
Benutzerbild von gsh
gsh

Registriert seit: 24. Okt 2004
1.542 Beiträge
 
Delphi XE Architect
 
#5

Re: Probleme mit Indy10 installation/update

  Alt 20. Mai 2008, 19:14
Zitat von MSSSSM:
nimm automatic-installation von atozed, auch da zu finden..
mfg
meinst du den da http://www.atozed.com/indy/Plus/install.DE.aspx
den gibt es nicht für delphi 2006
Alex
"Sage nicht alles, was du weißt, aber wisse alles, was du sagst!" Matthias Claudius
"Wer sich über Kritik ärgert, gibt zu, daß er sie verdient hat." Tacitus
  Mit Zitat antworten Zitat
Benutzerbild von gsh
gsh

Registriert seit: 24. Okt 2004
1.542 Beiträge
 
Delphi XE Architect
 
#6

Re: Probleme mit Indy10 installation/update

  Alt 21. Mai 2008, 11:59
*kleiner push*
Alex
"Sage nicht alles, was du weißt, aber wisse alles, was du sagst!" Matthias Claudius
"Wer sich über Kritik ärgert, gibt zu, daß er sie verdient hat." Tacitus
  Mit Zitat antworten Zitat
Benutzerbild von gsh
gsh

Registriert seit: 24. Okt 2004
1.542 Beiträge
 
Delphi XE Architect
 
#7

Re: Probleme mit Indy10 installation/update

  Alt 28. Mai 2008, 14:17
soo da bin ich wieder ...
ich habe bis jetzt noch immer keine Lösung gefunden. Noch einer eine Idee?
Alex
"Sage nicht alles, was du weißt, aber wisse alles, was du sagst!" Matthias Claudius
"Wer sich über Kritik ärgert, gibt zu, daß er sie verdient hat." Tacitus
  Mit Zitat antworten Zitat
Benutzerbild von Assertor
Assertor

Registriert seit: 4. Feb 2006
Ort: Hamburg
1.296 Beiträge
 
Delphi 10 Seattle Enterprise
 
#8

Re: Probleme mit Indy10 installation/update

  Alt 28. Mai 2008, 15:09
Hi gsh,

ui, da hast Du Dir aber was eingebrockt Ganz schön viel durcheinander. Dadurch das verschiedene Versionen von Packages geladen werden, knallt es natürlich bei Dir...

Am einfachste für Dich wäre jetzt:
- Delphi Deinstallieren
- Prüfen, ob wirklich alle Delphi Verzeichnisse entfernt wurden, sonst manuell löschen (achte auf den Borland Shared Ordner)
- Alle Packages unter den "Eigenen Dateien\Borland Studio-Projekte\BPL" löschen
- Delphi OHNE Indy neuinstallieren (wirst ja beim Setup gefragt, noch vor der Seite wo Du zwischen Indy9/Indy10 wählen kannst)

- Den Indy DevSnapshot in ein eigenen Verzeichnis entpacken
- Die Packages in der bereits ohnen verlinkten/angegeben Reihenfolge installieren
- In den Delphi Optionen die Verzeichnisse System/Core/Protocols deines Indy Verzeichnisses in den Suchpfad aufnehmen

Am einfachsten für geübte Indy-Nutzer/Entwickler:
- Manuell alle Indy Dateien aus Lib/Source/Debug löschen
- Alle Indy BPLs entfernen unter "Eigenen Dateien\Borland Studio-Projekte\BPL", aber auch in den Borland Verzeichnissen - da stecken nämlich die Installations-BPLs wenn man Indy mitinstalliert
- Delphi IDE starten und fehlerhafte BPLs mit "nicht mehr laden" bestätigen
- Delphi IDE schließen
- Indy DevSnapshot in eigenes Verzeichnis entpacken
- Die Indy Packages gemäß der oben verlinkten Anleitung/Reihenfolge installieren
- Neue Indy-Verzeichnisse System/Core/Protocols in den Suchpfad aufnehmen

Beides "getestet" - bzw. habe selbst die schmerzliche Update-Erfahrung einmal machen müssen. Das hat aber nichts mit Indy zu tun, würde dir bei manch anderer Komponente/Package genauso ergehen.

Gruß Assertor
Frederik
  Mit Zitat antworten Zitat
Benutzerbild von gsh
gsh

Registriert seit: 24. Okt 2004
1.542 Beiträge
 
Delphi XE Architect
 
#9

Re: Probleme mit Indy10 installation/update

  Alt 28. Mai 2008, 17:56
cool danke für die Anleitung
sobald ich Zeit finde und daheim bin werde ich es gleich ausprobieren
Alex
"Sage nicht alles, was du weißt, aber wisse alles, was du sagst!" Matthias Claudius
"Wer sich über Kritik ärgert, gibt zu, daß er sie verdient hat." Tacitus
  Mit Zitat antworten Zitat
Benutzerbild von gsh
gsh

Registriert seit: 24. Okt 2004
1.542 Beiträge
 
Delphi XE Architect
 
#10

Re: Probleme mit Indy10 installation/update

  Alt 31. Mai 2008, 00:40
super hat alles wunderbar hinghauen bis auf eins:
Er erkennt TBytes nicht mehr ... sind die mit der neuen Version raus?

procedure TThread_UDP.UDPServerUDPRead(Sender: TObject; AData: TBytes; ABinding: TIdSocketHandle);

[Pascal Fehler] T_UDP.pas(19): E2003 Undefinierter Bezeichner: 'TBytes'
Alex
"Sage nicht alles, was du weißt, aber wisse alles, was du sagst!" Matthias Claudius
"Wer sich über Kritik ärgert, gibt zu, daß er sie verdient hat." Tacitus
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 2  1 2   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 22:55 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf